Manjaro becomes slow after few hours.

I used to run Ubuntu, then i decided to install Manjaro XFCE.
Mostly becouze i read that Manjaro XFCE runs better.

But i am running into problems i don’t use to have before.
I have googled, but can’t find much about it:

I have 2 problems:
1.My laptop runs slower after a hour of use, everything becomes sluggish. Openings browser and small apps happen very slowely and sometimes things get a bit stuck
(In taskmanager the cpu and ram usage is low, so can’t find a reason )

  1. Internet sometimes stops working, still connected to Wi-Fi. But it doesn’t load pages.

As i said i googled the problems before, i have seen poeple asking for specs: So here are my specs:

Host: pakos-hppaviliong7notebookpc Kernel: 5.9.16-1-MANJARO x86_64
bits: 64 Desktop: Xfce 4.16.0 Distro: Manjaro Linux
Type: Laptop System: Hewlett-Packard product: HP Pavilion G7 Notebook PC
v: 0593110000204610000620100 serial: CNF1260PFG
Mobo: Hewlett-Packard model: 1672 v: 09.24 serial: PCEKV111Z0A02M
BIOS: Hewlett-Packard v: F.12_M1 date: 04/08/2011
Info: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP
L2 cache: 3 MiB
Speed: 1049 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 1049 2: 1229
3: 896 4: 798
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
driver: i915 v: kernel
Device-2: AMD Seymour [Radeon HD 6400M/7400M Series] driver: radeon
v: kernel
Device-3: Chicony HP Integrated Webcam type: USB driver: uvcvideo
Display: server: x . Org 1.20.10 driver: loaded: ati,intel,radeon
unloaded: modesetting resolution: 1600x900~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
v: 3.3 Mesa 20.3.3
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.9.16-1-MANJARO
Device-1: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi
IF: wlo1 state: up mac: 8c:a9:82:72:e0:86
Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
IF: eno1 state: down mac: 2c:27:d7:c4:66:70
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Local Storage: total: 465.76 GiB used: 257.43 GiB (55.3%)
ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
ID-1: / size: 47.81 GiB used: 10.66 GiB (22.3%) fs: ext4 dev: /dev/sda1
ID-2: /boot size: 511 MiB used: 58.6 MiB (11.5%) fs: vfat dev: /dev/sda4
ID-3: /home size: 47.81 GiB used: 5.46 GiB (11.4%) fs: ext4 dev: /dev/sda2
ID-1: swap-1 type: partition size: 9.77 GiB used: 0 KiB (0.0%)
dev: /dev/sda3
System Temperatures: cpu: 76.0 C mobo: N/A gpu: radeon temp: 67.0 C
Fan Speeds (RPM): N/A
Processes: 228 Uptime: 24m Memory: 5.75 GiB used: 2.73 GiB (47.4%)
Shell: Bash inxi: 3.2.02

That could be a reason I guess.

That’s weird, i don’t know what to say about that.
I have opened up my laptop 12 months ago to clean the dust, and even redo the heatsink installation with new thermal compound… (artic-mx-4.)

I am going to look into this a bit more…
These old laptops from hp, are known to have bad cooling.

Some suggestions where to look.

Check for error messages written to the journal, x-org log, and if there are any core dumps:

journalctl -b0 -p err
less /var/log/Xorg.0.log

Start a monitor (any noticeable cpu hogs)

# or

Some folks have found a solution by deleting session cache. I had some weirdness and just deleted everything under .cache. You might want to go to Settings Manager > Session and Startup > Current Session and remove any saved sessions.

rm -rf ~/.cache/sessions

So before i take apart the laptop to clean the dust…

Can you guyz atleast help me fix the sudden slow internet speed / totally not loading pages at all issue. (which by the way is totally unrelated to my heating issue)


Laptop is really unusable this way, still need help with my Internet.

If you use Firefox, give us:

grep -oP '},"name":"\K[^"]+' ~/.mozilla/firefox/*.*default*/addons.json

In addition, did you activate webrender ?

Anyhow, if your PC is on fire, it won’t run faster with a soft optimization…

Not using Firefox, so no i did not activate webrender.

As i mentioned before, i am currently working on the heat issue…

But i need a fix for the slow internet. I can assure you, that the slow internet behavior has nothing to do with the heating issue.


I remember now having the same issue back then when i started using ubuntu.
I had to disable the “n” at the end of “wifi 802.11”… Becouze that was couzing a bug.

I have no idea how to disable that in Manjaro…

That may be the problem :stuck_out_tongue_winking_eye:

So happy i left this distro…
You know what should be illegal? This distro!!

I have no idea how you guyz can claim that this distro is userfriendly.
The amount of headaches i got… And the support is near sh*t!!!

That’s not supported - maybe try the linux54 LTS kernel instead, also have a go with the newest kernel (5.10.15-1) which is linux510.

Also be sure your laptop isn’t clogged with fluff - it’s warm enough, I think, to be unhappy.