Manjaro asks for the wifi password over and over

I know this question has been asked multiple times, but I have tried all solutions, and they don’t work for me.
Manjaro asks for the wifi password repeatedly, but never connects.
This happens regardless of the desktop environment (I tried XFCE, KDE and GNOME) or if it is a live usb or fresh install.
PC: Thinkpad 14s AMD gen1
OS: Manjaro Ornara 21.07
Kernel: 5.10
Open source drivers

I can’t test other kernels because I would require wifi to download them.
Thanks for your help.

srry for bad english.

Im pretty new to linux, if you need anything please tell me.

sudo nano /etc/conf.d/wireless-regdom

uncomment(remove #) your country code

reboot, try wireless again

will try this

That didn’t work, no diference, but thanks for your time.

have you tried restarting your router

yes I have

Are you sure that you’re typing the correct wifi password?

Did you save the file? Because if you strictly follow what you replied to, you didn’t.

yes, im sure its the correct one, and yes, I checked.

Maybe your router uses a configuration or security that blocks Manjaro connection? out of thin air I would guess MAC filtering?

Find an ethernet cable and connect directly to the router, and connect to the router interface from web browser to check it out.

also if could tell us what desktop you currently have installed, it’ll be easier to give you correct instructions.

Try typing in your password in text document - then copy the pass and paste it into the wifi dialog.

This could - in theory - be a driver issue - even the passwd is correct - if the connection cannot be made the credential is not saved.

To get an idea of what wifi card is connected to your system - copy the text result from below commands

PCI connected

lspci | grep net

USB connected (internal/external)


Im using xfce.
will try all this later in the day, as I am really busy.
thanks for all your time, its really apreciated.