Manjaro ARM update failed, "brcm-patchram-plus" and "pi-bluetooth" conflicting

I hadn’t updated Manjaro ARM on Raspberry Pi4 8GB for about 10 weeks, and I received an error when I tried to update yesterday…

Failed to prepare transaction

conflicting dependencies:

  • brcm-patchram-plus and pi-bluetooth are in conflict

I had a look on and found this post…

in the post, @Darksky mentioned…

"In the future images brcm-patchram-plus will be the default …"

so I’m wondering can I just ignore “pi-bluetooth” during update? then can I just leave “pi-bluetooth” as it is, or is it better to uninstall it to prevent future conflicts?

I’m not sure what to do. Any advice would be appreciated. Thanks.

“pi-bluetooth” has an issue with having a scratchy sound with bluetooth headphones. You need to go with brcm-patchram-plus.

First install brcm-patchram-plus before updating your system:

sudo systemctl disable brcm43438.service
sudo pacman -S -dd brcm-patchram-plus firmware-raspberrypi
sudo systemctl enable attach-bluetooth.service

Then update your system:

sudo pacman -Syu
sudo reboot

thanks @Darksky for your quick reply, I followed your instructions and now up to date :ok_hand:

your instructions were very clear. the commands were not something I would have been able to by myself, thanks again, much appreciated. This is a great user forum, and also a great distro for the RPi4. Many thanks to all the devs who work on it.

1 Like

I currently do not use bluetooth and I have it disabled via dtoverlay in config.txt

I noticed brcm_patchram_plus was installed via system updates, however it is a run-a-way process on my system, consuming 100% of a CPU. What is the proper way to disable it?

brcm-patchram-plus does not enable it’s self when installed. A kernel change will overwrite the config.txt. All brcm-patchram-plus does is patch the onboard chip with the firmware at boot. Possibly disabling in config.txt and trying to load bluetooth related services could be causing the issue trying to load it’s self.

sudo systemctl disable bluetooth.service
sudo systemctl disable attach-bluetooth.service

Disabling those two bluetooth services did the trick, thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.