Manjaro arm (or at least pinephone-phosh) is missing CPUIDLE

Megi has noticed that many distros are not building the kernel with sunxi cpuidle, making the battery life much worse. I checked on latest phosh release and indeed there is no cpuidle support.

$ sudo cpupower idle-info
[sudo] password for alarm:
CPUidle driver: none
CPUidle governor: menu
analyzing CPU 0:

CPU 0: No idle states

Is it really true that all this time we have been wasting the already poor battery life?

The linux-pinephone kernel does have CPUIDLE enabled.

See: config · 6.1-megi · manjaro-arm / packages / core / linux-pinephone · GitLab

But, our uboot package does indeed not build TF-A with SUNXI_AMEND_DTB=1.

You can add an issue about that here:

I don’t know tf-a nor how the uboot interacts with things, so maybe better someone else makes the issue?

Created the issue for you.

1 Like

thanks! interesting to see how big the difference is

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.