Manjaro arm on Amlogic Tv box?

@TheMojoMan same device model here, did you use your custom dtb files ? also how to use linux-vim, if you don’t bother explaining to me (I don’t even understand what it’s about –vim is a text editor to me hahahaha)

Hi @rna , I use both SD Card and USB Flash to boot GT King Pro. One important note to take is, in order to ensure GT King Pro not kernel panic with Manjaro-Arm, you must use “boot-vim3-2020.10-1” to boot up, else you will encounter kernel panic during large system update or some times randomly. I have shares what will cause kernel panic when using the older u-boot.ext previously. Advice is to install “boot-vim3-2020.10-1” first after you burn Manjaro image unless that image already uses “boot-vim3-2020.10-1”.

Second point is with “boot-vim3-2020.10-1” on GT King Pro, it better to use SD Card to boot as using USB Flash to boot you are limited to using USB OTG port on GT King Pro and with no other USB Flash or HDD connected to GT King Pro - SD Card do not have this limitation. Do read my earlier message on the new u-boot.ext booting experience. i don’t know how to link to my earlier message (sorry about this).

Great another fellow GT King Pro user. I suppose yours will be with wifi6. GT King Pro is well supported by Manjaro-Arm Team. Looking forward to your experience with GT King Pro.

Hi @TheMojoMan, Do you face any system freeze with linux-vim 5.11.2-1? I had 4 kernel panic/system freeze in two days on GT King Pro.

Thanks for this info. Yeah I read your very first post, until I reach post number 100, I gave up. The discussion is getting very long to read, therefore I ask you directly. After reading from many forums, I found that the kernel panic is the main problem for this box.

Yes, but unfortunately because of some technical problem, the seller cannot send the package and the order is cancelled. :frowning: Hopefully soon I could join the forces.

As long as you are using the “boot-vim3-2020.10-1” with GT King Pro it will work well with Manjaro-Arm and it works with linux or linux-vim kernel.

linux-vim is a package which contains a patched kernel that let you run Manjaro Arm on Khadas VIM single board computer and many TV boxes.

For instructions on how to getting started see here.


I did not observe any kernel panics, yet, but I must admit that I did not use my X96Max+ for longer periods of time since I updated.

Hello and welcome to the forum,

linux-vim was named as it was custom kernel used for Khadas VIM boards but I plan to rename it to linux-aml as it will me amlogic focused kernel.

install linux-vim
sudo pacman -Syyu linux-vim
This will ask you to remove the existing kernel so please say yes to it.

Which board are you using. @TheMojoMan Can we have a new thread where we add support to different boards ? Like the custom dts you have used. maybe we can try to add it to the kernel so users can use it directly without the need to compile much. This will need support from the community users who have good knowledge of dts editing etc. I will just add the dts to the pkg while users with the device have to test and report back.

If you think you have time to contribute to the Manjaro arm project then it will be helpful for other users which such devices.

Update: Not to forget that not all boards support is possible only those who can contribute to the project with the dts and also maintain its support, as it is nearly impossible to add support for all the random Chinese knock offs.

This kernel panic is something different and not the one from previous bootloader issue, I have seen some kernel panic on AMlogic S905X3 as well. Still did not get time to see what is causing it as I am not getting any logs posted on uart.


Using kodi-wayland-19.0-6-aarch64.pkg.tar.zst from archlinuxdroid repo it seems that hardware acceleration video decoding works, (using 20% of system) and playing is fluid, but its strange because it says it is software acceleration. (Using linux-vim 5.11.2-1 and manjaro with gnome)

1 Like

Thanks for the info. I understand this kernel panic I am experiencing with linux-vim 5.11.2-1 seems different from previously. Previous kernel panic I can repeatedly induce it.

Hi @TheMojoMan, thank you for your reply
Yes I did follow those instructions using KDE edition, but I’m considering using XFCE because KDE isn’t fluid on my X96Max+. Does KDE edition works smoothly on your device ?
I wanted to know, when using linux-vim, do you choose the vim version of your .dtb files ?

Hi @spikerguy thank you
I am using an X96Max+ 4Gb/64Gb but I don’t know if this is the information you’re asking about. Chipset is AmLogic S905X3.

@TheMojoMan I once managed to extract the .dtb file from the android system installed on the X96M+ and convert it back to .dts. But I don’t have any knowledge in this language and It didn’t work when I tried to boot Mjro with it. I can share it if you’re interested by analyzing it

OK noted.

That would be great if we have a new thread for X96 Max+, I think everything is almost perfect, except for Blutooth and Audio Jack.

For H96 Max RK3399 I have made the thread, but still merged with Rockchip Topic. Everything is running perfectly, except bluetooth. I am waiting a cavalry to help to fix this.

Maybe it can help someone with H96 Max RK3399, please refer to the link above.

As far as I know, android dtb is not working with mainline kernel. Unless there’s somebody that is skillfull to upgrade the code from kernel 4.9x to the mainline kernel. Therefore please stick with the @TheMojoMan dtb for X96 Max+.

In case you had a problem with booting after upgrade from linux-vim 20.12 to the latest stable release, I have backup of my boot partition and I can confirm that it works flawlessly without the problem that I mentioned above in discussion number 767. Here it is:

Based on my experience, sometimes an upgrade cause the box failed to boot. Therefore I would advise to make backup of the boot partition. In my case I make backup of the working unstable image. Therefore when it comes to the problem from stable release, I just need to restore my backup boot partition. Copy all files, except for “image” and “image.gz” use from your current update that failed to boot. With this workaround you will be able to boot to your box. I used @TheMojoMan method and his latest dtb for mainline but by box still cannot boot, until I came up with this workaround and the problem is solved event by using the old dtb. Just to let you know that I did this backup workaround on Armbian as well and my box never failed to boot.

This X96 Max+ box comes with three variants:

  • 2gb / 16gb
  • 4gb / 32gb
  • 4gb / 64gb

The device tree for 2gb/16gb and 4gb/64gb is different, I don’t know about the 4gb/32gb because mine is the 4gb/64gb.


I am sorry, since I do not use KDE I cannot answer this question. Tried it some time ago (last years November I think) and it was not very smooth as you have mentioned.

Sure. The vim version for the vim kernel and the other version for the mainline kernel if you want to go experimental. Hopefully, some day the fixes of the vim kernel will be integrated into the mainline kernel and then there should be no need for different .dtb files.

Thanks for the offer but I already extracted the .dtb from Android myself.

That is a dead end as you have experienced. It is like taking the square root of x squared :grinning:

1 Like

Found out how to rectify Chromium visual glitch when displaying certain webpage.Chromium “GPU rasterization” when Enabled might cause the certain webpage with foreing text (eg. chinese characters) to have visual screen artifacts.

Disable “GPU rasterization” and the webpage will be displayed with no visual artifacts.

@spikerguy, Just upgraded to linux-vim 5.11.4-1 from linux-vim 5.11.2-1. All key functions working.

I am sorry, since I do not use KDE I cannot answer this question. Tried it some time ago (last years November I think) and it was not very smooth as you have mentioned.

Which version are you using ? I tried Manjaro-ARM-xfce-vim3-20.12.img.xz but it shows a turquoise screen when I boot the device. Did you experience this bug ?

Interesting! I do not experience this bug on my X96Max+ (which I have successively updated over the past weeks) but have the same problem with my X96Mini which I have updated yesterday.
This is a well known bug of Amlogic devices that is related to the boot loader and was fixed (a long time ago) by adding the correct u-boot.ext file to the boot partition.
Since I do not have access to my boxes right now I cannot test it myself but you can try to rename the file u-boot-s905x2??? to u-boot.ext that is located at the boot partition of your sd card and have a look if this changes something.

1 Like

In fact I went through and when I installed linux-vim (+updated the system) the screen went back to black. I noticed that the strcture of BOOT partition changed and extlinux folder was added (like in KDE edition).
Now sound is working, bluetooth seems to be recognized (but I haven’t tested yet) but Wifi doesn’t work.
Would the installation of linux-vim-headers add or change anything ?
I also noticed the display is flickering
I am now trying to test the bluetooth

UPDATE : in fact bluetooth doesn’t work either. Here’s the output of rfkill and blueman-adapters

xmaxx@x96 ~]$ rfkill & blueman-adapters
[1] 1019
0 bluetooth hci0 débloqué débloqué
blueman-adapters version 2.1.4 starting
blueman-adapters 19.46.04 ERROR Adapter:53 init : No adapter(s) found
[1]+ Fini rfkill

For wifi to work you have to install rtl8822cs-dkms (don’t know exactly the name of the package right now). Maybe also bc, linux-vim-headers and make. I remember that some dependency was missing that was not installed automatically.

Edit: See post 702 or 703 → you have to install bc for rtl8822cs to compile correctly.

1 Like