Manjaro arm on Amlogic Tv box?

Yes you can generate one from manjaro arm installer Or I might do one for testing this weekend.

Yes I think there is some config issue somewhere. Will look into this

Yes soon once we have gpu support.

This is only for S922X-H soc and no one really knows what is the difference between -H and -J as beelink version of S922 is -H and those are the only ones which have kernel panic.

I will all beelink to send a sample to neil who is the lead kernel developer for amlogic soc.

Btw please tag me when asking something coz without the tag I won’t get any notification.

Thanks for taking interest in manjaro For amlogic.

If i get such an overwhelming support then I will be able to look into it now.

I also have mainline uboot image for Vim3 which can be directly flashed to emmc but only when there is nothing in the emmc like no Android uboot present.

1 Like

@spikerguy I also (with s922x-j) get freezes/lockups but not so often (I can have the box running more than a day on low load). (A freeze on my system is just a freeze; frozen screen, unresponsive, impossible to ssh in.) When a freeze happens, it is usually preceded by loss of Bluetooth (or, perhaps one of those graphics glitches, I’m not sure if these are correlated). I managed to salvage a bit of dmesg from last time it happened and there is a kernel Oops there:


[ 7.522816] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[ 7.527479] scsi host0: usb-storage 1-1.2:1.0
[ 7.534434] systemd[1]: System time before build time, advancing clock.
[ 7.674182] systemd[1]: systemd 246.6-1.1-arch running in system mode. (+PAM +AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +ZSTD +SECCOMP +BLKID +ELFUTILS +KMOD +IDN2 -IDN +PCRE2 default-hierarchy=hybrid)
[ 7.700975] systemd[1]: Detected architecture arm64.
[ 7.829081] systemd[1]: Set hostname to .
[ 8.558439] scsi 0:0:0:0: Direct-Access SanDisk Ultra Fit 1.00 PQ: 0 ANSI: 6
[ 8.579438] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 8.579805] sd 0:0:0:0: [sda] 240254976 512-byte logical blocks: (123 GB/115 GiB)
[ 8.593224] sd 0:0:0:0: [sda] Write Protect is off
[ 8.597291] sd 0:0:0:0: [sda] Mode Sense: 43 00 00 00
[ 8.597761] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn’t support DPO or FUA
[ 8.723467] sda: sda1
[ 8.739851] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 8.776064] systemd[1]: Configuration file /usr/lib/systemd/system/sound.service is marked executable. Please remove executable permission bits. Proceeding anyway.
[ 8.891801] systemd[1]: Queued start job for default target Graphical Interface.
[ 8.901481] random: systemd: uninitialized urandom read (16 bytes read)
[ 8.913544] systemd[1]: Created slice system-getty.slice.
[ 8.938126] random: systemd: uninitialized urandom read (16 bytes read)
[ 8.942791] systemd[1]: Created slice system-modprobe.slice.
[ 8.950891] random: systemd: uninitialized urandom read (16 bytes read)
[ 8.954804] systemd[1]: Created slice system-serial\x2dgetty.slice.
[ 8.964555] systemd[1]: Created slice User and Session Slice.
[ 8.969104] systemd[1]: Started Dispatch Password Requests to Console Directory Watch.
[ 8.977161] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[ 8.984734] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[ 8.993802] systemd[1]: Reached target Local Encrypted Volumes.
[ 8.999244] systemd[1]: Reached target Paths.
[ 9.003521] systemd[1]: Reached target Remote Encrypted Volumes.
[ 9.009532] systemd[1]: Reached target Remote File Systems.
[ 9.015017] systemd[1]: Reached target Slices.
[ 9.018841] systemd[1]: Reached target Swap.
[ 9.023500] systemd[1]: Listening on Device-mapper event daemon FIFOs.
[ 9.030070] systemd[1]: Listening on LVM2 metadata daemon socket.
[ 9.036421] systemd[1]: Listening on LVM2 poll daemon socket.
[ 9.046906] systemd[1]: Listening on Process Core Dump Socket.
[ 9.058020] systemd[1]: Listening on Journal Audit Socket.
[ 9.064271] systemd[1]: Listening on Journal Socket (/dev/log).
[ 9.070253] systemd[1]: Listening on Journal Socket.
[ 9.076387] systemd[1]: Listening on Network Service Netlink Socket.
[ 9.089886] systemd[1]: Listening on udev Control Socket.
[ 9.094252] systemd[1]: Listening on udev Kernel Socket.
[ 9.102524] systemd[1]: Listening on User Database Manager Socket.
[ 9.117557] systemd[1]: Mounting Huge Pages File System…
[ 9.123049] systemd[1]: Mounting POSIX Message Queue File System…
[ 9.131486] systemd[1]: Mounting Kernel Debug File System…
[ 9.135930] systemd[1]: Condition check resulted in Kernel Trace File System being skipped.
[ 9.147266] systemd[1]: Mounting Temporary Directory (/tmp)…
[ 9.155909] systemd[1]: Starting Create list of static device nodes for the current kernel…
[ 9.164892] systemd[1]: Starting Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling…
[ 9.173362] systemd[1]: Condition check resulted in Load Kernel Module drm being skipped.
[ 9.211007] systemd[1]: Condition check resulted in Set Up Additional Binary Formats being skipped.
[ 9.253201] systemd[1]: Starting Load Kernel Modules…
[ 9.267028] systemd[1]: Starting Remount Root and Kernel File Systems…
[ 9.272825] systemd[1]: Condition check resulted in Repartition Root Disk being skipped.
[ 9.281259] systemd[1]: Starting Coldplug All udev Devices…
[ 9.289025] systemd[1]: Mounted Huge Pages File System.
[ 9.292720] systemd[1]: Mounted POSIX Message Queue File System.
[ 9.297993] systemd[1]: Mounted Kernel Debug File System.
[ 9.304178] systemd[1]: Mounted Temporary Directory (/tmp).
[ 9.310191] systemd[1]: Finished Create list of static device nodes for the current kernel.
[ 9.318079] systemd[1]: Finished Load Kernel Modules.
[ 9.323022] systemd[1]: Finished Remount Root and Kernel File Systems.
[ 9.330258] systemd[1]: Condition check resulted in FUSE Control File System being skipped.
[ 9.337196] systemd[1]: Mounting Kernel Configuration File System…
[ 9.343467] systemd[1]: Condition check resulted in First Boot Wizard being skipped.
[ 9.358395] systemd[1]: Condition check resulted in Rebuild Hardware Database being skipped.
[ 9.362873] systemd[1]: Condition check resulted in Platform Persistent Storage Archival being skipped.
[ 9.374304] systemd[1]: Starting Load/Save Random Seed…
[ 9.381810] systemd[1]: Starting Apply Kernel Variables…
[ 9.391585] systemd[1]: Starting Create System Users…
[ 9.405841] systemd[1]: Mounted Kernel Configuration File System.
[ 9.428680] systemd[1]: Finished Apply Kernel Variables.
[ 9.490551] systemd[1]: Finished Coldplug All udev Devices.
[ 9.516516] systemd[1]: Finished Create System Users.
[ 9.532868] systemd[1]: Starting Create Static Device Nodes in /dev…
[ 9.611276] systemd[1]: Finished Create Static Device Nodes in /dev.
[ 9.621078] systemd[1]: Started Entropy Daemon based on the HAVEGE algorithm.
[ 9.633730] systemd[1]: Starting Journal Service…
[ 9.645261] systemd[1]: Starting Rule-based Manager for Device Events and Files…
[ 9.987664] systemd[1]: Started Journal Service.
[ 10.465938] mc: Linux media interface: v0.10
[ 10.478816] meson-vrtc ff8000a8.rtc: registered as rtc0
[ 10.480617] meson-vrtc ff8000a8.rtc: setting system clock to 1970-01-01T00:00:10 UTC (10)
[ 10.491234] libphy: mdio_mux: probed
[ 10.497213] axg-sound-card sound: ASoC: no DMI vendor name!
[ 10.503531] videodev: Linux video capture interface: v2.00
[ 10.585086] Registered IR keymap rc-khadas
[ 10.633647] IR NEC protocol handler initialized
[ 10.648176] libphy: mdio_mux: probed
[ 10.674967] rc rc0: meson-ir as /devices/platform/soc/ff800000.bus/
[ 10.681376] rc rc0: lirc_dev: driver meson-ir registered at minor = 0, raw IR receiver, no transmitter
[ 10.689857] Bluetooth: Core ver 2.22
[ 10.690268] input: meson-ir as /devices/platform/soc/ff800000.bus/
[ 10.697406] NET: Registered protocol family 31
[ 10.707773] meson-ir receiver initialized
[ 10.711510] Bluetooth: HCI device and connection manager initialized
[ 10.717385] Bluetooth: HCI socket layer initialized
[ 10.729559] Bluetooth: L2CAP socket layer initialized
[ 10.733019] Bluetooth: SCO socket layer initialized
[ 10.771887] meson_vdec: module is from the staging directory, the quality is unknown, you have been warned.
[ 10.849405] Bluetooth: HCI UART driver ver 2.3
[ 10.851183] Bluetooth: HCI UART protocol H4 registered
[ 10.855230] Bluetooth: HCI UART protocol BCSP registered
[ 10.860406] Bluetooth: HCI UART protocol LL registered
[ 10.865531] Bluetooth: HCI UART protocol ATH3K registered
[ 10.870811] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 10.873092] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[ 10.877221] Bluetooth: HCI UART protocol Intel registered
[ 10.890364] Bluetooth: HCI UART protocol Broadcom registered
[ 10.890378] Bluetooth: HCI UART protocol QCA registered
[ 10.890379] Bluetooth: HCI UART protocol AG6XX registered
[ 10.890393] Bluetooth: HCI UART protocol Marvell registered
[ 10.890523] hci_uart_bcm serial0-0: supply vbat not found, using dummy regulator
[ 10.890654] hci_uart_bcm serial0-0: supply vddio not found, using dummy regulator
[ 10.901751] cfg80211: Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’
[ 11.070632] brcmfmac: F1 signature read @0x18000000=0x17294359
[ 11.074892] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4359-sdio for chip BCM4359/9
[ 11.079925] usbcore: registered new interface driver brcmfmac
[ 11.143410] random: crng init done
[ 11.147114] random: 7 urandom warning(s) missed due to ratelimiting
[ 11.245316] Bluetooth: hci1: BCM: chip id 121
[ 11.249461] Bluetooth: hci1: BCM: features 0x0e
[ 11.253730] Bluetooth: hci1: BCM4359C0
[ 11.257420] Bluetooth: hci1: BCM4359C0 (003.001.006) build 0000
[ 11.273854] Bluetooth: hci1: BCM4359C0 ‘brcm/BCM4359C0.hcd’ Patch
[ 12.117545] Bluetooth: hci1: BCM43596 UART 37.4MHz AMPAK AP6359S2 CL1.5[Baseline: 0134]
[ 12.125306] Bluetooth: hci1: BCM4359C0 (003.001.006) build 0268
[ 13.445339] usbcore: registered new interface driver uas
[ 13.534894] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4359-sdio for chip BCM4359/9
[ 13.541109] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[ 13.565164] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4359/9 wl0: Jan 19 2018 12:14:30 version (a85e25e@shgit) ® FWID 01-cb5aa0a5
[ 13.718328] logitech-djreceiver 0003:046D:C534.0001: hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on
[ 14.209776] logitech-djreceiver 0003:046D:C534.0002: hiddev0,hidraw1: USB HID v1.11 Mouse [Logitech USB Receiver] on
[ 14.297244] logitech-djreceiver 0003:046D:C534.0002: device of type eQUAD nano Lite (0x0a) connected on slot 1
[ 14.315168] logitech-djreceiver 0003:046D:C534.0002: device of type eQUAD nano Lite (0x0a) connected on slot 2
[ 14.327223] input: Logitech Wireless Keyboard PID:4023 Keyboard as /devices/platform/soc/ffe09000.usb/ff500000.usb/
[ 14.354642] input: Logitech Wireless Keyboard PID:4023 Consumer Control as /devices/platform/soc/ffe09000.usb/ff500000.usb/
[ 14.376475] input: Logitech Wireless Keyboard PID:4023 System Control as /devices/platform/soc/ffe09000.usb/ff500000.usb/
[ 14.398355] hid-generic 0003:046D:4023.0003: input,hidraw2: USB HID v1.11 Keyboard [Logitech Wireless Keyboard PID:4023] on
[ 14.399109] input: Logitech Wireless Mouse PID:4022 Mouse as /devices/platform/soc/ffe09000.usb/ff500000.usb/
[ 14.399332] hid-generic 0003:046D:4022.0004: input,hidraw3: USB HID v1.11 Mouse [Logitech Wireless Mouse PID:4022] on
[ 14.834363] zram: Added device: zram0
[ 14.841643] zram0: detected capacity change from 0 to 5707489280
[ 14.974782] Adding 5573716k swap on /dev/zram0. Priority:100 extents:1 across:5573716k SSFS
[ 15.165094] input: Logitech Wireless Keyboard PID:4023 as /devices/platform/soc/ffe09000.usb/ff500000.usb/
[ 15.199983] logitech-hidpp-device 0003:046D:4023.0003: input,hidraw2: USB HID v1.11 Keyboard [Logitech Wireless Keyboard PID:4023] on
[ 15.312231] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 15.312238] Bluetooth: BNEP filters: protocol multicast
[ 15.322347] Bluetooth: BNEP socket layer initialized
[ 15.351088] NET: Registered protocol family 38
[ 15.381305] input: Logitech Wireless Mouse PID:4022 as /devices/platform/soc/ffe09000.usb/ff500000.usb/
[ 15.383176] logitech-hidpp-device 0003:046D:4022.0004: input,hidraw3: USB HID v1.11 Mouse [Logitech Wireless Mouse PID:4022] on
[ 16.447007] meson8b-dwmac ff3f0000.ethernet eth0: PHY [0.0:00] driver [RTL8211F Gigabit Ethernet] (irq=29)
[ 16.458391] meson8b-dwmac ff3f0000.ethernet eth0: No Safety Features support found
[ 16.460481] meson8b-dwmac ff3f0000.ethernet eth0: PTP not supported by HW
[ 16.468582] meson8b-dwmac ff3f0000.ethernet eth0: configuring for phy/rgmii link mode
[ 16.656207] ieee80211 phy0: brcmf_dongle_roam: WLC_SET_ROAM_TRIGGER error (-52)
[ 20.136237] meson8b-dwmac ff3f0000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[ 20.139240] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 20.152530] meson8b-dwmac ff3f0000.ethernet eth0: Link is Down
[ 23.320758] meson8b-dwmac ff3f0000.ethernet eth0: Link is Up - 100Mbps/Full - flow control off
[ 23.349244] fuse: init (API version 7.31)
[ 32.271272] logitech-hidpp-device 0003:046D:4023.0003: HID++ 2.0 device connected.
[ 38.117853] Bluetooth: RFCOMM TTY layer initialized
[ 38.117920] Bluetooth: RFCOMM socket layer initialized
[ 38.122316] Bluetooth: RFCOMM ver 1.11
[ 68.095423] logitech-hidpp-device 0003:046D:4022.0004: HID++ 2.0 device connected.
[ 78.044270] device-mapper: ioctl: 4.42.0-ioctl (2020-02-27) initialised:
[ 80.531644] EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)
[ 118.917657] tun: Universal TUN/TAP device driver, 1.6
[ 640.964676] rc rc0: two consecutive events of type space
[ 3349.778660] brcmfmac: brcmf_sdio_readframes: RXHEADER FAILED: -110
[ 3349.779338] brcmfmac: brcmf_sdio_rxfail: abort command, terminate frame, send NAK
[ 3349.786973] brcmfmac: brcmf_sdio_readframes: RXHEADER FAILED: -110
[ 3349.792769] brcmfmac: brcmf_sdio_rxfail: abort command, terminate frame, send NAK
[12593.289229] Unable to handle kernel paging request at virtual address ffff800016006350
[12593.291755] Mem abort info:
[12593.294506] ESR = 0x96000007
[12593.297564] EC = 0x25: DABT (current EL), IL = 32 bits
[12593.302785] SET = 0, FnV = 0
[12593.305802] EA = 0, S1PTW = 0
[12593.308887] Data abort info:
[12593.311747] ISV = 0, ISS = 0x00000007
[12593.315543] CM = 0, WnR = 0
[12593.318537] swapper pgtable: 4k pages, 48-bit VAs, pgdp=000000000278a000
[12593.325137] [ffff800016006350] pgd=00000000dd7ff003, p4d=00000000dd7ff003, pud=00000000dd7fe003, pmd=00000000ad65e003, pte=0000000000000000
[12593.337594] Internal error: Oops: 96000007 [#1] PREEMPT SMP
[12593.343051] Modules linked in: tun dm_crypt dm_mod dax rfcomm fuse algif_hash algif_skcipher af_alg bnep zram hid_logitech_hidpp joydev nls_ascii uas hid_logitech_dj btsdio brcmfmac brcmutil cfg80211 hci_uart btqca btrtl meson_vdec© btbcm btintel bluetooth v4l2_mem2mem ir_nec_decoder videobuf2_dma_contig videobuf2_memops ecdh_generic videobuf2_v4l2 dw_hdmi_cec ecc rc_khadas videobuf2_common rfkill meson_rng meson_ir rc_core videodev mdio_mux_meson_g12a snd_soc_meson_g12a_tohdmitx rtc_meson_vrtc mc snd_soc_meson_axg_spdifout snd_soc_meson_axg_sound_card sch_fq_codel crypto_user ip_tables x_tables
[12593.395711] CPU: 5 PID: 27889 Comm: kworker/5:1 Tainted: G C 5.9.0-1-MANJARO-ARM #1
[12593.404463] Hardware name: Ugoos AM6 (DT)
[12593.408624] Workqueue: events dbs_work_handler
[12593.412921] pstate: 60000085 (nZCv daIf -PAN -UAO BTYPE=–)
[12593.418506] pc : regmap_lock_spinlock+0x1c/0x30
[12593.422954] lr : regmap_lock_spinlock+0x18/0x30
[12593.427315] sp : ffff800016003a40
[12593.430614] x29: ffff800016003a40 x28: ffff0000d7dada00
[12593.435859] x27: ffff0000d7dad800 x26: ffff0000d7dad100
[12593.441114] x25: 0000000000000000 x24: 0000000000000000
[12593.446369] x23: 0000000000000000 x22: 0000000000000030
[12593.451636] x21: 00000000040003f0 x20: 0000000000000208
[12593.456896] x19: ffff0000d5eb1800 x18: 0000001dcd64f880
[12593.462156] x17: 0000000000000000 x16: 0000000000000000
[12593.467455] x15: 0000000000000000 x14: 0000000000b71b00
[12593.472683] x13: 00000000016e3600 x12: 0000000165a0bc00
[12593.477937] x11: 0000000000000000 x10: 0000000000000001
[12593.483205] x9 : ffff800016003978 x8 : 0000000000000006
[12593.488465] x7 : 000000000000001a x6 : 0000000000000000
[12593.493720] x5 : 0000000000000000 x4 : 0000000000000000
[12593.498986] x3 : ffff0000d5eb1800 x2 : 0000000000000001
[12593.504241] x1 : 0000000000000000 x0 : 0000000000000000
[12593.509515] Call trace:
[12593.512111] regmap_lock_spinlock+0x1c/0x30
[12593.516167] regmap_update_bits_base+0x44/0xa0
[12593.520586] meson_clk_cpu_dyndiv_set_rate+0xf4/0x120
[12593.525570] clk_change_rate+0x148/0x2bc
[12593.529432] clk_change_rate+0xf4/0x2bc
[12593.533238] clk_core_set_rate_nolock+0x1bc/0x274
[12593.537880] clk_set_rate+0x38/0x150
[12593.541448] dev_pm_opp_set_rate+0x3d8/0x770
[12593.545660] set_target+0x44/0x90
[12593.548982] __cpufreq_driver_target+0x1dc/0x644
[12593.553473] od_dbs_update+0xc0/0x1a4
[12593.557101] dbs_work_handler+0x40/0x80
[12593.560921] process_one_work+0x1cc/0x350
[12593.564856] worker_thread+0x13c/0x470
[12593.568588] kthread+0x154/0x160
[12593.571782] ret_from_fork+0x10/0x30
[12593.575414] Code: f9000bf3 aa0003f3 9413de97 f9000660 (f9400bf3)
[12593.581353] —[ end trace 90a5062826febd46 ]—
[12593.585909] note: kworker/5:1[27889] exited with preempt_count 1

Edit: This was not during idle; I browsed the web or watched a movie, don’t remember.

Thanks for confirming, so this means its something to do with S922x-(J, H) variant of soc’s

Good to know this and the logs look quite similar during kernel panic.

Balbes is maintaining Ugoos Am6 I will try to ping him, but first check if it is the same with armbian image by balbes.

@spikerguy I have Armbian with Balbes latest kernel 5.9.0 (his general multiboard arm-64 tag/branch/family) running 100% stable on my (s922x-j) box. (I have used Armbian on the box for a couple of months.)

Edit: Clarification.
Edit2: I have also had Armbian kernel 5.8.10 (I think it was .10) running w/o problem on the box.

Hi Spikerguy,

Thanks for the response. I am interested in trying out the latest Manjaro 20.10 on Beelink GTKing Pro but am very new in Linux so to compile or generate one from majaro arm installer is most likely beyond me unless with a lot of guidance with detailed steps.

If you are building one image for GTKPro for testing would it be possible release/share for those that is interest to test it?

The Manjaro VIM3 20.06 with kernel 5.7 is too unstable for GTKPro as it is. I can’t get pass basic system updating without kernel panic or freezing (eg. during fresh "pacman -Syu, was able to complete download of all the packages (500-700MB) but will hit kernel panic during “checking available disk space or unpacking of up to 5 packages then freeze.” The latest was during boot up “kernel panic” (cannot boot up anymore).

Looking forward to test Manjaro Arm with kernel 5.9.1 and above soon.

1 Like

Yes i am using the kernel from balbes branch only. So our dtb is the same as his.

Ok will try to build one later this weekend.

You can build one on your own using this guide.
Try if you can.

@spikerguy This means that it should be possible to solve this. Let me know if there is something I can do (run tests, possibly build something, etc). Much appreciate your work.

1 Like

Hi Spikerguy,

Thank you. Looking forward to test the Manjaro Arm 20.10 for GTKPro.

In Armbian I notice there are at least two versions of dtb files for meson-ugoos-am6.dtb one with 73K file size and another file size 51K. There is also one from Armbian for GTKPro meson-g12b-gtking-pro.dtb of file size 73K.

@JFL I think this is due to the inclusion of a list of symbols (for use with overlays) in one of them. You can check by decompiling (I outlined this somewhere above) and look near the end of the decompiled file. For our use, I don’t think there is any difference.

Edit: Oops, I forgot that you don’t have a running box but if you are ambitious you can do this on some other Linux box.


Beelink GTKPro is the only Android TV box I have. Thanks for the information.


I have followed the Manjaro WiKi mentioned by Spikerguy above (using the section “Building an OEM image”) and produced two versions of a 20.11 image with the vim3 kernel version 5.9.0-1. You can find the images here; xfce-image and minimal-image

As these are files produced by a random person on the internet (me), treat them as such (use only for testing and then discard).

Edit: I don’t know exactly how the versioning works; the images came out with the tag 20.11 but I don’t know exactly what that means in terms of packages (there is also a txt file showing the package versions, but I didn’t upload that). The kernel is 5.9.0-1 though, that is clear.

1 Like

Regarding the versioning it is written in the ‘How to contribute to Manjaro ARM’ wiki that ‘buildarmimg’ has an option ‘-v’ which allows you to set the version name as you like. If you do not use option ‘-v’ it defaults to YY.MM.

Yeah, I kind of knew that but I guess I’m not clear on what that actually means. (I have been too lazy to actually look at the package list, but maybe I’ll get around to that… :slightly_smiling_face: ) (I haven’t used this image myself, since I have a running Manjaro ARM system, updated “manually”.)

I guess the ‘-v’ option is just for convenience so that you do not have to rename the final image by hand (since the rest of the name is automatically generated depending on the device and edition you are building).

BTW, I did my first (Gnome) build just some hours ago. I also have an updated XFCE version already running on my X96Max+ TV box (S905X3, Mali G31). After first boot I did not have ethernet on the Gnome version I built while ethernet is working fine on the updated XFCE version. Both sharing the same ‘meson-sm1-sei610-2.dtb’ I used to use on Armbian with the 5.9.0 kernel. Will have to investigate it later …


Hi Tripole,

Thank you. Wow, you are fast and good at it.

I will download your Manjaro OEM image 20.11 with VIM3 kernel 5.9.0-1 build and give it go shortly. Download speed seems slow for now.

I have contacted Beelink Android team and they confirmed that the kernel crash issue is nothing but Android Uboot conflict with Linux kernel.

So I will be trying to coordinate with the Beelink Development team to find a fix for the crash issue.

I hope to find a solution soon for this as I Cannot wait to start using gx King X as my main nas server instead of My current NanoPiNeo2Plus


Hi Tripole and Spikerguy,

Just completed downloading the Manjaro-ARM-xfce-vim3-20.11.img_xz and burn image on a USB Stick. I used meson-g12b-gtking-pro.dtb to boot up. It boot up but no ethernet or wifi connection. It said “Network Manager is not running…” I thought the Network Manager is automatically installed and running?

$ systemclt status NetworkManager
NetwrorkManager.service - Network Manager
Loaded loaded (./usr/lib/systemd/system/NetworkManager.service; disabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
Active: inactive (dead)

(Edited uEnv.ini to boot up with meson-g12b–ugoos-am6.dtb and reboot. Still have the same issue “NetwrorkManager is not running…” so still no network Ethernet or Wifi)

Need guidance on how to startup the Network Manager so that I can at least connect to Ethernet and hopefully wifi too. Thanks.

Hi Spikerguy,

Great at least now we know what is causing the Kernel Panic in Beelink GT King Pro. Does it means there will be a new Android Firmware Upgrade from Beelink?

I just burn the VIM3 image that Tripole build and burn on a USB Stick. It boot up but NetworkManager is not running meaning No Ethernet or Wifi. I use meson-g12b-gtking-pro.dtb from Armbian as this VIM3 image does not have gtking-pro.dtb.

Appreciate input to resolve this NetworkManager not running issue. Thanks.

It seems that Network Manager has died and I guess it takes a little troubleshooting to figure out why… You must probably google a little about how to use the command journalctl and filter out error messages from the systemd log that can be relevant for diagnosis. Also, I would suggest that you first restart the box and perform that little ritual that worked for you before (cold boot, or maybe it was warmbooting from Android). Another thing, you can do a
dmesg | grep dwmac
and see what you find (dwmac is a program-glue layer that wraps the physical ethernet device, I think, and therefore this can help diagnose if the physical layer is working). Just my 2 cents…

Edit: Maybe I’m not reading the systemd message correctly. I can’t tell (because of ignorance) if Network Manager never started or it started and has then died. If you do
systemctl start NetworkManager.service
and then immediately do
journalctl | tail -n50
what do you get in the systemd log?

I also notice during start up or shutdown there is message “Failed to configure Network…”

Will try to re-burn the image and start up clean with “meson-g12b-ugoos-am6.dtb” to see whether it boot up with NetworkManager running.

Re-burn image of Manjaro-ARM-xfce-vim3-20.11.img_xz and using meson-g12b-ugoos-am6.dtb still results in “NetworkManager is not running…” No Ethernet or Wifi on GTKPro.