Manjaro-arm-installer: no option for orange pi 800, chose opi4lts but now 2 USB ports do not work

Ok, so i tried to flash Manjaro to my orange pi 800’s emmc.

I installed the “manjaro-arm-installer” and when i started it, there was no option for orange pi 800.
The closest derivative i found there was “orange pi 4 lts”, so i chose that.
It installed the system properly, but then - 2 USB ports out of the 3 that are on the board do not work (there are 3 USB ports on this board - two USB3.0 and one USB2.0, only the USB2.0 one works).

I still have the Manjaro for Orange Pi 800 on my sd card and there the 2 USB ports work.
I think it may have to do with a “postinstall” script not included in the manjaro-arm-installer.

I saw a script called “orangepi4-postinstall” being used, there is also a “orangepi800-postinstall” script on my sd card… so perhaps that’s what missing?

This adds up to my previous 2 posts in which I also wrote that the VGA (eDP) port on orange pi 800 stopped working after the full system upgrade. It’s ok i can live without the VGA port but I did see that no one replied to those posts which leaves me kind of stumbled because it gives me the feeling that nobody here wants to mess with Orange Pi 800 anymore… ?

OK, I managed to fix the issue.
To the Manjaro developers team - consider applying this fix in your “manjaro-arm-installer” code to support Orange Pi 800’s.

Here’s what I did:

The manjaro-arm-installer source code comes from here: manjaro-arm / applications / manjaro-arm-installer · GitLab.

The arm-profiles that it uses come from here: manjaro-arm / applications / arm-profiles · GitLab

Under “devices” - there is an install script for opi-800 - it was simply left out of manjaro-arm-installer code.
So I added it.

The code is here:

After line #772 I added:

`        "opi4-lts"      "Orange Pi 4 LTS" \`
         "opi-800"       "Orange Pi 800" \

And I added “opi-800” to line #475 as well:


After this change - I just ran manjaro-arm-installer again, chose the now added “Orange Pi 800” menu option, chose the emmc drive (/dev/mmcblk1 in my machine), and installed.

Now the system works fine with the 2 additional USB ports now working, to which i can connect an additional keyboard, mouse, and wifi dongle if needed.

VGA is still not working, but it’s not a serious issue at the moment.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.