Manjaro ARM Developer-Release with Plasma-Mobile (PinePhone)

Ah, I can see that more apps have been added to the latest dev image! Thank you. Nice to know that Manjaros Plasma edition is still getting support!

I would say it’s unfair to suggest Manjaro devs are only working on Phosh. They will also be working on Plasma and Lomiri versions (although the latter has stalled of late through no fault of their own). That being said, I would expect that, ethically speaking, more time would need to be given to the Phosh build as hundreds/thousands of people will have recently shelled out £150+ for a Manjaro-based phone, which currently runs Phosh.

Who knows, priorities may change in the future. I believe that Plasma mobile will eventually end up being the primary build for Manjaro, but that’s just a uninformed hunch.

It would be great to get overall feedback on PlaMo, as we work towards Beta1. So any issues you may find can be posted here.

2 Likes

Can someone recommend a good music player for Plasma-Mobile? If I was using KDE on my Pinebook Pro I’d probably use Elisa.

GitLab login wants full access to my GitLab account

Yeah. I wasn’t particularly happy with that either. Only went with it because my GitLab account is practically empty as I only created it a couple of weeks ago while musing over moving away from GitHub

Reported two issues:

  • Incoming calls could not be taken on lockscreen and display stays off on arriving a call
  • provider in statusbar displayed only numeric eg. 345672

Newest image from 16.11.2020

Vvave is pre-installed and just for information, we work closely with Plasma Mobile and as long as I am here as Arm dev Plasma mobile will be available on Manjaro coz I am Plasma user myself :wink:

We do daily builds of plasma for testing. So yes currently plasma and phosh is priority but our aim to also get give importance to lomiri but due to health concerns the lead lomiri develeper is not available until unforeable future.

Thank you for supporting Manjaro.
We try to bring the best of the UI on Manjaro for our users.

Cheers.

3 Likes

Cool. I prefer plasma-mobile too. Dropped you some issues on GitLab ;p

I tried using the latest plasma build from the osdn site here last night but it was still very unresponsive. However it looks like the kdebuild link @philm posted has some newer builds. I will try them out. I was testing phosh builds(updating once every week or two), but prefer the look and feel of plasma right now. just wish it wasn’t so dogged. I will switch over though and see if i can’t help move this distro/de along some.

Oh yeah. Didn’t think to click on that. Assumed it would be the same as the link in the pinned message. Switching to build 201116.

Shouldn’t this be part of the pinned message in this thread?

Things i’ve noticed since switching over to plasma;

I CAN open up the app drawer(swipe up), open settings and go through various options. I CANNOT click on any individual setting from the top menu(swipe down). When I click battery, mobile data, wifi, etc. nothing happens. I can turn respective options on and off by clicking the square(mobile data, wifi, bt etc) but clicking the word/down arrow tries to launch the option, however it does nothing; just sort of hangs and then goes away.

Stuck on 24 hour clock. I went to settings and adjusted data and time automatically(manually set region/timezone), turned off 24 hour option, but clock is still 24 hours.

Mobile data is intermittent at best. A fresh power up seems to work, sometimes. It either shows AT&T(my service provider), a 6 digit string of numbers, or nothing(but bars/signal). APN setting seems to revert to default if I try and change the generic APN name in settings to what i was using in phosh. I cannot edit the APN if i click on it, I can only replace the default string, but it reverts. *As a side note i was also unable to edit APN settings in phosh, but I could at least add an additional config and select it as default so that mobile data worked.

When I click on Discover(app) I get “unable to load apps, verify internet” but opening the menu and clicking apps/addons/etc seems to load them just fine and i am getting update notifications.
Downloaded pure maps and osm scout. It failed to add icons to the app drawer, but otherwise seems to be working ok; sometimes the on screen buttons disappear(layers, navigate, etc) on pure maps after going into an option setting and going back. EDIT - reboot and the app icons are there…

I really wish i could get to the battery/power settings to keep the phone screen from shutting off after 60 seconds so i could monitor downloads, app launches etc a bit longer.

Phone seems to freeze/hitch/hangup for short periods of time more so than phosh(although it could be negligible, but i would lean towards more than), but its not really surprising or frustrating, just more of my feedback and what i’ve noticed based on use thus far.

I’m sure some of this could be remedied via the terminal, but i am giving initial feedback on the options available via the gui.

Can someone recommend a good GUI-based text editor for Plasma-Mobile? I’ve tried Kate and KWrite, but both have menus that extend off the screen.

have you tried nota? it comes preinstalled.

1 Like

Ah… opened that briefly and incorrectly assumed that it was a note taking app.

Does anyone know how to take screenshots using Plasma-Mobile, or is it not possible yet? I think you can press volume up and volume down together on some other OS builds.

Last I tried Plasma Mobile, the shortcut in the notifiaction bar worked just fine for screenshots.

Ah… missed that. Thank you.

I tried to install element-desktop to access matrix.org (after opening element.io in Angelfish had kept crashing the browser). However, I seem to be unable to enter my credentials in that electron app as the virtual keyboard doesn’t come up.

:arrow_right: Is there a way to force the virtual keyboard to appear in Plasma-Mobile?

Also, closing element-desktop does not seem to stop any of its processes, i.e. eight electron processes still show up in ps. If this is worth reporting, where should I turn to?