Manjaro ARM Beta8 with Plasma-Mobile (Pinephone)

We are happy to present our eight Beta Release of the Manjaro Plasma-Mobile edition for the PinePhone. This marks the last release with ofono stack!


This image includes

  • Kernel 5.14.17 optimized for the Pinephone, which recently had some great improvements in regards of battery life,
  • Frameworks 5.87
  • Plasma 5.23.2
  • Plasma-Mobile apps, which are now bundled as Plamo Gear 21.08
  • Maui Apps 2.0 and
  • Camera app Megapixels 1.3.0 with great improvements in responsiveness,
  • Pipewire 0.3.39
  • Appimagelauncher 2.2.0 and
  • our Pico-Wizard for easy initial setup at first launch

Over the last months Plasma-Mobile has made a lot of remarkable progress in regards of graphical appearance with smooth transitions and auto-rotate. Apps are now launching faster, too.
The drop-down menu provides Settings, Flashlight, a Screenshot function and more.
With Plamo Gear and the Maui Apps applications for all typical everyday needs are pre-installed.

Known issues:

  • keyboard in pico-wizard closes frequently and needs to be re-opened by tapping input fields again
  • modem stability is still not very good. This should be improved significantly in the near future by transitioning to support of modemmanager
  • text prediction is currently only available for English.
  • many translations are still missing.


Device PlaMo
PinePhone Beta8
PinePhone Development

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker



How far along is a similar update for PineTab?

Are you saying that this a secure smartphone?
Are you saying this is a fully working smartphone?
Does it read potentially infected pdf files sandboxed?
What is the position regarding google connections?
Does it use MicroG…?

Security is defined by the user’s habits. Encrypted filesystem is possible but requires the user to do it by hand.

I use a pinephone - so yes - but fully working depends where you are and your requirments and which system you run - e.g. I am living in Denmark and I have no issues (using phosh)

I don’t read pdf on my phone

There is no Google

What is that?

Do not expect a polished smartphone experience - expect bugs - expect to solve issues - it is a playground - for my use it works fine - no breaking issues.

I only use the phone for what it should be used for - phonecalls and texts - an internet connection for nerd access to my ssh server - browser for editing notes on my web based notepad.



Do you know if the ofono issue’s have been solved?

A new implementation of the phone stack is currently being implemented in Plasma Mobile, replacing ofono with ModemManager. I believe it was to be released with KDE Gear 21.10 last month, but that got cancelled due to some issues with the Caller app or such. It is now up for release with KDE Gear 21.11, but seeing as it’s late november already I wouldn’t be surprised if that gets cancelled too, and we’ll have to wait for KDE Gear 21.12 to be released.

However, as I understand it the current plasma-mobile-dev builds already run on the phone stack where ofono is replaced with ModemManager, so you could try your luck with those :slight_smile:


I’ve been using the same Plasma Mobile installation for tree weeks now. Such a long usage was impossible before - at least for me. There was always something that made the entire installation unusable. Plasma mobile has definitely come a long way. There are still a few minor issues here and there but overall the system feels stable, snappy and beautiful.

first plasma mobile i have tried out, and it was simply unusable. I was not able to activate mobile data, when clicking on the checkbox it just went to the page asking for access point details. I was not able to shut it down or restart phone unless typing it into search box. It was also slower than phosh and app launcher needed excessively long press before it registered scroll input. All UI buttons suffered from the same, needing to press, instead of just quickly tap, to have reliable input. OSK keyboard lacked all other arrow keys except left (wtf?)

I am kind of hoping i did something wrong because this is just astonishing level of fail for a beta8, it feels like beta1 of phosh worked better as i never had showstoppers, just small annoyances there.

edit: i found one improvement over phosh, the haptic feedback through vibra was stronger. But i feel bad this OS is what is shipped with new devices.

1 Like

That is your usage - not mine or most people.
I want a stable secure smartphone that protects my privacy. :ok_hand:
I got rid of eFoundation eS7 phone because I could not turn off location under microG. I sent it back for total refund as it was still making google connections so was not google free as advertised.

I then bought a used budget smartphone - Pixel 3a - and flashed GrapheneOS myself following video and instructions from techlore security expert. :male_detective:
I have been stopped providing links so you will have to find the video by putting https in front of…
This is a smartphone as it should be. :hugs:
You can even view pdf files sandboxed for complete safety and security.
Superb 20mp camera too.

Never considered a pinephone at the time as it looked like an expensive amateur project in early stages.

Well, expensive it is for sure. It already took Millions of Dollars to get to the state it is now, but amateur project ?!?. It is more like a hen egg problem. Without the hardware, no phone, and with no phone no proper software on Linux.

The pinephone is not alone. There is also Librem 5 by Purism. Sure, both projects are started by companies, but Pine64 has grown also a great community with developers from multiple opensource focused projects. Some a backed by corporation sponsorship, others do it in their free time to get Linux on Mobile possible.

Purism started with a flag ship device and Pine64 on the low end cheaper side. However, for a developer it partly doesn’t matter how slow the application starts, rather how it is visual presented and how you may interact with the new mobile platform also software wise. Having the Pinephone Pro targeting the regular user only shows that there is a wider interest in within the broader community in Mainline Linux phones. Expect more to come, as we, as a company and community have much to give in that regard. So stay tuned for future updates on the matter …


Hi Phil – could we agree that pinephone and GraphenOS Pixel phones are diametrically opposite in form, function, capabilities, security and ethos…?

"If I were configuring a smartphone today, I’d use DanielMicay’s GrapheneOS as the base operating system. I’d desolder the microphones." Edward Snowden

I am sure you fully know the backstory but please see cellularnews dot com.

Are there any preinstalled secure OS pinephones available to buy like omertadigital dot com…? Or NitroPhone - Most Secure Android on the Planet.

I think you need to get near to this level or you may end up like ReplicantOS regarding actual phones. You also need to consider the internal hardware – the chip – security, security, security…!

Having said all that – as I like to support the small guy – I wish you the best of luck.

First of all, I would like to note that my rating refers exclusively to the software.

It depends on what you expect from an OS.

I personally like to have the following things
  • A relatively stable software experience
  • modern design(optional but nice)
  • Touch gestures(optional but nice)
  • Customizability(themes,icons,fonts,application names …)
  • Music player(like Elisa or vvave)
  • Podcast player(like kasts)
  • deactivatable vibrations(they eat a lot of energy)
  • a Corona Vaccination app(like vakzination)
  • terminal emulator(I prefer maui-station)

Since we are talking about a beta version, I expect that software can become (temporarily) unusable (like discover and dialer for example). Also, I expect to run into problems.

there are two ways to interact with these quick settings.
A short press activates the modem.
If you keep the button pressed, the access point page you mentioned opens.

Of course, it is also possible that it is due to a software issue or that your sim card may be incompatible.

that’s weird. normally you hold the power button down for about two to three seconds. You may need to release and wait.

Yeah. It’s because Plasma mobile requires significantly more system ressources than phosh.
The startup of Maui apps like index or vvave had just been sped up by a factor of five!

Since plasma has been updated to version 5.23 there is a bug in Plasma Mobile. the app drawer hangs when scrolling. Sometimes the lock screen hangs as well. I think that the problem is already known and will be fixed in a upcoming release.

I cannot replicate this.
Maybe it has already been fixed?
Is your installation up to date?

The left arrow key is located in a bar. hold that bar and swipe left to see the full contents.

I don’t think you did anything wrong. Plasma Mobile is more complex than phosh. More complexity means more bugs to crush and more hardware requirements. Hardware requirements that the Pinephone, as a prototype for software developers and Linux enthusiasts, can’t always provide. That’s why the Pinephone Pro was announced.

I guess they choosen Manjaro and KDE because they worked with them before and because Plasma Mobile is the most similar alternative to android.

BTW: I’ve seen a development snapshot with a new app switcher that makes Plasma Mobile even more similar to Android 10+

Not yet. Incoming calls are very stable and the modem is working most of the time. but you can’t make calls at the moment, you have to be called.

I did try it and really an amazing jump since release 6!
Gesture for the most part are fluid, app’s start faster, call and text message get in and out (i am not experiencing issue with outgoing calls as far has i know) without any issue, batterie life is so much better about 100% better(I can now go for a full day without worrying at all). Nice going!
@varikonniemi There are indeed some bug’s but it is after all just a beta release!

Thanks, with next beta i will try again and keep in mind the long press to access reboot/shutdown menu and swiping the OSK bar with the arrow key. Seems like after all some problems were just user error :slight_smile: (though these are not discoverable through UI, so should probably be fixed)

I’m eager to see what the experience is like once the launcher bug and lockscreen are smooth again. And hopefully switching away from ofono will make data work, i indeed just tried tapping the checkbox, not long pressing.

Hi Devs,

Running the Dev version and ran across a bug. After updating via pacman when I power up my phone I no longer get prompted for a password. This first started happening a few days ago.

While troubleshooting this I reflashed with the latest version, 202112050253. When first powering up the setup wizard doesn’t start, goes right to the desktop.

I tried several earlier nighties, seems this first started happening on version, 202112030855.

I’m thinking both issues are related.



1 Like