Manjaro ARM Beta8 with Phosh (PinePhone)

Manjaro ARM Beta8 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our eight BETA release for the PinePhone running Phosh!

This image is running the 5.11 kernel from Megi, which is designed for the PinePhone.


  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function we had to remove
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps with working GPS
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta7

  • phosh is now at 0.10.0 series
  • update calls to 0.3.1
  • chatty is now at 0.3.0 Beta
  • megapixels is at 0.16.0 and mesa got updated to 21.0.1
  • more fixes to eg25-manager to stabilize the modem even more
  • Systemd is at 248
  • Bluez is at 5.57
  • we did a rebuild of Anbox to make it work again
  • uboot got renewed to enhance battery life
  • regular upstream updates and most of our Gnome Apps got updated to 40 series

A detailed list of package changes can be found here.

Currently broken:

  • Mic-Mute function in calls not working
  • GPS may not work as it should

Known issues

  • Megapixels might not show your back camera unless you had switched cameras once
  • it may take longer to wake up from deep-sleep mode when a call is incoming. Most of the time that call will vibrate only.
  • UI becomes unresponsive after a while.
  • Lots of apps are still missing or are not mobile friendly yet.


Device Phosh
PinePhone Beta8
PinePhone Nightly

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


Pinephones Beta Edition Pre-Orders start on the 24th of March! Don’t miss it !!! Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta9 here

  • Beta8 (2021-04-13) Download
    • based on stable branch
  • Dev (2021-04-30) Download
    • based on unstable branch
    • more Gnome 40 updates including Shell 40 and Mutter 40
    • fixes to atinout
    • updates to callaudiod, calls, chatty, phosh
    • more fixes to eg25-manager
    • feedbackd supports more fine theme adjustments
    • pipewire updates
    • mesa updated to 21.0.3
    • Pamac 10.1 is now mobile ready
    • we switched to Qt5 with KDE patches
    • uboot got updated to support 5.12 kernel
    • we use now 5.12 kernel series with patches by Megi. This extends also battery-life once again
  • Dev (2021-05-04) Download - StarWars Edition
    • based on unstable branch
    • Gnome Apps got updated to 40.1
    • updates to phosh, phoc, calls and chatty
    • eg25-manager got enhanced gps management
    • Megapixels is now at v1.0.1
    • Siglo is at 0.7.0

Just to let you know the top line of this post still says:
" … proud to announce our fifth BETA release …"

It should say “eighth” instead of “fifth”, but we know what you mean.

Just downloaded and flashed. I’m unable to unlock the phone using the usual 123456 pin. Any suggestion ?

Nothing changed with the default unlock digits. Maybe try to type them slower.

Thanks! I’ve to type very, very slowly. … :smile:

As was mentioned in the previous thread which i also noticed, what is the reason phone apps seem to start much faster after this update? Calls, messages and terminal are the ones i tested and noticed a change in, but firefox did not have any noticeable change.

I have been using the Pinephone with Manjaro (Phosh) as a daily driver for several weeks now. Working from home, I find that this phone works for calls, sending simple text messages, listening to podcasts, news reading (liferea), and general web browsing (including youtube). The phone can do more, I simply don’t do more with it.

What I hope the developers of phosh address in a future update are:

  • Extending battery life to 8 to 10 hours without recharging will be nice.
  • Chat (text messaging) support for sending/receiving multimedia files (e.g. photos) will also be nice.


I’ve flashed Beta8 to the eMMC, via Jumpdrive and Balena Etcher and it seems the SIM card isn’t recognized. The same is true for Beta6 on eMMC, and yet it is recognized and functional (voice, text, data) using Beta6 on SD card. Anyone have any suggestions?

Upon manipulation of the SIM card and re-flashing Beta8, I can report my issue below is resolved. I have a nano inside a micro sim wrapper. I still do not have a reason for the difference between SD card and eMMC .

I’ve noticed the bluetooth button toggle seems to activate airplane mode, rather than turning off bluetooth only.

After receiving an update yesterday, Chatty does not launch. The error is the following:

warning: chatty: local (0.3.0_beta+15+g6477649-1) is newer than community (0.3.0_beta2-1)

How do I down grade to the community version?

Any advice will be appreciated because Chatty is very useful.

Note: What would cause this conflict? For example, updating using the software center app versus the command (sudo pacman -Syyu).

Keep up the great work!

That does not look to be a downgrade to me, likely a version comparison issue that may need to be resolved. However, to “downgrade”, you can run sudo pacman -Suu

Thank you! I will wait a bit for the issue gets resolved with an update should it be released in the near future. I will look if it is reported, and if not, see if I can figure out how to report it.

Since updating to beta8:

  • I can no longer receive, send or even read SMS messages (it does not work, does not even open the app).

  • Randomly the lockscreen does not unlock (typing in the correct code, and regardless the screen is being returned indefinitely to the lock screen - only a forced restart by holding the power button worked)

try typing slowly: I had the same trouble

thanks for the tip :slight_smile:

The lockscreen glitch was technically “less than an issue”, in compare to the SMS functionality entirely not working

@kern707 the problem with the SMS not working is because a missing library used by chatty which is really not missing but was just upgraded and it’s name changed. To fix it just do the following using the terminal

cd /lib
sudo ln ./ ./

Now you should be able to open chatty without issues :slight_smile:

1 Like

Thanks so much! This worked for me. Really appreciated it.

Hello! Thanks for your work! I newbie in Manjaro on Pinephone, but is it correct when app center does not work?
“Data lock” - in app center, cannot update of course
Why geany in store is have proprietary license?

The solution is to simply reinstall the newer beta2 of chatty: sudo pacman -S chatty

Just want to thank everyone involved in this development! I have been using the pinephone with manjaro/phosh since beta 4. With each update this system is getting noticeably better. By now, it suits me as a daily driver. I’m in the US on black wireless, which is essentially AT&T. Calls, texting (after fixing the latest issue noted above), web browser, contacts, email, calendar, and other basic features seem to work reliably. Again, thanks for the hard work!!

I updated our changelog including a new image for you to test.