Manjaro ARM Beta6 with Phosh (PinePhone)

Manjaro ARM Beta6 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our fifth BETA release for the PinePhone running Phosh!

This image is running the 5.11 kernel from Megi, which is designed for the PinePhone.


  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function we had to remove
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps with working GPS
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta4

  • we are using now eg25-manager in combination with modemmanager to manage the modem.
  • callaudiod 0.1.0 will allow user to pass arbitraty data to async functions
  • calls 0.3.0 got patched to support new callaudiod
  • profiles of feedbackd are now applied and functional, including LED usage
  • chatty got many fixes
  • Kernel got updated to 5.11.1
  • Phosh is now at 0.8.1
  • pipewire got renewed to 0.3.22
  • squeekboard got a new release: 1.12.0
  • Mesa is now at 20.3.4
  • firefox is now at 86.0-1
  • regular upstream updates

A detailed list of package changes can be found here.

Currently broken:

  • Mic-Mute function in calls not working
  • GPS may not work as it should

Known issues

  • Megapixels might not show your back camera unless you had switched cameras once
  • it may take longer to wake up from deep-sleep mode when a call is incoming. Most of the time that call will vibrate only.
  • UI becomes unresponsive after a while.
  • Lots of apps are still missing or are not mobile friendly yet.


Device Phosh
PinePhone Beta6
PinePhone Nightly

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


Pinephones should be soon in stock after CNY. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.



If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta7 here

  • Beta6 (2021-02-28) Download
    • based on stable branch
  • Dev (2021-03-10) Download
    • based on unstable branch
    • update calls to 0.3.1
    • chatty got more fixes
    • phosh is now at 0.9 series
    • more fixes to modemmanager, networkmanager and eg25-manager to stabilize the modem even more
    • pipewire is now at 0.3.23
  • Dev (2021-03-15) Download
    • based unstable branch
    • fixed Headphone/set jack detection
    • screen fades to black for 5s before it turns it off on proximity
    • firefox is at 89.0.1
    • some fixes for gnome-contacts and gnome-control-center

After the latest update on stable branch, seems that the modem is lost each time after resuming from deepsleep.

Please get the latest image and flash it to an microSD and test again. On my end it works totally fine.

Yes, probably the update in the stable branch didn’t correspond to the release image. Now seems that all is OK. After reflashing I caught no modem losing during several hours and 6-7 resumings from sleep. Also I’ve got 1 call and 2 SMS with correct notification and without delay. I’ll continue testing tomorrow, but hope that the only problem remains - permanently shining LED. Is it possible to turn it off completely for now?
PS. Great job!

Thank you for this great release of Manjaro ARM (Phosh) I use this next to the Manjaro ARM (Plasma Mobile) edition. Manjaro ARM (Phosh) I use for when I really need to run something stable, and Plasma Mobile is just for playing and bug-hunting. Hopefully PM will just get as stable as this in time. At least haven’t encountered any problems with this release so far. Also I do not have the same problem as Xeno. Maybe edition dependend somehow? Don’t know which edition you have, mine is the KDE CE. Keep up the great work!

There is a strange Bluetooth behaviour on this release which hasn’t been reproduced earlier. If Bluetooth was turned off using Settings dialog and then turned on again, all Bluetooth controls will be still disabled. The only way to turn them on again is reboot. Can anyone else reproduce this?

Can confirm I am experiencing the same behaviour. It’s toggled on but shows nothing.

That being said these releases are starting to be solid. Marvelous job!

With this update it seems that the modem is lost. It displays the following message within Calls:
Can't place calls: No voice-capable modem available

Output from uname -r:


I’ve been using my phone SIM in the pinephone since beta 5, and calls/sms are stable enough for me that I didn’t felt the need to switch back to my backup phone. Great work!

1 Like

Just curious… I’ve installed a microSD in the PinePhone and afterwards the boot process is blocked. The microSD card is formatted with extvat and works properly on the Pinebook Pro…

…is there a limitation of file formats for the microSD on the PinePhone?

is it the blue led? That is indicator LED so confirm any notifications in the top bar to make it go away.

Yes, it is the blue led. But it turns on each time before going to deep sleep even if there were no active notifications. In the bugtracker there was described possible cause of such behaviour and possible solution - but it hasn’t been implemented yet. Currenyly I’ve decided to use systemctl suspend command instead of power button to avoid this problem because permanently shining LED reduces battery life even more while it was too short initially.

1 Like

Beta 6: so far so good! Installed yesterday and this morning I received the first OTA update.
The call quality is good for the caller and the receiver. Tomorrow I will try the BT with different devices. If I make a comparison with the latest Plasma version available, I must admit that there is no comparison: now the phone is usable at least in its main functions.

The phone notifies you “due to inactivity the phone will suspend soon” this message might be the one causing it if you don’t check it. But checking would stop suspension, so might be a pretty weird design decision to introduce that message recently.

1 Like

OK, I’ve re-partitioned the microSD with an extended partition in ext4 format and all seems to be good now…

1 Like

sounds like a bug in the bootloader getting stuck on exfat format

Just wanted to mention that twitch via streamlink and vlc is running perfectly and much better then via a browser…if you’re curious install both streamlink and vlc and from terminal: streamlink webadress/streamername 480p as example, enjoy !!

  • Maps with working GPS

When I load up maps and press the locate button(bottom left), it says location services must be turned on, which they are(also shows no apps have asked for permission). I turn the service off and on, but I get the same result. It never asks for permission and keeps throwing the same error. I am missing something simple here?

ETA - I have tried with mobile data + wifi and without wifi(mobile only).

1 Like

Is it just my device, or has Anbox stopped working for others too?