Manjaro ARM Beta36 with Phosh (PinePhone / PinephonePro)

Manjaro ARM Beta36 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our thirtysixth BETA release for the PinePhone running Phosh!

Those images run the 6.4 kernel from Megi.

Features:

  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot (Pinephone only)

Changes since Beta 35

  • Kernel got updated to 6.4.16
  • Gnome got updated to 45.0
  • Pamac got updated to 11.6.0
    • gained Gnome 45 support
  • Firefox is renewed to 118.0.1
  • Systemd is now at 254.6
  • Phoc got updated to 0.33.0
  • Phosh got updated to 0.33.0
  • Phosh-Mobile-Settings got renewed to 0.33.0

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • xdg-desktop-portal-gnome gets installed as a dependency when you updated from Beta32. Remove it as applications may start slower than needed.
  • During a Call the Mic can’t be muted on Pinephone and PinephonePro
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Phosh
PinePhone (Pro) Beta36
PinePhone (Pro) Nightly

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Order

Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta36 here

  • Beta36 (2023-12-06) Download
    • based on stable branch
3 Likes

What’s the problem with the kernel staying at 6.4 for all this time? That’s 6 months old at this point. Would be nice to see that eevdf scheduler shine on a constrained device like this.

I tried this Beta 36 iso on my original Pinephone but it doesn’t boot.

Then i tried last Phosh-dev Release Release 202312230236 · manjaro-pinephone/phosh-dev · GitHub

And it works fine, after patching an udev rule to fix the frame flipping bug to fix the “UI becomes unresponsive after a while.” known problem.

https://forum.pine64.org/showthread.php?tid=17771&pid=117637#pid117637

But i see qgnomeplatform-qt5 and qgnomeplatform-qt6 are missing from the repos along with their dependencies adwaita-qt5, adwaita-qt6 and adwaita-color-schemes.

So all QT apps show the light theme instead of the dark one like before.

Any chance to put these packages on manjaro repos?

I tried qt5ct and kvantum but they didn’t work.

QGnomePlatform and Adwaita-Qt are unmaintained upstream. These were developed by a Fedora developer, and Fedora decided to drop support for them. See: https://jgrulich.cz/2023/08/22/qt-theming-in-fedora-workstation/ .

1 Like

No, they’re unmainted and no longer actively developed–That’s why Arch dropped them.

EDIT: It seems @Kevin_Kofler beat me to the punch. See his link above for even more info. :point_up:

See:

Fedora is now working on QAdwaitaDecorations. Thing is, they’re using patches for Qt5 Wayland that haven’t been accepted upstream yet.

See my WIP PKGBUILDs. Note that I have not tested them on ARM yet.

1 Like

Good to know there’s an alternative incoming for Qgnomeplatform.
Making it upstream sounds even better.

Thanks for the PKGBUILDs, i’ll see if i can find the time to test them.

Note that QAdwaitaDecorations (by design) only themes the client-side window decorations to look like GTK/GNOME/Adwaita. It does not theme the widgets, nor is it responsible for settings such as color schemes.

Right, I think Fedora is leaving that up to upstream KDE.

Here are examples:

polychromatic (Qt 5):

pacmanlogviewer (Qt 6):

I managed to build some 6.6 kernels for the Pinephones:

Will see when I find time to test these …

3 Likes

Thank you! It works well on pp and cpuidle is still functioning.

edit: it does work on stable. But on the nightly build it fails with rcu stall warnings at boot, pulsing backlight and modem does not appear

1 Like

Well, if you test this release, it still comes with the 6.4 pre-installed. If the image doesn’t boot with 6.4, then some non kernel related issue might be given: Release Release 202312310240 · manjaro-pinephone/phosh-dev · GitHub Today’s image should come with 6.6, which I might find time to test on my end …

No, the nightly worked fine with 6.4, but not after running update to 6.6.

edit: latest nightly with 6.6 preinstalled fails in same way as previous one after updating to 6.6 on it. Check the mkinitcpio log because it says errors were encountered when running for 6.6 on nightly, but not on stable.

When I updated PP (Nightly) on 2024-01-14, I noticed that several PulseAudio packages had been removed. Does this mean that the switch to PipeWire has been completed? :crossed_fingers: