Manjaro ARM Beta33 with Phosh (PinePhone / PinePhonePro)

Thanks for this, I noted my phone-screen waking up all the time :sunglasses: :ok_hand:
I noted since updating to beta 33 my phone drained the battery really quick, maybe this was the reason.

Is there a way to disable the suspending notification only? I never liked it even before this waking screen function and I actually like the idea of waking the screen for other, actually useful notifications.

1 Like

If I understand correctly this should work:

“It would be good if your distro could disable that notification altogether: I’ve added this here: phosh 0.28.0 · World / Phosh / phosh · GitLab
@philm This message is from Guido (Phosh dev)

Thank you for the additional information. I followed your link but I could not really see if there is something the end user (me) can do or is it up to the distro (Manjaro) to disable the automatic suspend-notification?

Indeed, this constant waking up from sleep cycle is really prohibitive of using the phone on battery.

My message was more to manjaro devs.

What users can do this do now is this (in terminal):
gsettings set sm.puri.phosh.notifications wakeup-screen-triggers []

1 Like

A warning to everyone:

Even though i did run this command:

gsettings set sm.puri.phosh.notifications wakeup-screen-triggers []

until I realized that the phone was waking constantly and checked here for a fix it seems that all the constant going to sleep and waking has broken the modem. The modem constantly disappears and sometimes reappears after a random amount of time. Even if the modem is online, as soon as an sms or phone call is sent to the pinephone the modem dies so I cannot be called anymore and receiving sms is highly unreliable (sometimes the open firmware can restore the missed sms).

It seems that this update essentially broke the pinephone as it is unusable as a phone.

During one of the short times the modem is online I managed to update the open firmware to the latest version, this did not help. I don’t know if there is anything else I could do in software to fix this, though I suspect that the hardware has broken.

Try flashing an older release that you know worked, and don’t update it, and see if the problem persists. It seems the recent big phosh update caused modem instability for many people, for me it’s same as trunorth said, that 4g drops to 3g more often than before, and sometimes the whole modem disappears and reappears.

Turning off notifications from “power” does not change the behavior.

But

gsettings set sm.puri.phosh.notifications wakeup-screen-triggers []

works.

Would it be possible if Manjaro would ship nautilus and gvfs-goa be default?
With these packages Nextcloud file integration from System settings will work out of the box