Manjaro ARM Beta33 with Phosh (PinePhone / PinePhonePro)

If you just use the phone as is you can even get one version you like and flash it to your internal memory called MMC. Newer versions you can then flash to a microSD card and test it out before you upgrade. Since Manjaro is a rolling release model we don’t archive older versions. There is a plan to create such an archive of which you may can freeze the OS to a specific date and stay there, but not now.

Mixing old packages with new ones is also not a good idea. Regressions can always happen. So if a specific version is working better, in this case calls, you may get the source code of the PKGBUILD and compile it for the version you are currently using.

Else you can simply keep a released version and avoid updating. It is a constant progress, but mostly with updates it gets better. It might also depend which modem firmware you may use. the stock proprietary or the alternate community firmware.

Testing daily builds is also a good idea to see what might come in an upcoming release. You’re just a flash to a microSD card away. The beauty is to be able to boot the whole OS from SD cards. Pop them out switch them, no touching the internal OS at all …


Install these packages:

At the same time they should remove conflicted packages (like pulseaudio and wireplumber). IMO that setup is only one which work with a guarantee when speaking on default Phone as phone audio :slight_smile:

I don’t know is it okay but I could share that old Calls package so you and other people can install it easier? If the downgrade command does not work then you don’t have that version in pacmans cache.
Because at the moment that Calls package from stable is not usable - it will crash constantly and unfortunately it will also crash constantly silently in the background so it is hard to notice (like incoming call → Calls crash → no sound or vibration → you don’t see it and before you forcefully kill Calls the app is semi-frozen aka. it will open but you can’t place or receive calls)
I would at least say cautiously that for a stable distribution we need to get another version of Calls :). I just tried this with fresh install and it is disaster xD.
I will try the version from unstable and report as soon as possible.

Phil and Alarrajavamma
Thank you for your replies.
Phil - I do DL and retain previous version and have a copy of Beta 31. Since 31 was so stable and functional for me I did not think to try 32 on an SD – silly me; never too old to learn, right?? I am using the stock modem firmware. I have avoided “community” firmware/software as I want to use the phone as my main driver and fear once I start using non-stock items will make it more difficult to debug.

Alarrajavamma -I have tried to follow the Pulse vs Pipewire discussion and your suggestion is an interesting one. I see my pacman shows Pipewire 1:0.3.70-2 on my phone - not sure why or if it is even loaded/called (remember I am not a developer and the discussion often gets too technical for me)

My tentative plan is

  1. Install Beta 31 on an sd card and see if it will work - at least get me back to where I was before I installed Beta 32 and 33. As I recall there was a major camera problem in 31 (green tint) that was eventually resolved - can’t recall how now, but It the solution greatly improve the camera, IMHO.
  2. May do the same for Beta 32 and try it from the SD card. I see it is listed as “Latest” even though there is 33 version also listed. It Beta 33 an unstable version???
  3. If 31 or 32 on the SD cards function properly for me, I may try installing the Pipewire family noted above and see if that fixes the problem.
  4. If it does not solve it I may re-install Beta 31 or 32 if they work from the SD cards.
  5. Finally, if all else fails, and last and for sure least I may have to return to my old fruit phone or buy a new one – please don’t let this happen - hahahahah.
  6. I am a pretty interested user. If there is some way I can help, feel free to ask.

Again thanks and if you have any further ideas let me know. Has anyone else reported this problem - loosing notification sounds?? Remember my phone is virtually a “virgin” phone with no real tweaks or additions.

I can confirm the charge limit is not saved, even when it correctly asks for root privileges when applying changes, and shows it being applied before restart. Clearly a bug somewhere.

Thanks for confirmation; good to know not me. Only included in my message as an example to demonstrate that I have tried/made only minimal tweaks to phone; use pretty much as is out of box. I think this is the way most people like me (ie non-developer/non-techie) would use it, but of course could be wrong.

I am still troubled/challenged by the loss of sound notifications starting with Beta 32 (no ring on calls or sound when new sms arrives) - very basic function and major issue of course. Plan to pick up a couple of SD cards today as per message 22.

The most obvious solution to that would be that you by accident change sound levels.

Have you noticed that there are two sound levels you need to worry about: internal speaker which is the common level, and then internal earpiece that sets level during call . I once wondered why i did not get notification sound even when i just had audio during call, and it was that internal speaker was accidentally set so low it could not be heard.

There are new packages now in stable branch, including a new calls and other mobile ones …

Awesome, Calls issue is now fixed :slight_smile:


1 Like

Seems something prevents me to get pipewire without plumber going: FS#75442 : [pipewire-alsa] [REGRESSION] Can't use pipewire-media-session

Phil - Might this in some way relate to my external speaker notification issue which persists??

Curiousier and curiousier. Discouraging because I like this phone!!

  1. Have checked all sound level settings several times, all set to max. ALSO if change Sound Setting to “Make Phone Call” can hear sounds in eyepiece (but not notification sounds).
  2. Not sure I fully understand Rolling Release, but I have saved previous Beta versions. Tried Beta 29, 31 and 33 from SD card. Still no notification sound from external speaker. ALSO no vibration either, which as I recall I would get for 1 sec on startup, but no longer. Sadly, beginning to think might be hardware issue (ie maybe USB-C Side Board which I gather contains ext speaker) ?? I have been very careful with the phone. Has been dropped once or twice in 3 years, but cannot recall if recently to be related to external sound problem. Don’t think so, but could be wrong.
  3. Is there some other way to check the external speaker function???
  4. This is new. Also noticing when when phone detects an incoming phone call - connection moves from moderately strong 4G to very weak 3G signal. When I hang up, signal returns to moderate-strong 4G. This seems rather odd and is new in the last couple of days since updates. Could sound issue be related to carrier and would it affect notification sounds??
  5. ALSO want to repeat that in Quick Menu - “Notification Button” shows highlighted “ON” BUT icon to the left is greyed out with a “!” warning sign. BUT the “Quiet” button is all highlighted, option plus icon.
    Any further advice/guidance would be much appreciated!!

connection quality worsening when phone is beside your head compared to on table etc. is expected.

Secondly, try this: use the side buttons to make volume to max. Then make a phone call, and during that phone call, use the side buttons to make the volume max again. You should see you are adjusting 2 different volumes, “internal speaker” “internal earpiece”

I’m just trying to give some (maybe far fetched) ideas what could be going wrong, i wonder because i have been riding manjaro since early alpha releases, and i never had audio issues like you describe.

edit: issues in point 5 you mention don’t make sense in most up to date UI, The button left of notification is rotation. And i don’t know what a “quiet” button means.

Thank you again. I too have not any any particular speaker sound problems up till recently - last 3 weeks or so.

  1. Tried your suggestion and indeed the sound sliders do move up and down when I press the volume control on the phone when on a call. When on a call, If I change the Output Source Configuration in Sound Setting from Make a Phone Call to Play WiFi Quality Music the Speaker Volume Slider also moves. The earpiece works fine it is just the external speaker that is not working. More and more I am thinking this is a hardware issue.

  2. Sorry was not clear about Quick Menu/Button stuff. On my phone, Swiping down from top brings up the Quick Menu. On my phone which I believe is now Beta 33, there are two sliders for screen brightness and sound at the top; then two columns left and right. On the right column there are 3 items; Wifi connection indicator, battery level indicator, and what I believe is the notification setting, which if I tap has 3 options, default is ON, then QUIET, and then SILENT. Each has a tiny symbol/ icon adjacent to the word - On, Quiet, or Silent. The “ON” setting the word ON is highlighted, but the tiny symbol/icon is grayed out AND has a highlighted warning symbol “!” on it. On the Quiet Option BOTH the word and the “vibration” symbol is highlighted, but the phone also no longer vibrates. And on the Silent Option, word Silent is highlighted, and the symbol/icon is also grayed out. I am GUESSING the non-highlighted symbols/icons mean this function is not working??? But I could be wrong. It is as if the phone is stuck in Quiet Mode.

  3. Also while in Make a Phone Call MOde I can hear the speaker test “Right Front/Left Front” in the earpiece. It is just the external speaker that is the problem. Real bummer!

1 Like

I just use pacman -Rdd
Not recommended, I know :slight_smile: but works

Unfortunately that sounds like hardware issue but you have nothing to lose :smiley:
Maybe try to install something completely different distro on SD card and try if the speaker works there?

Quick settings icon are just designed like you mentioned. So the settings are working and showing what they should show. I think that “!” symbol just want’s to tell that the phone is now in SHOUT mode :wink:

VoLTE not working for some reason? Then it will fall back to something not 4G/LTE, i.e., 3G or 2G.

this ships plumber: Release Release 202306140250 · manjaro-pinephone/phosh-dev · GitHub. maybe a provides will be a workaround …

Thank you (and the others) again for your suggestions. I will try another distro. I suspect it is a hardware issue, not sure how to confirm it, but if find a way I may order a new side board, but that is for another day.

The PP is near perfect for me and my use case, but reliability is critical.

In the meantime, after 10 mos of using the PP as my main driver with minimal problems which I could always resolve, it is with regret that I have had to set it aside and return to my fruit phone. The problem with notifications which I have been trying to resolve for 3+ weeks and the recent and curious cell connection level issues are major issues for me. If I find resolution with these I will share them.

Thanks again to all who tried to help me – very much appreciated!!

i am also similar issue on Pinephone pro. Now I cannot hear anything during call. i tried changing mode in sound but did not work. I hope next update resolve this issue.

There was some annoying issue related to suspend but it is easy to solve.

In Phosh 0.28 there was this new option: Allow notifications to wake up the screen.
And by default it on for “Urgent” notifications.
“Suspending soon” notification is now waking the screen and basicly preventing suspend :smiley:

So you need to disable that option like this:
gsettings set sm.puri.phosh.notifications wakeup-screen-triggers []

And btw suspend is way more better than it was before. Suspend will eat something like 1% in hour while it was before 2-4%. The actual % depends how do you run your modem :slight_smile:

1 Like