Manjaro ARM Beta33 with Phosh (PinePhone / PinePhonePro)

Manjaro ARM Beta33 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our thirtythird BETA release for the PinePhone running Phosh!

Those images run the 6.3 kernel from Megi.


  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot (Pinephone only)

Changes since Beta 32

  • Kernel got updated to 6.3.5
    • fixed regression in Pinephone power consumption during sleep (touchscreen was not disabled properly, consuming a lot of power)
    • added DRAM reclocking support to Pinephone Pro (needs Rockchip TPL/TF-A which is provided by uboot-pinephonepro-rockchip)
  • updated uboot for PinePhonePro to 2023.07-rc2 from megi-branch
  • Gnome Shell and Mutter got updated to 44 series
    • most applications are now ported to GTK4
  • alsa-ucm-conf 1.2.9 included a broken PP UCM config.
    • We are using the working from Mobian still
  • Firefox is renewed to 113.0.1
    • mobile-config-firefox might not work with it in portrait mode. remove the package.
  • Megapixels now supports newer kernels and got updated to 1.6.1
  • Python got updated to 3.11
  • Systemd is now at 253.4
  • Phoc got updated to 0.28.0
  • Phosh and Phosh-Mobile-Settings got updated to latest git-master commits to match phoc
  • Gnome-Control-Center is at 43.6
  • Phosh got updated to 0.28.0
  • Phosh-Mobile-Settings got renewed to 0.28.0

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • xdg-desktop-portal-gnome gets installed as a dependency when you updated from Beta32. Remove it as applications may start slower than needed.
  • During a Call the Mic can’t be muted on Pinephone and PinephonePro
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.


Device Phosh
PinePhone (Pro) Beta33
PinePhone (Pro) Nightly

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta34 here

  • Beta33 (2023-06-07) Download
    • based on stable branch

pp seems to have lost cpuidle support with the kernel 6.3

What was the “fix” again? Maybe it was not added to that branch of the kernel.

According to CPUIDLE not working on pinephone - #37 by philm, the fix was 0008-arm64-dts-allwinner-a64-h5-Add-CPU-idle-states.patch · 6.1-megi · manjaro-arm / packages / core / linux-pinephone · GitLab, but that patch is still being applied according to the job log you linked above, so that does not seem to be the issue here.

Well that patch was not added in 6.3.5-1 release. Hence test 6.3.5-2 which I linked.

Calls upgrade is extremely unstable.
Calls will crash constantly when receiving or placing calls and app is also really much slower.

Fix is to downgrade:
sudo pacman -U /var/cache/pacman/pkg/gnome-calls-43.4-3.aarch64.pkg.tar.zst

But maybe it is good idea to not upgrade calls at all?

Please uninstall xdg-desktop-portal-gnome

I allready uninstalled it.

I’ll add this fix and you can test it in revision 44.1-3 from unstable branch: mm-origin: Don't unref origin in call_deleted_cb (!699) · Merge requests · GNOME / Calls · GitLab

'Thanks, it works again with this kernel installed. Hopefully it can be fast-tracked to stable.

There was an excellent surprise in this release :).

If you have wireplumber installed install snapshot from flatpak.

Without any other tweaks you have ability to record videos like you do with normal phones. Video (and pictures) are in the wrong position but this just works wow.
Video recording with Cheese does not work. And if you have not installed wireplumber it most likely needs one reboot.

Somehow playing the videos will crash the system with Clapper and mpv but it works with VLC.

I don’t know why this was not advertised (while it is no where near perfect) but this is one of the biggest milestones in mobile linux?

I just noticed this with Pinephone Beta (not pro).
I need to test this tomorrow with Pinephone Pro and I am quite sure it will work also there.

And to be noticed that wireplumber will breake audio routing after calls - it does not route audio back to speaker when call ends. So if you need working ringtone don’t install wireplumber.

Same here (a Manjaro ARM Plasma Mobile installation upgraded to the latest stable update set, with the kernel from the Manjaro GitLab CI linked above, CPUIDLE works):

[kevin@plasma-mobile ~]$ inxi -M | grep -v serial
  Type: ARM System: Pine64 PinePhone (1.2) details: N/A
[kevin@plasma-mobile ~]$ uname -r
[kevin@plasma-mobile ~]$ sudo cpupower idle-info
CPUidle driver: psci_idle
CPUidle governor: menu
analyzing CPU 1:

Number of idle states: 3
Available idle states: WFI cpu-sleep cluster-sleep
Flags/Description: ARM WFI
Latency: 1
Usage: 386990
Duration: 377989024
Flags/Description: cpu-sleep
Latency: 2300
Usage: 0
Duration: 0
Flags/Description: cluster-sleep
Latency: 2350
Usage: 0
Duration: 0

This is because libcamera is now supported (to some extent) on the original PinePhone. (The PinePhone Pro has already had this for a few weeks.)

That said, there are some limitations:

  • The front camera produces only errors, only the rear camera is detected correctly.
  • The qcam test program from libcamera-tools works, sorta. The image is rotated by 90°, but otherwise it seems to work.
  • plasma-camera does not work. Neither out of the box nor even when I run it with libcamerify, with or without gst-plugin-libcamera installed. Unfortunately, GStreamer exposes the hardware implementation details to applications, e.g., applications can be specifically hardcoded to use the v4l2src and then not work with libcamerasrc. This should really be an implementation detail and not visible to the application at all, but alas, that is not how GStreamer works. plasma-camera uses QtMultimedia, so presumably QtMultimedia needs to be fixed to work with libcamera. If it has not already happened for Qt 6. (Plasma is still stuck on Qt 5.)
  • kamoso does actually work with gst-plugin-libcamera. (Note that Kamoso uses QtGStreamer, not QtMultimedia.) Of course, there too, as in qcam, the image is rotated by 90°, but otherwise it seems to work. In addition, the image is mirrored by default, but that can be disabled in the settings.

EDIT: Actually, the mirroring is a kamoso feature (designed for desktop webcams, not useful for smartphone rear cameras) and does not happen in qcam. I have updated the above text accordingly.

Well, some say if you want to use pipewire instead of pulseaudio you may use pipewire-media-session for now. I had no time to test if calls work as expected with it. Plumber is known to have the issue not to switch back. We should be more noisy in this issue post and do some more debugging for upstream: [PinePhone] Audio switching after PhoneCall not working properly (#156) · Issues · PipeWire / wireplumber · GitLab

There must be something wrong with plasma as i have never seen it output zero for the deepest sleep states on phosh, is plasma just that more resource hungry?

Maybe because I have suspending disabled when plugged in (this can be set up in Plasma Mobile if you manually bring up the desktop configuration dialog for power management instead of the mobile one), and the phone had been plugged in since bootup when I ran the command? Or should CPUIDLE trigger even when the phone is not suspended?

On phosh i have it to not go to deep sleep on external power (default), and never even immediately after boot have i managed to get idle-info that was zero on 2;n or 3:rd level of power saving.

cpuidle should work all the time, minimizing the power use when cpu is idle (what was it’s name again?) :wink:

It is indeed not related to suspending or not when plugged in. I had it unplugged now, and I am pretty sure it was suspended, but the sleep states still show 0 use. Only ARM WFI (wait for interrupt) is used.

there seems to be significant difference in it’s functioning between kde and phosh

I am new to this Forum. If this is the wrong place to post, please advise accordingly, but I need some help. First let me say a BIG thank you to all those who are working on this project!!! You are doing a great job! Sorry this is long, but I thought it important that I give as much detail as I have.

I have been using PP (16Gb) w/ Manjaro Phosh as my daily driver for nearly 1 yr., though have played with Manjaro OS on the PP as far back as Alpha 3 (2020). My phone needs are very very basic and simple, phone calls, SMS/MMS, the odd pic, a calendar, clock, and calculator. I backup Contacts and some pics on an installed SD Card. NOTE - My expectations are in line with a low cost/low power phone. On the top of my list is reliability over bells/whistles. I suspect there might be other potential users like me who are looking for a basic reliable/inexpensive alternative to the 2 big players.

I am not a Linux developer/programmer, but have been using Linux (Debian based) for over 5 yrs and am relatively comfortable with the cli (but prefer GUI). My PP is what I would call “nearly virginal” – no app additions, virtually no tweaks (trying to limit charge to 85%, But it does not save this setting), etc; just running what comes stock with Manjaro Phosh; this minimizes confusion when something goes wrong. Up to now I have been about the problem-solve and correct.

In my experience, Beta 31 was by far the best version to date; pretty much everything worked (minor camera issue which was resolved) and most importantly it was relatively very reliable. There were/are several more minor issues which I would be glad to share, if interested and are not a deal breakers for me.

Starting with the Beta 32 update, problems began to (re)appear with basic functions, in my case the most critical was loss of call/ SMS sound notifications (led light still works).

I updated to Beta 33, hoping this would improve things, but problems got worse (extremely slow loading of apps and occasional crash); overall the phone seems less stable. I decided it was time to join this Forum a) to see if there is some solution to the sound issue and b) offer some help.

  1. As noted in the Forum, I uninstalled xdg-desktop-portal-gnome*which solved the Beta 33 slow app loading (btw when I updated to Beta 33 , I selected Option 1 which seemed to be the default as it was listed first. **Now I see I should have selected Option 2.

2.My biggest problem --I have not been able to resolve the sound notification issue. Once or twice in the last 2 days I have temporarily had a call/sms sound notification, but it eventually stopped working. When I “Test” the external speakers in Settings, there is no sound. Also in the Quick Menu, the Notification Option says “ON”, but shows a greyed-out icon and a highlighted Warning (!) mark. As suggested above, I tried downgrading calls using sudo pacman -U /var/cache/pacman/pkg/gnome-calls-43.4-3.aarch64.pkg.tar.zst ,BUT received a “cannot find file or read package error. When I checked var/pkg folder there is no 43.4-3 listed.The last one is 44.1-2. I tried 43.3-2 and received the same error message, even though it is listed in pkg. I have checked my entries several times to make sure I typed it correctly. I have not used Sudo before on Manjaro – it asks for the Manjaro PW which I enter. I am not sure what I am doing wrong at this point. Please help.

  1. I am thinking my only option may be to do a fresh install and revert back to Beta 31. Thoughts.
1 Like