Manjaro ARM Beta30 with Phosh (PinePhone / PinePhonePro)

Manjaro ARM Beta30 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our Thirstiest BETA release for the PinePhone running Phosh!


Those images run the 6.1 kernel from Megi.


  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot (Pinephone only)

Changes since Beta29

  • Kernel is now at 6.1.12
  • Chatty is at 0.7.0
  • Firefox is renewed to 110.0.1
  • phosh is at 0.25.2, phoc at 0.25.2 and phosh-mobile-settings at 0.25.0
  • pipewire got renewed to 0.3.66
  • Systemd is at 253.1
  • Uboot Firmware got updated to 2023.01
    • this may bring better power management for the Pinephone Pro
  • mesa got refreshed to 22.3.7

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • During a Call the Mic can’t be muted on Pinephone and PinephonePro
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.


Device Phosh
PinePhone Beta30
PinePhone Nightly

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta30 here

  • Beta30 (2023-03-13) Download
    • based on stable branch

Am I the only one who hasn’t been able to launch the Megapixels app for a while? Does it work for others?

When I tested this image it worked for me on the OG PP. There were some changes on 6.2 kernel series which break the app.

1 Like

I have the problem even on kernel 6.1. But definitely thank you for the information.
(BTW, OG PP means HW before the release of PP Pro?)

With Beta 30 Stable Megapixel works (there was some releases where it did not work - maybe 27 and 28?).
But postprocessd does not work out of the box - I just removed it and installed it from the AUR and that one was working.
So you must be using Nightly?
(I am talking about PP - and in general OG PP means HW before PP Pro)

Pinephone Pro is not ready for daily use but if anyone wants to use it for calling it is not possible. Can you please check this issue. I did make those changes and after that you can use PPP for calling - without those changes no one can hear you.

PPP callaudio is really mess but at least if you change those lines other person can hear you :slight_smile:

@philm I am unable to open the “settings”, this bug existed in the previous release, I have updated yesterday to Beta 30, hoped that maybe this issue will resolve it self, I am still unable to open “settings”.

When I tap on “Settings”, it shows the background (app “loading” behavior), but nothing ever loads.

Is this issue known? what can I do to make it work?

My PinePhone is the non-Pro, Convergence Edition (3GB internal memory, 32GB eMMC)

version information:

Manjaro ARM Release 23.02
Linux 6.1.12-1-MANJARO-ARM #1 SMP PREEMPT Thu Feb 16 11:20:53 UTC 2023 aarch64 GNU/Linux

1 Like

I have the same thing, also on an original PP 3GB/32, also on 29 don’t know about earlier.
Sometime also other applications don’t start the first time, but do on retry. But the settings never works.

Chromium Fonts are transparent. Wayback before Beta 25 Chromium worked. Slowly, but perfectly. At some point The fonts on all webpages and settings became invisible. In Plasma we can turn off anti aliasing in the os settings, but that causes more problems. Fonts become unreadable in every app. Chromium is the only app that this affects. Is there a way to fix it inside chromium only.

I found the solution to this Chromium invisible fonts. Under Chrome://flags>search for Ozone>Choose Wayland from drop down menu. I know this does not seem to be important to many people. I hope it helps someone.