Manjaro ARM Beta3 with Phosh (PinePhone)

Isn’t the only difference that Lomiri immediately goes to deep sleep whenever you push the power button to lock the screen while Phosh has at minimum a 5 minute timeout before deep sleep kicks in?

The convergence dock no longer works at all for me. If connected the phone will start to charge, but the device does not indicate it will dock. If a mouse is plugged in it will turn off when the phone is connected. I assume these are all power issues as well?

EDIT: after allowing the phone to charge until it wasnt charging anymore, the dock worked again, and the keyboard and mouse did as well. Once connected, the Powersupply app showed 0 capacity, 0 voltage, although the charging indicator said it was charging.

By the way what is the preferred method for follow up? Reply to myself or edit like I did here?

You can adjust that timeout in settings if you want. Lomiri on the other hand has a total different power management from UI also, which is not given with Phosh yet.

I have to try out the dock more with the PMOS CE Phone and the Manjaro CE Phone. There are small hardware differences in these editions. But yes, the power management still needs improvement.

“Yet” as in it is planned to be ported there? :slight_smile: Admittedly, I had a much better battery life when running Lomiri Alpha1 so that would be a huge improvement for Phosh as well.

I’ll try decreasing that timeout to something shorter to see if that improves anything. Given that wakeup from deep sleep has been quite stable recently this shouldn’t cause many problems, right?
For posterity:

$ gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 120

This will set the timeout to 2 minutes.

I just received my Pinephine Manjaro E, i started it up, all seemed fine :slightly_smiling_face:
Then i tried to upgrade to Beta 3, in terminal, all files/programs are downloaded, but when it shall upgrade, i get that some pgp keys need to be imported.
When i say “y” to allow the import i get the error message “import pgp key ‘CAA6A59611C7F07E’ could not be looked up remotely”.
I started the upgrade with “sudo pacman -Syu”
appreciate any help that i can get.

Try sudo pacman-mirrors and sudo pacman -Syyu.

Hmm, that is odd. Is an old problem it seems.

gpg --keyserver --recv-key CAA6A59611C7F07E

Nice Work so far.
But I have 2 problems with the keyring.

  1. Unfortunately the keyring doesn’t get automatically unlocked when unlocking the phone.
  2. The prompt for the keyring is over the regular login/unlock screen.

Hopefully this hasn’t already been answered… But the app store on my recent Beta 3 install doesn’t work. I’ve adjusted my date and time to be correct and already pulled one update. But when I attempt to use the app store I’m just given a blank screen.

It doesnt populate, its blank for everyone. But you can search and it will find software you can add. Then when you install it may say that it cant or wont install, but it does, depending on the application, but it actually will. With some applications I had to restart the phone to get it to work right. Gnome Web and Libre office for example.

Is everyone experiencing very slow app launch times? e.g. 10 seconds to launch firefox

I half expected this would be the case, just looking for some sort of indication that it’s normal at the moment.

Yeah, that matches with what I’m experiencing too. I’m not worried about it just yet.

Does anyone have a guide to install anbox? There’s a couple apps I’d like to keep from Android (“Our Groceries”, “Kindle Reader”, and “Logitech Harmony” if you care :slight_smile: ). Or maybe there’s better solutions?

Pretty sure I installed using the command below:

pacman -S anbox anbox-image

I installed it on beta2 and it wasn’t working but after upgrading to beta3 it actually runs.
Though I haven’t been able to test installing any apk’s yet as i only tested it a few minutes ago.

Thanks, that got it installed. For me it perpetually says “starting”.

Starting in the terminal, it complains about unknown keymap and hangs. Looks like it’s almost there…

Actually there’s new icons appearing, and they seem to work! Very cool!

I have tried “pacman-mirrorsandsudo pacman -Syyu” and also
“gpg --keyserver keyserver.ubuntu. com --recv-key CAA6A59611C7F07E”
I also tried the other solutions, from the “old problem”.
But i still can´t upgrade, get below error message now:

:: Proceed with installation? [Y/n] y
(126/126) checking keys in keyring                      [#############################] 100%
downloading required keys...
:: Import PGP key CAA6A59611C7F07E, "Philip Mueller <>"? [Y/n] y
error: key "CAA6A59611C7F07E" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
[manjaro@manjaro-arm ~]$`

Hi All,

I am getting frequent crashes with firefox with the Beta3 release. The issue did not occur initially with Beta3, just when I received a subsequent update a day or two ago. When firefox crashes, the screen goes black with a blinking cursor in the upper left. I launched firefox from a terminal to see if that revealed useful information post-crash; however, it didn’t because it seems the desktop environment restarts and the terminal is gone.

Anyone experience the same?

Look forward to the next release…


Sometimes after deep sleep the modem is crashed and does not start or establish a connection to the provider