Manjaro ARM Beta3 with Phosh (PinePhone)

I am on a recently delivered PinePhone CE Manjaro with Phosh (3GB ram), just installed all new updates directly from the Software application (was a breeze!), and had a short over run on various apps and functionality.

I can already confirm, that on my PinePhone, while using the Megapixels app, although the switching action is still VERY slow- I can now switch between the two cameras (front / back) without the app freezing on me, this is great progress for the camera functionality!

I also love the new “swipe to close” action for closing apps, much smoother and more intuitive than the previous “x” button action.

The next thing would be to thoroughly test the call functionality with most importantly - the return from deep sleep on an incoming call etc… that is IMHO a very important theme.

One big deal (for me), is that I am still unable to type certain foreign languages on the keyboard despite of adding that keyboard and switching to it - English characters are shown on the virtual keyboard, as well as when I type - English characters are typed in.
This perhaps happens only with the more exotic languages, (e.g. German works, but less popular languages do not, e.g Hebrew? and maybe Russian? despite being available to add as a keyboard)
Any clue?

I am still fiddling with the various apps and screens.
If I will find any functionality which does not work correctly, I will update with a bug report

Thank you Manjaro-arm team for the progress done, keep up the great work!

1 Like

Love to see new beta releases so quickly!

I have the recently released Pine64 Manjaro Community edition and an update message coinciding with beta3 is not received (even when using pacman -Syyu as root). I thought this phone came with the beta release of Manjaro mobile and would receive updates to beta releases; however, I could be incorrect about this.

Is there a way to confirm I have a beta release installed?

Is manually updating to beta3 required?

Thanks in advance,

1 Like

For example, you can use “pacman -Q | grep mesa” in the terminal. When the command prints “mesa 20.2.2-2”, the system is up to date.

1 Like

Unboxed my Pinephone CE Manjaro yesterday, and its been through two update cycles and working better than when I got it. This is a lot of fun.

The new swipe to close is better than than tap to close, I like it. I added glances to get more detailed system information, and it works.

At first I couldnt get VLC to work, but once I used the scale-to-fit VLC, I could see that there was a hidden accept dialog that I couldnt see before.

I added KDEconnect previously, I may try and add it again, but it pulls a number of KDE dependencies in with it. I wonder if there is something else I should use. I know I could just ssh.

I use qownnotes for Nextcloud note integration on my desktop, I wonder what I should use for the pinephone.

Is there a wiki for the Manjaro Pinephone or is it all lumped into manjaro-arm?

Thanks again for the work!

The other odd thing is how often the software session says that something cannot be installed because it is not supported, but it installs anyway. I suppose I could, and should, do all installations in the terminal to watch what is actually happening. But it does make me want to take a look and see if the message is just a warning that the app is not set up for mobile use, not that it cant or wont install.

The factory image was released on the 18th of October, Beta1 on the 16th of October. If you read the changelog of beta2 you will see that some images got based on testing or unstable branch. Only Beta1 (2020-10-27) was based on stable, which was the first update for Pinephone CE Manjaro. As documented on the changelog of beta3, the second update was then Beta2 (2020-11-09). Which concluded in the 3rd update as of Beta3 (2020-11-24). So if your kernel says 5.9.9-1, you most likely are up to date.

Thanks philm! I managed to do the update.

Although initially I was unable to update to Beta3, sometime after I posted the message above, I tried ‘pacman -Syyu’ as root and a message appeared stating updating failed to prepare transaction due to a conflict with “rtl8723bt-firmware-megi”, as well as a y/N prompt asking me to remove the already installed rtl8723bt-firmware. I chose ‘y’ to remove the already installed bluetooth firmware and the update proceeded. There was a second y/N prompt due to a conflict with another already installed package, which I recall was wlroots.

Once I chose ‘y’ for both prompts, the update proceeded. I walked away from the pinephone to let the update complete.

Approximately 10 to 15 minutes later, I returned and found the lock screen enabled with the time and a few icons display. I swiped up to unlock and entered the user password; however, the phone refused to unlock. After trying and failing to unlock the phone, I decided to hold the power button down for five seconds to force the phone off and then pressed the power button again to boot up again. I figured that being root in a terminal made the lock screen not accept the default user password (only numbers appear on the unlock screen).

The pinephone turned on normally and I was able to unlock the phone using the user password. I checkeked the kernel installed with ‘uname -r’ and it is 5.9.9-1, so I think my pinephone is on Beta3.

Thanks again! Thanks for those who provide updates to the system. I look forward to checking out this latest release.

Cheers!

Exactly the same thing happened to me, but I’m booted up again and it’s looking slick. Good job!

@philm A short update:

I have just noticed that since the latest beta3 update, my PinePhone is experiencing an abnormal battery drain, even when the device literally sits on my table untouched for several hours, the battery is unable to get fully charged - just looked at my device after it was charging for 2 hours untouched, the charge level stays around 80-81% at all times, almost seems like the battery is having difficulty trying to cope with the drainage. this was not so bad before the beta3 update.

is there any possible explanation for this ? was there any change made in beta3 that might cause the battery drainage issue to worsen instead of improve?

thanks

1 Like

Have similar problems with power consumption since the update. The device starts discharging from about 85%.

I think the Charging Functionality w/ Convergence Dock is broken.
No HDMI output while charging through Dock.

Beta 3 / 5.9.9-1
PinePhone PmOS CE

The PinePhone loads exactly to 4.2V. It’s a restriction by Megi Kernel and Drivers to prevent the battery catching on Fire or overheat.
At least that’s what a dev of Arch ARM version said, which is using Megi Kernel aswell.

2 Likes

Thank you for your answer! That’s right, the voltage is displayed as 4.2V. Shouldn’t the charge level actually be 100% at this voltage?

1 Like

Geri: Thank you for your answer! That’s right, the voltage is displayed as 4.2V. Shouldn’t the charge level actually be 100% at this voltage?

There is a good explanation about PinePhone battery.
I think I am not able to post links. Even with a fix for 4.35V.
Search for “xnux eu” Website → Devices List → PinePhone (Detailed Information) → Battery/USB Power

Haven’t tested it. Not going to, since 80-90% is good enough for me. :slight_smile:
Since it’s able to charge further I don’t think 100% would be accurate. It’s a minor flaw I can gladly ignore since it doesn’t really impact my usage.

1 Like

The megi kernel should only charge to ~89% unlike older ones.

In addition to this check that you have plugged in the charger after DE starts loading. At least for me the phone only charges at 0.5A if i leave the charging cable plugged in during boot, i need to reconnect it after DE started loading to reach full 1A charging speed. If you run any applications in the background 0.5A is not enough to charge, or it will take many hours to raise even 10% in battery indicator.

Regarding Battery. Yes the Megi kernel prevent you from charging it fully up to 100%. Only 80% on Phosh or 89% on Lomiri. You may want to read-up on how a PinePhone can be a risk and what can be done to prevent it.

So I’m happy testing Lomiri on battery to see what we may get. Phosh on the other hand needs more power in terms on how you configure it. Lomiri is mostly programmed to save battery all the time:

2 Likes

Isn’t the only difference that Lomiri immediately goes to deep sleep whenever you push the power button to lock the screen while Phosh has at minimum a 5 minute timeout before deep sleep kicks in?

The convergence dock no longer works at all for me. If connected the phone will start to charge, but the device does not indicate it will dock. If a mouse is plugged in it will turn off when the phone is connected. I assume these are all power issues as well?

EDIT: after allowing the phone to charge until it wasnt charging anymore, the dock worked again, and the keyboard and mouse did as well. Once connected, the Powersupply app showed 0 capacity, 0 voltage, although the charging indicator said it was charging.

By the way what is the preferred method for follow up? Reply to myself or edit like I did here?

You can adjust that timeout in settings if you want. Lomiri on the other hand has a total different power management from UI also, which is not given with Phosh yet.

I have to try out the dock more with the PMOS CE Phone and the Manjaro CE Phone. There are small hardware differences in these editions. But yes, the power management still needs improvement.