Manjaro ARM Beta1 with Phosh (PinePhone)

Manjaro ARM Beta1 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our first BETA release for the PinePhone running Phosh!

This image are running the 5.7 kernel from, which is designed for the PinePhone.


  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function we had to remove
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps with working GPS
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-unstable. This can be changed by editing /etc/pacman-mirrors.conf
  • This image uses a Crust enabled uboot

Changes since Alpha4

  • calls is now able to dial local network numbers incl. service numbers
  • Gnome got updated to 3.38 release series
  • We added Gnome-Authenticator
  • Most apps got ported to libhandy1
  • Megapixels gained autofocus feature
  • Squeekboard supports now emojs

Security notice:

  • update your system to the latest kernel to fix bluetooth bleeding tooth issue

Currently broken:

  • N/A

Known issues

  • it may take longer to wake up from deep-sleep mode when a call is incoming. Most of the time that call will vibrate only.
  • UI becomes unresponsive after a while.
  • Lots of apps are still missing or are not mobile friendly yet.


Device Phosh
PinePhone Beta1

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


You can now pre-order the Manjaro CE Edition and the Manjaro CE Convergence Package of the Pinephone!

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.



If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta2 here

  • Beta1 (2020-10-16) Download
    • based on stable branch
  • Beta1 (2020-10-17) Download
    • based on unstable branch
    • updated kernel to 5.9.1 with better sound-stack
    • updated ALSA-UCM profiles for kernel 5.9 series
    • Gnome 3.38.1 updates
    • updated Network- and ModemManager
    • Known Issues: Camera is not working
  • Beta1 (2020-10-18) Download
    • based on unstable branch
    • fixed camera issue
    • updated Phosh, Phoc and Squeekboard
    • Known Issues: Due to MR631 v6 Phosh starts in docked-mode
  • Beta1 (2020-10-24) Download
    • based on unstable branch
    • updated packages: alsa, firefox, freetype, mesa, phosh, phoc, squeekboard
    • docked-mode issue got fixed
    • geary-mobile removed
  • Beta1 (2020-10-27) Download
    • based on stable branch
    • same changes as with 2020-10-24 release
  • Beta1 (2020-10-29) Download
    • based on unstable branch
    • enable 60 FPS
    • fix HDMI output
    • update phosh, phoc, firefox, gstreamer
    • torch works now with upower
  • Beta1 (2020-11-04) Download
    • based on unstable branch
    • proper fix HDMI output
    • usage of callaudiod for better audio experience with calls
    • update phosh, chatty and alsa-ucm audio profile


I can’t believe this phone got GNOME 3.38 before my desktop :stuck_out_tongue: Any videos maybe so we can check it out?

1 Like

Onscreen keyboard does not work

OMG - the so called stable Beta looks very unstable :frowning:

If modem sleeps deep incoming call could not be received

Works for me.

It seems as though I’m able to receive text messages, but I can’t seem to open the thread for a given text to see it’s full content. I also am having problems making calls (I didn’t in the alphas), where I continuously get ‘Call Failure’.

Update: I can open text threads in which I initiated the text, but receiving a text I can’t seem to open within the chats app. I also can’t receive photos via text.

MMS? he said, completely without hope.

You must be a very lucky guy.
Either you got a golden phone or some magic has improved your software image…

Same here.
This build feels rather unusable, to be frank.

  • Localisation doesn’t work (after selecting my native language and rebooting, the interface is still in English)
  • WiFi seems to be very unstable
  • The vibrator just goes off for no reason and doesn’t stop.

Hard to conceive of the PP being shipped with a build where the keyboard doesn’t work, really. I thought Mobian was quite rough around the edges, but a build without working text input? How could this pass testing? Yes, I know that this is a volunteer effort and I don’t want to sound like a complaining customer but still, this seems like such a basic flaw that should be spotted immediately. Why wasn’t it?

  • The localisation BUG is present since minimum one month and not fixed
  • Keyboard BUG was not present on the first BETA

There is a firmware update for the modem, which may improve call audio or, if you are very unlucky and somethingGoesWrong™, break the modem… (you have been warned).

Already done, no change in problem “cannot receive calls”

@zash1958 ,@jro check if the phone is in Docked or Unlocked mode from the notification bar. This one got me confused for awhile there - for whatever reason it defaulted to Docked and the on-screen keyboard was never showing :grin:

Thanks!!! Worked!

The numpad in the phone application seems to only be able to input numbers. Long-pressing 0 produces just 0, not a +. I also cannot input # either. So I cannot call/type any international extension number, like +421…

Can anyone confirm this bug on their end too?

Yup, happens to me as well.
I don’t have plasma mobile or Lomiri to try at the moment (I definitely need more sd cards).

For the international numbers you can try to use 00421 instead of +421

1 Like

Another issue seems to be, that while I have 4G connectivity when not in a phone call, during the phone call, the signal reception seems to always automatically switch to 2G. Maybe a similar problem as described here: adamlabay net/2020/07/03/update-consistently-successful-calls-on-pinephone-with-ubports?

Isn’t this normal mobile phone behaviour? My Nexus 5X running Android also does this.