Manjaro ARM Beta25 with Phosh (PinePhone / PinePhonePro)

Да ви имам ъпдейтите! After the last update I can’t unlock the phone.

What is the problem with package “kio-5.93.0-1”? After a new installation, when updating, this problem appears. I’m using KDE connect. In beta 23 and now in beta 25 update it appears.

@philm i have compiled a kernel based on your gitlab using some patches that fixes all the suspend / wake issues. The pro has the over sensitive mic issue now and I am not sure if it is due to the patched kernel, community modem firmware or the old issue with alsa-ucm-pinephone package. Is anyone else having the very sensitive mic and the other person on the call hearing an echo?

With this patched kernel this phone is daily drive able for sure, just this mic sensitivity issue. Last time on my OG pinpehone I was able to use pauvucontrol to lower the sensitivity of the mic and fix the issue until that alsa-ucm-pinphone package was reverted, this does not work for the pro nothing seems to effect the mic sensitivity.

maybe open an issue and share your patch for review.@kmsgli

@philm my plan was to pull your gitlab and make another repo, the patches are not mine the mobian community made the patches along with the community firmware for a winning combo. I am very new to the github workflow so still trying to traverse pull / merge requests. I am re installing now to try one more fix to solve the mic issue and will report back.

1 Like

@philm I opened an issue and attached the one patch file as well as a modified PKGBUILD to compile the kernel, this solves all issues with suspend as far as I can tell but it does not solve the mic sensitivity issue which I can not seem to solve.

did you see this from the bibtorgj firmware guide?

Microphone audio is too loud during phone calls ( distorted audio and lots of background noise from your side )

Edit the ALSA UCM config file /usr/share/alsa/ucm2/PinePhonePro/VoiceCall.conf and look for the following parameters:
    IN1 Boost
Change the default value from 8 to 3 ( YMMV you may need to go a bit higher or lower, but 8 is way too much in my testing ).

it also contains a fix for the suspend issue so maybe you don’t even need the kernel patch?

Well, if we talk custom firmware then yes. Mostly we concentrate on the proprietary firmware for the modem. Those rules got changed in upcoming eg25-manager already. I’ll check the Mobian patches, which might not yet been part of the Megi kernel.

The latest phosh update (phosh-0.20.0beta3+4+gd4728aea-1) results in the UI locking up after unlocking the screen.Downgrading to the previous version (phosh-0.20.0beta2+4+g5027b9c3-1) fixes this.

1 Like

these are the current Phosh versions:

  • stable 0.20.0beta3+4+gd4728aea-1
  • testing 0.20.0beta3+15+gdf8eff99-1
  • unstable 0.20.0beta3+24+gbe421af4-1

@dsj maybe get the latest development build of today and test the latest phosh from unstable branch to see if the upcoming 0.20.0 fixes your issue.

@varikonniemi
That does not work for manjaro I have tried lowering IN1 Boost to 3, 2, 1, and 0. I have also tried a fix the mobian guys found using alsamixer to lower the mic gain to 0 with no fix either.

Also the fix for the modem suspend is to leave the modem powered on during suspend (thats what one of the patches is for) but this can not be done without the community firmware. Setting auto to on will only allow the modem to stay powered on during suspend if you use community firmware not for the modem with stock firmware.

Both those fixes work for the audio and the modem staying powered up during suspend (if on community firmware).

The only issue is the mic sensitivity.

interestingly enough, those recommended settings for the OG pinephone do the trick and I have been using the community firmware for a month or so now with great results, especially getting some sort of call waiting back has been huge!

@philm is the unstable branch already changed the eg25 settings? Should I give that a try?

you can always follow my changelog on this OS image. use our packages service to see when the eg25-manager package hits our stable branch.

So its kind of rock and hard place. Stock firmware has no echo but the modem takes to long to wake when the phone is suspended. Community firmware modem doesn’t sleep but echo is had. Based on talking to biktorgj his firmware doesn’t have noise cancellation like stock and the PPP routes sound to the cpu differently the then OG PP which is why his firmware works fine on the OG PP.

The sound fix patch biktorgj made does work regardless of modem so I think that useful to add as that solves half the suspend issues.

1 Like

Hi, I have the same issue as @dsj do.
Phosh since 0.20.0beta3+4+gd4728aea-1 breaks when I try to switch apps.
Tried version 0.20.0+2+g4a93126f-1 from unstable - it has the same issue too.
And the weirdest thing is that it occurs only on OG Pinephone, while Pro one is fine.

For now I’ve managed to fix it by replacing phosh with phosh-next.

There is a workaround for the swipe up infinite loop bug.

Enable the animation in Tweaks or in command-line:
gsettings set org.gnome.desktop.interface enable-animations true

The bug has been reported here Infinite loop when opening app switcher with `enable-animations=false` (#818) · Issues · World / Phosh / phosh · GitLab

2 Likes

Thank you very much, workaround worked for me

Thanks very much, this works. Bit of an odd workaround… I imagine we won’t be the only 2 to experience this though! :roll_eyes:

At least I know now why the echo was so bad, I didn’t realise there was a thing with the open source firmware having no echo cancellation. Can’t see an issue logged, but there are some related ones …

Using the custom firmware is not recommended. It might be even illegal in some countries to do so …