Manjaro ARM Beta2 with Plasma-Mobile (PinePhone)

I finally got around to trying my phone.
I assume the KDE SMS app is for text messages. When I open the app, it says no devices. How does one send a text message?
Is the SD always required or is there a flashing process?
Also it does not seem to charge more than 84%.

1 Like

It’s for SMS/MMS. To send a text message, you need to have a contact phone number in.

You can flash to the internal eMMC, just like on any other board.

1 Like

you are right of course :wink:
tag added.

1 Like

Sure! You will get everything simply by updating the system.
Unstable now also has more newer updates available.

1 Like

Mobile network don’t work I tried what some one mentioned in beta 1

It worked for a few seconds then it drops and then I tried run that command again and it only gives me an error message.

Call worked
I am using CBB a Danish telecompany and on all other distribution whit phosh mobil network also works.

Modem don’t wake up after deep sleep only wifi so reboot is required to use call again.

Would be nice whit a contact app which synced whit online acc like phosh does…

But overall I really like plasma and the polished UI is top nice, ihope functionality will be prioritiesed soon
:sunglasses:

Also it does not seem to charge more than 84%.

This might explain it.

@oberon This could be added to known Issues

Ok, successfully flashed the image to the emmc and it now boots in the image.

First tests, calling…

My carrier is AT&T. Incoming calls work without an issue. I have not yet tested while it is in sleep.

However, for outgoing calls to my wife, also on AT&T, I hear a beep instead of a ring and she does not receive a ring but her led light indicates an incoming call. If she answers, the call works as expected.

If I call a land line, I hear a normal ring and the call connects and works as expected.

Text messaging works with the Spacebar app. But how do you delete them?

Edit: It seems I can not activate the data network. Do I need to contact my carrier to activate this phone?

1 Like

Hey @0n0w1c ! Did you try the ofonoctl command to set the DNS resolvers?

sudo ofonoctl wan --connect --append-dns

DNS resolution isn’t automatically set for me either, so I’m thinking I might get systemd to execute it at startup, maybe.

2 Likes

That worked! Thank you very much.

[kde@plasma-mobile ~]$ anbox check-features
You're running Anbox on a not yet supported architecture

How does Anbox work on Phosh then?

I have done:

sudo mkdir /dev/binderfs
sudo mount -t binder binder /dev/binderfs
sudo systemctl start anbox-container-manager

and then…

[kde@plasma-mobile ~]$ anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewActivity
[ 2021-01-26 18:03:11] [daemon.cpp:61@Run] [org.freedesktop.DBus.Error.Timeout] Connection timed out
  • can’t do anything modem related after wake from sleep. e.g. phone sleeps once, no more modem access until reboot. US AT&T. I did receive a call when it was sleeping once
  • this wake from sleep problem prevents me from receiving text messages - permanently. I can’t access text messages that were sent when the modem was asleep, even in other OS’s
  • settings app isn’t accessible after wake from sleep as well, perhaps related
  • have to manually append DNS still to use data
  • can’t use nextcloud with a locally signed certificate - Chromium/angelfish won’t allow self-signed certs, tried to use Firefox, but it is completely unusable - perhaps adopt Phosh’s firefox config and give users the option
  • the keyboard is a nice layout, but I can’t get rid of it when I want to or bring it back when I want to

overall, no reliable phone functionality. layout looks nice, but I would like to use it as a phone.

The keyboard sure could use a [ctrl] key.

I was able to place/receive phone calls with pinephone running Plasma Mobile Beta 2 but noticed that the keypad doesn’t work during a phonecall. For example, interacting with a voicemail system to delete messages using keypad. Doesn’t seem to work yet. Very encouraged by the progress of this version of Plasma Mobile. Keep up the great work!!!

Alarm dosent go off i gues deep sleep is preventing it
Phone calls get disconnected and some times it gets disconnected whit out hanging up…

Hi all,
I am so sorry but I still have problem (with modemmanager ?),
I can’t use Manjaro at all (PM, Phosh, ubuntu touch).

[kde@manjaro-arm ~]$ ofonoctl list
No modems found
[kde@manjaro-arm ~]$ systemctl status ModemManager
* ModemManager.service - Modem Manager
     Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2021-01-30 17:07:07 CET; 10min ago
   Main PID: 3729 (ModemManager)
      Tasks: 3 (limit: 1995)
     Memory: 6.9M
     CGroup: /system.slice/ModemManager.service
             `-3729 /usr/bin/ModemManager

Jan 30 17:07:06 manjaro-arm systemd[1]: Starting Modem Manager...
Jan 30 17:07:06 manjaro-arm ModemManager[3729]: <info>  ModemManager (version 1.14.10) starting in system bus...
Jan 30 17:07:07 manjaro-arm systemd[1]: Started Modem Manager.
Jan 30 17:07:10 manjaro-arm ModemManager[3729]: <info>  [base-manager] couldn't check support for device '/sys/devices/platform/soc/1c10000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1': not supported by any plugin
Jan 30 17:08:30 manjaro-arm ModemManager[3729]: <info>  [base-manager] couldn't check support for device '/sys/devices/platform/soc/1c10000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1': not supported by any plugin
Jan 30 17:13:52 manjaro-arm ModemManager[3729]: <info>  [base-manager] couldn't check support for device '/sys/devices/platform/soc/1c10000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1': not supported by any plugin
Jan 30 17:17:17 manjaro-arm ModemManager[3729]: <info>  [base-manager] couldn't check support for device '/sys/devices/platform/soc/1c10000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1': not supported by any plugin

[kde@manjaro-arm ~]$ systemctl status ofono
* ofono.service - Telephony service
     Loaded: loaded (/usr/lib/systemd/system/ofono.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2021-01-30 17:07:06 CET; 10min ago
   Main PID: 3605 (ofonod)
      Tasks: 1 (limit: 1995)
     Memory: 3.0M
     CGroup: /system.slice/ofono.service
             `-3605 /usr/sbin/ofonod -n

Jan 30 17:07:05 manjaro-arm systemd[1]: Starting Telephony service...
Jan 30 17:07:05 manjaro-arm ofonod[3605]: oFono version 1.31
Jan 30 17:07:06 manjaro-arm systemd[1]: Started Telephony service.
Jan 30 17:07:24 manjaro-arm ofonod[3605]: parse_devices_reply: found 1st battery device: /org/freedesktop/UPower/devices/battery_axp20x_battery

[kde@manjaro-arm ~]$ mmcli -S
successfully requested to scan devices
[kde@manjaro-arm ~]$ mmcli -L
no modems were found
[kde@manjaro-arm ~]$ mmcli -e
error: no modem was specified
[kde@manjaro-arm ~]$ mmcli -B
ModemManager daemon 1.14.10 running

I have tried Mobian, PostmarketOS ← works fine for me, but sometimes disconnect from Telekom network and I can make/recive the calls, reboot fix it (I can’t reboot phone 10x per day)

I used donate button because pinebook with manjaro works great, thank you, but pinephone is unusable at this moment obviousli just for me :smiley: should I wait for kernel update ?
thank you

1 Like

I am not sure but somthing has happrned because calls has worked fine om Phosh but no longer does . I dont know if it’s relater to the current kernel or?

1 Like

hello, plasma-mobile version dev 20210211 flash on emmc

a lot of stuff works.
I did a full report on gitlab d on real-life telephony.
we cannot say that it does not work … but there is interference with the wifi if it is cut or restarted

sometimes in long sleep the telephone closes permanently

likewise the keyboard keys to delete a voice message do not work

apart from that the Plasma-mobile moves and becomes something good

if anyone this is how to save my phonebook would be welcome

Hey folks,

first of all, thanks for your great work and progress.

Does anyone know how to lock the screen again without previous authentication i.e. if you just want to know the time?
And has anybody managed it to use wayvnc yet? I just get a somehow wl_roots related error.

1 Like

I was watching some Youtube videos last night about this. They were recent posts from 4 and five days ago. I am most intrigued. I have to get a new phone because of the pending 3G sunset. My cell phone needs are basic, partly because I am not a gamer. So the idea of a Pinephone running the same OS as I use for my desktop seems pretty revolutionary.

Im having trouble importing my contact.
Im using google csv format… Anyone know how to get the contact importing?