Manjaro ARM Beta2 with Phosh (PinePhone)

I have a new PinePhone CE with “5.9.1-9-Manjaro-arm” installed with Phosh, and I acknowledge the same issues from B, D, E

I’m getting “Authentication type of wifi network “Name of network” not supported” while setting up the device Did get the same with beta 1.

Did seem to work fine with postmarketOS earlier today

Some quick questions.
Is gstreamer supportet on Arm, cant find it, need it to watch videos with Gnome Web?
Does your phonenumbers from the simcard get imported, if yes where?
Please correct me if i am wrong, but you use Chats to send sms, can only send online messages so far?

Not a genius to linux but learning, so be gentle

kernel 5.9.8-1 seems to have broken bluetooth. The indicator icon is displayed but settings app says it is off and keyboard does not work. i did never boot into 5.9.7-1 so it might also have been broken there. All other versions have worked fine.

Thanks for the tip on using Nemo. The Nemo program is nice in that once I changed to displaying folders/files as icons with names, Nemo remembered the setting. So, that is quite convenient. Just recommended that icon be used by default; however, it is early development and this is probably very low priority. I cannot wait to try out other parts of this pinephone manjaro device.

I tested out the bluetooth connectivity of pinephone manjaro with Beta2 by syncing it with a pair of inexpensive over-the-ear bluetooth headphones (Srhythm NC-25). Making the bluetooth connection between the phone and these specific headphones was easy, and the audio was heard using the headphones. These headphones have four buttons on right side for increasing/decreasing volume, on/off/pause, and enable/disable noise canceling. I tested by listening to a podcast I downloaded using the podcast program on the pinephone. The only function on these headphones that did not work was pressing the button to pause the audio. The volume buttons worked, although a long press did not progressively increase/decrease the volume. I had to repeatedly press the volume up/down to get the audio volume to change.

Overall, the bluetooth works quite well with these specific headphones and the podcast program that came pre-installed on the phone.

Can’t get wg-quick working.

  1. command resolvconf not found, fixed by installing openresolv package
  2. RTNETLINK error, not resolved
[#] ip -6 rule add not fwmark 51820 table 51820
RTNETLINK answers: Operation not supported
[#] ip -4 rule add not fwmark 51820 table 51820
RTNETLINK answers: Operation not supported


with a connected mouse I can do it. But why I can not do it with my fingers if I want no add a physical mouse ?


I’ve updated my Pinephone from Beta1 to Beta2 with “pacman -Suy” and put comments in the Beta1 thread.

Thermal information : temperature for cpu 76°C without Wifi or Bluetooth - hardware swith set to off.


I would use the Pinephone as my regular phone. I’ve added a name in the Contacts application but this contact is not visible in the Calls application.

How to import my contacts (from the SIM card or the VCF files) in the Contact application or the Calls application to use it to dial a phone number ?

Kind regards.

Yes everything will be the same except for the uboot as for uboot you need to flash it to the drive you’re booting from.

Once you see the image on hdmi you can drag the mouse to the right side if the mobile screen to move to hdmi screen.
Now you can open any app on mobile screen and hold its title and drag it to the hdmi output screen and resize if needed.

This is a community based support forum, so feel free to ask for support as we’re all friendly here and like to help if we know how the topic in discussion.

sudo pacman -Ss gstreamer
This will list you all thr gstreamer pkgs as there are multiple of them.

Not automatically but I think address book or contact app should have import functions from sim card.

Oh well chats is the name of the app used for sms, is that what you asking about? Sms from sim card works fine maybe you got confused by the name of the app.

It need a new firmware pkg
sudo pacman -S rtl8723bt-firmware-megi

Either thermal sensor have some issue or it is actually getting that hot.
Most likely hardware issue.

This should be inside contacts app settings yo import I am not sure about this but I will check it.

And Welcome all the first time users on Manjaro Forum.


What’s the additional SSH host key for in /etc/ssh?


The file is empty.

Thank you! Bluetooth is working again. Why was this replacement not done by pacman?

Now the only new issue is that the latest update removed the close buttons on the program icons when selecting running application, cannot close programs any more :smiley: probably due to the new phosh version

edit: apparently you are now supposed to swipe the apps to close like on lomiri. This is certainly an improvement as hitting the small close button was sometimes missed and the app instead popped up.

With FbReader, when in the application, the landscape mode is chosen, the screen goes black for one second and display again the book. The time between two black screens if variable, but it’s permanent.

The UI is always in portrait mode in this application.

The USB-C doc bar is not connected.

P.S. : Correction -> UI always in PORTRAIT not ‘landscape’ mode. Sorry.

Coz the kernelsource have been changed and there are more 2 source for pinephone.
This made us maintain 2 Bluetooth packages.

I mean if the phone does not work without the new package, why did pacman not ask me to replace it like it does with other similar situations?

Should “Explore” in “Software” show anything?

Possibly waiting for when megi’s kernel replaces the current one in the next beta.

beta is stable branch not unstable, so replacing it in unstable should not interfere?

So, as we’re all on stable, is there a testing branch, or just unstable and stable?