Manjaro ARM Beta2 for PineTab

When I restart my Pinetab after removing/moving icons or change the wallpaper on Plasma Mobile it seems like all those changes reset to the default icon/wallpaper configuration. Is anyone else experiencing this?

EDIT: Playing with this some more I noticed that this only happens when you reboot. If you shutdown or force power off by holding the power button, the icons and wallpaper configuration does not revert to the default.

I just now grabbed the Plasma-Mobile image and am getting loaded onto a uSD card. While I wait:

What are the current projected plans to get this (these?) images included in the manjaro-arm-flasher?

We are working on it. :wink:

I assume you’re waiting for beta flag to fall away?

Actually working on getting the Manjaro ARM Flasher to find them where they are.

Could someone shed some light into the behavior of the Tab when in a TTY?

On the Lomiri image, after the last update I ran the GUI failed to start, just gives me a flashing cursor on screen.

I booted it up today, switched to TTY from the flashing cursor on screen, and told pamac to update. It got to finalizing the update for linux-5.11 and the screen just went black. No buttons, keys, or touch will turn the screen back on. I’ll have to hard boot. However, given where the screen went dark in the update process, I don’t want to do a hard boot if there’s a chance that the Tab is still on/working, and the screen just won’t show image.

Would this behavior be to turn off the device entirely or just the screen?

EDIT: I waited about 30m till hard booting it again, and it seems the update didnt fix the issue. should updates, or a specific branch be avoid in general for the lomiri img?

No lomiri packages have been updated for a while.

Do you have any logs to indicate why the GUI don’t start?

It seems all the updates i’ve gotten have primarily been base system updates. I’ll mount the SD in a chroot later and look for some logs.

Which display manager does Lomiri use? (I’m sure it’ll help narrow down the logs i need to look through.)

i think lightdm

thanks for confirming @clover

@Strit here’s where the snippet of the log where lightdm tries to start and fails: manjaro lomiri - pinetab - Pastebin.com

Latest online update broke the tablet installation. It seems to boot but display remains dark.

Is the newly update and it’s display driver only for the first (braveheart) edition of the tablet?

Check your extlinux.conf file.

Is the correct DTB used?

LABEL Manjaro ARM
KERNEL /Image
FDT /dtbs/allwinner/sun50i-a64-pinetab-early-adopter.dtb
APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200        root=PARTUUID=e4fc0753-02 rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

Seems to be the right one? How are named the 2 versions of the tablet?

early-adopter is the one sold to consumers by Pine64.

And it’s the only one currently supported by our kernel.

You can try changing the dtb to the regular PineTab one and see if that works.

What phrase I have to enter for the regular version?

Just remove early-adopter from the line with dtb and it should pick up the other DTB.

Now have installed a fresh Beta on a new SD card. … 300 packages to update and 710MB. Let’s see if this works

Installation and 700MB update now worked flawlessly

System boots and is usable. But I find no way to config the keyboard from Pine to my german keyboard settings. The virtual keyboard could be configured to use germen keymap. But for the Pine keyboard I cannot find any possibility to do it.

Yeah, I don’t think the interfaces have a method for that, so you probably have to use good old localectl.

localectl status

System Locale: LANG=de_DE.UTF-8
VC Keymap: de-latin1-nodeadkeys
X11 Layout: de
X11 Model: pc105
X11 Variant: nodeadkeys
X11 Options: compose:rwin

But konsole and external keyboard remain in en_US

Correction: have done one more reboot and now the keyboard works in DE mapping :slight_smile: