Manjaro ARM Beta13 with Phosh (PinePhone)

Well, flashing the firmware to a newer one is kinda easy for user willing to do it. However doing a dump of the current firmware is a little tricky.

Most of the software for the pinephone is targeting 01.002.01.002 firmware. So having that is good. However, this also changes how calls get handled as in 01.001.01.001 firmware. So some want to be more cautious before updating. They want at least a backup of the current firmware.

Based on the discussions I had with Pinephone developers, the alternate firmware is the way to go, but it might have some legal issues.

I’m currently testing and preparing a new flash guideline which should have most things covered. As I’ve a Pinephone almost having a touchscreen dying, that can be used for some flashing experiments …

Thanks for all the info here and in the next few posts. I did post the issue a few days ago, but saw no responses, so I wan’t sure I put it in the right place. I’ll add details there rather than continue the “hijacking” of this thread.

No, the sim card has only ever been in the PinePhone. I’ve tried going back to Beta 12 on an SD card, but I haven’t had any luck getting a successful flash, hence the aforementioned Mobian experiment, which yielded the same result (no incoming text, but other communications functions working).

Seems I had experienced the same behaviour. I had installed Beta 12 and during some time it worked almost ideally - almost all calls and SMS were received normally in sleep mode. But after several days (while I had not installed any new updates) SMS stopped be received in sleep (till phone reboot). I’ve updated the phone, and now SMS work ideally but there are no incoming calls in sleep mode, as I’ve already written. Currently I’m still using the original modem firmware.

A complete manual for reflashing modem firmware, with Manjaro specifics taken into account, is badly needed. Unfortunately, I can’t do any experiments there by myself because I have no second device for testing (and it is very difficult to order it to my country). So I can only ask for it, hoping to provide some possible help with testing/further development later :pray:

Hi Xeno,

A reflashing firmware guide specifically for Manjaro is not needed AFAIK, you can just follow any ‘Pinephone firmware flashing guide’ you can find, for example the one found on Pine64’s Wiki page :slight_smile:

You may want to flash the alternative 0.3.1 firmware. At least on my end it worked to get calls from deep-sleep again.

Currently I’ve already flashed the 01.002.01.002 firmware which seems to be the most stable according to documentation. The flashing was completed successfully, and I’m very thankful to all who helped me. Now I’m going to test it for a while, hope that it will be enough and there will be no need to flash some new firmwares again.

Upd. Unfortunately, this firmware also causes missed calls. Probably I’ll try the “alternative firmware” a bit later. What firmware is mainly used by Manjaro development team for testing now?

The alternative firmware is more flexible. However, I just pushed some fixes to our unstable branch. Tomorrows daily build might have them for easy testing.

@philm @fch I found a solution to my texting issues here and closed issue 200. The long and short of it was that there were a bunch of binary texts “clogging” the SMS intake. Judicious use of mmcli fixed the problem (and all my test texts from the past week came streaming in all at once).

thanks for your suggestions through this issue.

With the Beta 12 => 13, and now that Beta 14 is out… I seem to have a repeating issue with the Software tool when OS Updates are released… even though they are listed in the Software Tool and I am prompted to install them…
Unable to install updates: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_2dengine_2derror_2dquark.Code1: Prepared update not found: /var/lib/PackageKit/prepared-update

If I use Portfolio to browse the disk, there are only 2 elements under the /var/lib/PackageKit folder… a file named transactions.db and a folder named alpm

I have usually been able to work around the issue in the terminal with sudo pacman -Syyu… but I’d really like the Software tool to be able to install/deploy the OS updates normally.

Are there some commands I can run to return my OS Updates to function normally so that the prepared-update file is generated?