Manjaro ARM Beta11 with Phosh (PinePhone)

Manjaro ARM Beta11 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our eleventh BETA release for the PinePhone running Phosh!

This image is running the 5.12 kernel from Megi, which is designed for the PinePhone.

Features:

  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta10

  • kernel is now at 5.12.8
  • added a workaround to Calls to mute the Mic during a call. We are working on a better approach, though.
  • fix headset button handling and jack/mic plug in/plug out detection
  • updated UCM profiles based on upstream changes
  • more changes to Phosh including better support for Asian languages
  • we updated modemmanager for quick suspend/resume
  • fixes to kernel and uboot-firmware to stabilize RAM speed. Users can try again higher clock speeds
  • pipewire is now at 0.3.28
  • calls got updated to 0.3.3
  • pamac is at 10.1.2
  • systemd got updated to 248.3
  • fixes to Phosh to support Japanese and Asian languages better
  • Squeekboard is now at 1.14.0
  • chatty got updated to 0.3.1
  • Mesa is on 21.1.1
  • PostmarketOS Tweaks is at 0.6.1
  • we updated the Upower profile to power off as needed when the battery is low
  • updated patches for eg25-manager to stabilize the modem further
  • fixed issues with feedbackd to find themes
  • Siglo got updated to 0.8.2
  • small fixes to eg25-manager
  • wake-mobile got added and Anbox updated
  • regular package updates

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • You may loose the modem often. If that is the case call systemctl edit --full ModemManager and then edit --test-quick-suspend-resume to become --test-no-suspend-resume
  • it may take longer to wake up from deep-sleep mode when a call is incoming. Most of the time that call will vibrate only.
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Phosh
PinePhone Beta11
PinePhone Nightly

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Order

Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta12 here

  • Beta11 (2021-06-04) Download
    • based on stable branch
  • Dev (2021-06-09) Download
    • Based on unstable branch
    • Pipewire got updated to 0.3.29
    • More fixes to Chatty got added
    • We added Confy to the profile
    • Most of the Gnome packages got updated to 40.2
    • Firefox got updated to 89.0
    • libinput ins now at 1.18.0
    • We updated the Kernel to 5.12.9
    • libxcrypt got renewed to 4.4.22. See also this issue if you miss to change your password and land on a terminal after rebooting your phone!
    • Mesa is now at 21.1.2
    • We updated modemmanager to 1.16.6
    • siglo is now at 0.8.4
    • We use now upstream uboot 2021.04 with needed patches
    • We no unblank screen on incoming calls and only enable proximity on active calls. See also here
  • Dev (2021-06-14) Download
    • Based on unstable branch
    • Fixed pacman keyring gpg-keys issue. This also includes the fix for dropping to terminal on first boot.
    • Pipewire got updated to 0.3.30
    • Calls is now at 0.3.4
    • More fixes to eg25-manager
    • Gnome got updated to 40.2
    • libxcrypt got updated to 4.4.22. You’re phone won’t boot unless you have changed your password. This image already switched password-hashes
    • Kernel is now at 5.12.10
    • Mesa got updated to 21.1.2
    • Pacman got updated to 6.0
    • Pamac got updated to support latest pacman version
    • Uboot got updated to 2021.04
    • Regular upstream updates
  • Dev (2021-07-02) Download
    • Based on unstable branch
    • Pipewire got updated to 0.3.11
    • Bluez is now at 5.59
    • Chatty is bumped to 0.3.2
    • eg25-manager got some fixes
    • Firefox is at 89.0.2
    • Mesa is at 21.1.3
    • Phoc is at 0.7.1
    • Phosh got updated to 0.12.0
    • Some additional fixes to Squeekboard
5 Likes

Problems with the Keyring ?!

(45/45) Überprüfe Paket-Integrität                                                   [------------------------------------------------] 100%
Fehler: gawk: signature from "Arch Linux ARM Build System <builder@archlinuxarm.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/gawk-5.1.0-1-aarch64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: m4: signature from "Arch Linux ARM Build System <builder@archlinuxarm.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/m4-1.4.18-3-aarch64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
...

That has helped me:

sudo pacman-key --init
sudo pacman-key --populate archlinuxarm

normally not: lib/functions.sh · master · manjaro-arm / applications / manjaro-arm-tools · GitLab

i encountered and posted about same issue in previous thread when running testing, weird it has not been fixed. Or are you updating from previous beta/testing?

Anyhow, the manjaro wiki should be updated to indicate the -arm suffix for arm platforms when fixing issues.

Thank you for the continued and frequented updates.

For me, my biggest hang up is chatty does not receive text messages. I am thinking that this issue may be due to the APN used, which is mobilenet. My carrier (t-mobile) indicates a different APN; however, I cannot see the ‘save’ button in the Settings for Mobile Broadband in Advanced Network Connections to try a different APN. Hopefully, the UI for this app will get more optimization for the PinePhone Phosh screen.

I did have the broadband modem disappear after the phone was not used for 6 hours over night and rebooted the PinePhone to re-enable calling.

The apps I use most often are:

  • Liferea (news reader installed via Software)
  • Podcast (default app)
  • Firefox
  • Clocks (timer for brewing coffee in the morning)
  • Geary (reading new emails)
  • Chat (receiving texts)
  • Calls/Phone (mostly rejecting incoming calls)
  • Terminal (checking and installing updates)

Cheers!

2 Likes

You can just add another APN and go back one screen, it will save automatically :slight_smile: On the previous screen you can then select it as your current APN.

1 Like

Thanks for the quick reply. I hadn’t thought of creating a new broadband connection. I tried it but unable using the Advanced Network Connections utility because much of the UI of this app is unseen and not possible to navigate the wizard to create the broadband connection.

I’m having an issue with losing the 4G icon and the possibility to call and be called. The Calls application then shows a red bar stating it’s not possible to place calls, since no modem with voice functions available (in Dutch). Restarting the phone does not help. Switching off and starting it up, doesn’t help either. The only thing that works for me is switching off the phone and disconnecting the battery shortly. I think this issue is related to charging the battery, but it doesn’t happen always while charging.
I’m using the stable Beta 11-version, without the changes from the 9th of June. Anyone else with this problem?

Update: I managed to create a new broadband connection in the Advanced Network Connections. The Advanced Network Connections is a nice tool because it has a wizard that will conveniently set up what appears to be common mobile providers with the appropriate APN. I used this wizard.

Unfortunately, I still don’t received incoming plain text messages. I can send, just not receive. Not sure if the cause is user error (me) or an update.

Will post a fix when I figure out what it is.

If anyone has a suggestion on the best method for fixing (reinstall, search internet for specific terms, post request at a specific site), chime in. Otherwise, I will bumble along.

Thanks goes to those of you who put time into maintaining software on this phone. Appreciate the work.

1 Like

Hi fariid - I have had the 4G icon disappear occasionally. I also reboot to fix it. It does seem inconsistent. It has gotten better recently. I am patiently waiting for future releases to improve, mostly because I am a non-technical enthusiast and not able to debug/fix software.

I’m with T-Mobile as well and experiencing the same as described as above. No received texts.

I didn’t go thru the advanced configure app yet, just set the apn in the settings. Will try that next. Thanks for your reporting, having same carrier it’s been v useful.

with testing fully updated the phone does not seem to ask for PIN again if entered incorrectly. Some weeks ago it still did. Now i needed to go to settings → mobile and unlock.

Thanks for the reply message. Good to know my experience is not unique. Will file a bug report unless there is a reason not to.

I’m afraid I got another noob question. My apologies.
With the latest update my PinePhone has started randomizing its MAC address which is kind of fatal since I’m using MAC filters.
/etc/NetworkManager/conf.d/disable-random-mac.conf is already set to

[device]
wifi.scan-rand-mac-address=no

In fact, I have never touched this file. Yet, the MAC still keeps changing.
Any help would be appreciated.

Update:
I also tried the WiFi settings menu on phosh. Defining “cloned address” does not make any difference whatsoever, no matter whether it’s “stable” or “permanent” or any of the others. The phone will still come back with a new WiFi MAC upon rebooting. Defining a “hardware address” will offer me the current wlan0 MAC as an option. If I choose it, I won’t be able to connect after rebooting since that MAC will no longer exist.

A new question crossed my mind: Is it possible that the MAC address is not generated by NetworkManager but rather something else? If so, what might that be? FYI, my PinePhone is as stock Manjaro as it gets.

I assume I cannot be the only person affected by this. Any hints?

I set my number w/I a username or pw as per TMobile apn instructions in the advanced network connections app and I am getting about 90% of texts. Not all of them tho

Decided to test out my bluetooth earbuds since I saw some updates pertaining to Bluetooth coming across the unsable branch yesterday. Had no problem connecting to the earplugs and went on to Youtube to try to play a video. As soon as the video started to play, i loud buzzing sound started to play in the earbud. Disconnecting / rebooting didnt seem to help. Not sure what i can do to troubleshoot the issue. I do know that they used to work on Beta 9, possibly 10 but didnt try it out then.

Side note - MODS - Should we be posting issues on this thread or making a separate one within the Phosh section on here?

Referenced Bluetooth earbuds : Soundcore Life P2 Earbuds

Hi airclay - Good to hear. Could you clarify the meaning of “I set my number w/I a username or pw as per TMobile apn instructions”?

Specifically, it appears I have to enter my phone number somewhere, but where?

Thanks in advance for a follow up.

Cheers!

I think airclay means ‘w/o’ instead of ‘w/l’, so username and password can be omitted. This corresponds to the T-Mobile instructions you linked, where it say username and password are both ’ < Not set > '.

To set an APN you shouldn’t have to set a phone number. The only possibility I can think of setting your phone number as APN username, but I don’t think that’s necessary here. For my own provider, which is a virtual provider using the T-Mobile network underneath, I don’t need to set user or password for my APN. Just the APN address is enough.

1 Like

Hi p1x3l3d - thank you for the clarification.

I am at a loss on why I don’t receive any text messages. I have no idea how to investigate because I don’t know how receiving text messages works. For example, does it require a daemon running in the background? If yes, what is that daemon and how to verify it is running?

The settings for mobile and chat all seem to be enabled.

@p1x3l3d is correct, sorry was on my phone at work.

I’m not sure how sms works outside of follwing these direcrtions either. I’m sure the information is out there though.