Manjaro ARM Beta 9 with Plasma Mobile (PinePhone / PinePhone Pro)

We are happy to present our ninth Beta Release of the Manjaro Plasma-Mobile edition for the PinePhone and PinePhone Pro. This marks the first release with the ModemManager stack!
This is also the first Beta with support for the PinePhone Pro!

This image includes

  • Kernel 5.15.7 optimized for the Pinephone
  • Frameworks 5.88
  • Plasma 5.23.4
  • Plasma-Mobile apps, which are now bundled as Plamo Gear 21.12
  • Maui Apps 2.1 and
  • Camera app Megapixels 1.4.2 with great improvements in responsiveness,
  • Pipewire 0.3.40
  • Appimagelauncher 2.2.0 and
  • our Pico-Wizard for easy initial setup at first launch

Over the last months Plasma-Mobile has made a lot of remarkable progress in regards of graphical appearance with smooth transitions and auto-rotate. Apps are now launching faster, too.
The drop-down menu provides Settings, Flashlight, a Screenshot function and more.
With Plamo Gear and the Maui Apps applications for all typical everyday needs are pre-installed.

Known issues:

  • Text prediction is currently only available for English.
  • Many translations are still missing.
  • Megapixels and camera does not work yet on Pinephone Pro.
  • Charging does not work on Pinephone Pro yet.
  • Audio quality on the Pinephone Pro is not good yet.
  • Some small graphical regressions made their way into Plasma 5.23.


Device PlaMo
PinePhone (Pro) Beta 9
PinePhone (Pro) Development

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

PinePhone Pro:
The Pinephone Pro is all you love about the PinePhone, except with better specifications. It has a 6-Core RK3399S SoC and 4 GB RAM, which is a huge upgrade compared to the regular Pinephones Allwinner A64 and 2/3 GB of RAM.
More information can be found on the Pine64 PinePhone Pro page.


Pinephones Beta Edition are still on stock. Visit the Pine64 Store
Pinephone Pro Explorer Edition will be available soon at the above link.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone (Pro) should recognize the SD card as a bootable device and boot from it.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker


Hi, Thanks for the new version! Plasma seems to become polished enough to use as a daily driver or at least very close to.

Calls work fine on this version for me, and all the apps seem less buggy, and there are more settings/options that were previously missing.

That said I can’t get it to send sms using Spacebar, anyone else having that problem? I have tried restarting the phone, pressing the force restart button in Settings and sending multiple sms. The sms messages I am trying to send first have a three dot icon (…) next to them and after a couple of seconds the icon changes to :no_entry_sign: which I presume means it failed. Like I mentioned calls work smoothly. Mobile internet also works, it selected a apn automatically and it just worked. This is a freshly installed beta 9 version.

Also does anyone have any experience with the open source modem driver in combination with Plasma-Mobile? It seems many Phosh users update the modem software and report things work better, is that the case for Plasma-Mobile as well?

1 Like

You might have seen my post in the beta8 thread how unusable and broken it was, including being unable to get mobile data working. I am glad to report that modemmanager works, i needed to navigate to access point names for it to automatically activate it, even when on the previous page it seemed it was already ok.

The other major issue i had was OSK and how i just could not find what i needed. Now it looks almost like the one on phosh, even the arrow keys appeared!

The only issue that still persists is completely undiscoverable 3 second press of power button to shutdown/restart, it’s quite scary as 5s = hard power off.

But i have never been as amazed by the progress from one release to another as here, a few showstoppers got completely fixed and only annoyances remained.

utezzy: as i continue using this image i can report back to you how well the open source modem firmware works here, if it differs from phosh or is the same issues also found here.


Regarding the sms issue it seems you need to have your contacts country code in the phone number in order for the sms to work even if both are in the same country.

Strangely phone calls don’t require the country code, maybe this was fixed for the Phone app but not Spacebar? Perhaps they have different developers?

Also noticed that it seems you can only have either the internal earpiece or internal speaker set systemwide and not per app. So if you take a call and use the internal earpiece all your notification sounds now go through the earpiece and are barerly audible so you will not hear a call or sms. Or you run everything through the speaker and notifications are heard but all your calls are played over the speaker. Hope there is a fix for that so that calls default to the internal earpiece and notification sounds go through the speaker.

Still I have to say that the jump in functionality compared to previous versions is huge. I will test more and see if it can become my daily driver.

varikonniemi: would love to hear back how the open source firmware behaves, thank you.

Ever since this Manjaro ARM Beta 17 with Phosh (PinePhone) - #31 by varikonniemi i have again had minor problems with it on phosh, like needing to go to settings and turn off and on the mobile data to get it back working. On plasma it is done automatically, so the only sign is deactivated and activated messages in notification center.

So there clearly is still stability problems with the modem even using open firmware, but it seems to recover correctly and automatically now, and phone calls and receiving text works fine, i have not tried send one yet, but i never had problems with texts, not even a year ago.

I also like the power savings of the firmware, which can be felt as reduced heat on the back cover.

With the new release, I enjoy the upgraded Firefox mobile configuration with the bottom bar and new tab bar functionalities.
However, there are two things that I find problematic:

  • the duplicate of the tab name that stays on top and reduces screen space
  • the absence of an easy way to close tabs other than the currently open one

Are you directly using the code from pmOS and should I raise these issues there or is there another dedicated repo?

We don’t use firefox in our Plasma Mobile builds, but yes, the mobil econfig package in our repo uses the PostmarketOS source directly, so any issues with it, should be brought to their issue tracker.

ModemManager works well. The update didn’t disable ofono or enable ModemManager in systemd. Now data and SMS work. Calls don’t work because the plasmaphonedialer crashes before it is started completely. So does kclock. Error message looks like this:

file:///usr/lib/qt/qml/org/kde/kirigami.2/private/RefreshableScrollView.qml:175:13: QML Binding: Not restoring previous value because restoreMode has not been set.
This behavior is deprecated.
You have to import QtQml 2.15 after any QtQuick imports and set
the restoreMode of the binding to fix this warning.
In Qt < 6.0 the default is Binding.RestoreBinding.
In Qt >= 6.0 the default is Binding.RestoreBindingOrValue.

Updated more packages with pacman and compared all packages with the list from here in kdiff3. No idea what else could be wrong.

1 Like

after good initial impressions it seems the stability while in call is worse than on phosh and i need to go back to it. During long calls (20+ minutes) the modem drops out regularly and won’t restart unless i reboot. This never happened on phosh.

If i read the situation correctly plasma does not allow phone calls if mobile data is unavailable, while phosh does.

1 Like

I noticed this too. In a 22 minutes long call it happened twice about every ten minutes. That said it restarts something during the call and if neither you or the other caller hang up, the conversation continues without problems in the same call. This causes a moment of silence in the call that is about 3-5 seconds long. This is on the stock modem firmware though.

I had another call that lasted 9 minutes and had one of these breaks around 7 minutes in but again it recovered while the call was active and then the conversation could continue. Still not ideal though.

I noticed there were some new updates today, maybe they can improve the situation.

1 Like

It might be that the open modem firmware i run does not handle it as well, and just fails.

If i read the situation correctly plasma does not allow phone calls if mobile data is unavailable, while phosh does.

As I understand it, it does actually allow phone calls if mobile data is truly unavailable, the issue I reported is with mobile data disabled through the software killswitch in the top drawer (and it is a regression from the switch to ModemManager, it works fine in the old ofono-based code).

Manjaro should replace Vvave with Elisa as the default music player. Vvave still stops playing music once phone goes into sleep after 5 minutes. Elisa fixed that many months ago. Vvave is unusable because of that.

1 Like

Developer have replied that it was missed.
It have been added now and will be available in the new release on February version 2.2.1

1 Like

As far as I can remember, there have already been discussions about replacing Vvave with elisa.
The problem is that elisa depends on vlc which doesn’t work that well on Plasma Mobile.

1 Like

Yes, was suggested here:

And is part of a bigger suggestion here:

It is the Elisa Arch package that depends on VLC. Elisa itself allows building with or without VLC at build time. (The fallback is QtMultimedia.) I guess a custom elisa-qtmm PKGBUILD without the VLC dependency would solve the issue, at the expense of an extra package to maintain.

Seems like it would just be easier to either hide the VLC launcher on mobile, or maintain libvlc.

So still learning what’s what in this release… but upgrades do not seem to be working – it reboots to install, but fails and asks if I want to rebuild database… keeps working tho, but unable to do anything about the update nag