Manjaro ARM Beta 19 with Phosh (PinePhone / PinephonePro)

Manjaro ARM Beta19 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our nineteenth BETA release for the PinePhone running Phosh!


This image is running the 5.15 kernel from Megi, which is designed for the PinePhone.


  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta18

  • This is the first release adding initial support for the PinephonePro
  • Kernel got updated to 5.15.5 and Pro is using 5.16-rc2
  • eg25-manager will now prevent overflowing when receiving messages
  • Firefox got updated to 94.0.2
  • Most Gnome apps and tools got updated to 41
  • Pipewire is now at 0.3.40
  • Pamac got renewed to 10.3.0
  • We are using now regular rtl8723bt-firmware for Bluetooth. Please switch to that package if you lost Bluetooth support on your end.
  • Systemd is now bumped to 249.7
  • We are now shipping with the latest Xorg-Server 21.1.1 and XWayland 21.1.3
  • We worked on getting USB Tethering working again
  • Chatty is now at 0.5-beta
  • We fixed some issues with gnome-keyring
  • megapixels got updated to 1.4.2
  • mesa is at 21.2.5

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • Chatty may crash with experimental features like MMS enabled. You may disable them via gsettings set sm.puri.Chatty experimental-features false if that is the case
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.


Device Phosh
PinePhone Beta19
PinePhone Nightly

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta20 here

  • Beta19 (2021-12-01) Download
    • based on stable branch
  • Dev (2021-12-03) Download
    • based on unstable branch
    • Chatty got it’s second beta-release of 0.5 series
    • Kernel is now at 5.15.6
    • uboot supports now booting from eMMC and SD on the PinephonePro
    • eg25-manager handles resetting of the modem better
    • We had the regular ICU 70.1 rebuilds
    • ModemManager got updated to 1.18.4
    • More polish to Phosh and Phoc
  • Dev (2021-12-13) Download
    • based on unstable branch
    • PinePhonePro gained initial audio support with VoiceCall
    • Alsa got updated to
    • Chatty is now at 0.5.0beta3
    • eg25-manager 0.4.2 officially introduced PPP support
    • firefox got renewed to 95.0
    • We updated gnome-calls to 42alpha0
    • Kernel is now at 5.15.7
    • phosh got updated to 0.14.1
    • vvmd 0.7-1 and vvmplayer 1.4-1 enhanced VoiceMail experience

I’m not exactly sure why, but it took me three SD flashes with Etcher before the Phosh booted successfully, the first two times the error ended with… unable to do something about “WhoAmI”

At first I thought it might be something to do with the reduced file size from Beta 18…

But then I recalled I missed expanding the partition on my PC first, which I normally do to not burden the phone with that task. So I did that first before trying my 3rd boot, as well as unplugged the USB-C connector (had it plugged in as I knew the phone was down to 30%)… and it booted up as expected.

Now that I’m logged in, I seem to be unable to configure WiFi. Settings=>Network opens up a screen that tells me…

“Oops, something has gone wrong. Please contact your software vendor.
NetworkManager needs to be running.”

… and when I run sudo systemctl status networkmanager, it tells me “networkmanager.service could not be found”

Network didn’t feel like the right place to go, so in the settings tool I used the search to try find WiFi… and it loaded me to a screen with a big frowny face and the same quoted message above.

When I went back to the main settings list, then I could see WiFi in the list above Network.

Thought I would try reboot, noticed afterwards Wifi was now in the Settings list normally… but before I could click it a “welcome wizard” launched (didn’t on the first boot) guiding me through language, wifi settings, and privacy/location options.

Not sure why the initial boot was misbehaving, but things seem to be up and running properly after a reboot.

I made a fresh install and there is no bootsplash on startup or shutdown.

Bluetooth is barely working, i did not manage to get the phone to find my keyboard trying multiple reboots and shutdown-start cycles. Then i let the phone sit without charger so it went to deep sleep, and after resuming the “searching for bluetooth devices” text appeared for the first time, and the keyboard was found. Before going to deep sleep only the search animation was rolling, the text was not shown.

edit: switching to unstable and updating did not bring the bootsplash back, but it made the phone boot much slower. It also made the OSK slow to appear for inputting SIM PIN.

I recently switched my phone carrier plan to one with no data, talk and text only. The service still supplies a data endpoint/APN for MMS messages. When my data and my wifi are enabled and connected, my PP prefers the mobile data route rather than the wifi. I believe this should be reversed so that wifi is preferred.

Personally, as it is now, when mobile data is on, I cannot update my PP, but if I had data, this would make me think my update would have occurred over data.

Thanks for the new release! I would like to test the ppp with Beta 19. Just received the device and dd’ed beta 19 (ppp) to an sd card. I was wondering how to override the default emmc stock android bootloader. According to PINE64 PinePhone Pro (pine64-pinephonepro) - postmarketOS, the device should automatically pickup the uboot configuration on the sd-card, but everytime it just boots to Android. I found Android recovery (volume up), but that doesn’t seem to offer an option to select the sd-card as boot option. Any idea?

I stumbled into this myself when I got my device. But @PINE64 was kind enough to add a guide on the Pine64 wiki:

1 Like

Thanks, I’m in :slight_smile: Nuking Android through adb worked fine. Afterwards the phone boots with a green led. Initial boot took a while. Looks great so far. Love to test some things the coming days. Especially curious how the gpu performs in Firefox with webrender.

[PinePhone Pro]

IMX258 driver fails when built in to the kernel. Fails with “failed to read chip id” and errno EIO. I suspect it’s trying to start too early in the boot sequence, but I’m no expert.

I rebuilt the kernel (Quite amazed, the phone is fast enough to build the kernel on it directly!) with CONFIG_VIDEO_IMX258=m and the module loaded automatically and successfully with no further configuration and the imx258 is now found as a v4l2_subdev. I’m figuring out the usage of the camera to actually take pictures next, now that the driver works, but I might try to debug the builtin driver problem sometime in the future unless someone else bites.

[PinePhone Pro]

Does anyone else has the issue that Powersupply doesn’t show the battery status, and the phone doesn’t charge while on? The battery only seem to charge when the phone is off/tries to boot to empty emmc.

Charging seems to work fine now; it’s not clear to me why it didn’t charge before, although the charge info itself is not available.

Charging on the PPP is still a hit and miss. PD Chargers are recommended, however those might need USB-C to USB-C cables.