Manjaro ARM Beta 12 with Plasma Mobile (PinePhone / PinePhone Pro)

We are happy to present our 12th Beta Release of the Manjaro Plasma-Mobile edition for the PinePhone and PinePhone Pro.

This image includes

  • Kernel 5.18.9 optimized for the Pinephone
  • Frameworks 5.95
  • Plasma 5.25.2
  • Plasma-Mobile apps, which are bundled as Plamo Gear 22.06
  • Maui Apps 2.1.2 and
  • Camera app Megapixels 1.5.2
  • PulseAudio 16.1
  • Appimagelauncher 2.2.0 and
  • our Pico-Wizard for easy initial setup at first launch

The new and improved drop-down menu provides Settings, Flashlight, a Screenshot function and more.
With Plamo Gear and the Maui Apps applications for all basic everyday needs are pre-installed.

Known issues:

  • Text prediction is not working.
  • Discover might not want to update packages.
  • Many translations are still missing and may even crash some applications.
  • Megapixels and camera does not work yet on Pinephone Pro.

Download:

Device PlaMo
PinePhone (Pro) Beta 12
PinePhone (Pro) Development

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

PinePhone Pro:
The Pinephone Pro is all you love about the PinePhone, except with better specifications. It has a 6-Core RK3399S SoC and 4 GB RAM, which is a huge upgrade compared to the regular Pinephones Allwinner A64 and 2/3 GB of RAM.
More information can be found on the Pine64 PinePhone Pro page.


Order

Pinephones Beta Edition are currently in stock. Order yours at the Pine64 Store.
Pinephone Pro Explorer Edition are now available! Order here.


How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone (Pro) should recognize the SD card as a bootable device and boot from it.


Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker.

1 Like

Was loving this on the PPP, until suddenly my screen just stopped working, and now it won’t boot. :frowning: After I had just finished getting everything set up on it, too!

I can access the filesystem using towboot mass media mode, but so far I don’t see anything all that interesting in the journal. Interestingly, the sd-card image I played around with before flashing to the phone has the same issue, so I’m guessing something in an update borked it.

I can confirm that something on the image seems to be broken.
Flashed: Manjaro-ARM-plasma-mobile-dev-pinephonepro-20220711.img.xz
onto SD card, on first boot on PPP getting this:

Try a newer image. Should be fixed there. (except the baloo_file thing, that’s for developer debugging)

PS: Don’t post about development images in the Beta threads. They are very different.

1 Like

Thanks, Manjaro-ARM-plasma-mobile-dev-pinephonepro-20220713.img.xz seems to be working on PPP.

PS: Don’t post about development images in the Beta threads. They are very different.

ok. any other place to do so?

Please add to Known Issues on PPP (if they are known…):

  • unlocking on convergence mode does not accept your pin and therefore does not work
  • to get mobile data working, you might do following: Settings => Cellular Networks => SIM => Modify APNs => AUtodetect APN

At the bottom of this thread’s starting post you can read where you can do this yourself:

I don’t know whether the issues there apply to the beta images only, or to the development images as well.

Both of these are Plasma Mobile issues. Not related to the Pinephone as such. And the last one might not even be an issue, but more a personal preference. Either way, both are not something we (as Manjaro) can do anything about as they are upstream issues.

If you try to use an APN that does not match your operator, it will just not work. The APN will either not exist at all or not accept your connection attempt. So it is not just a personal preference: either the APN is automatically detected correctly, or it is not and you have to do it manually. On any given operator, there is just one correct setting, no preference.

This release has been a disaster for me. autodetect APN did not work on first boot, asked me to enter manually. It worked in a previous beta so i tried to reboot, and internet came up automatically. On top of this i regularly experience a plasma settings crash when opening mobile networks tab. Plasmashell itself has crashed once. And then the whole phone rebooted right after drkonqi crashed while i was trying to start report the plasmasettings crash. Now after i enter pin to login at boot, the phone reboots.

Only modification i had time to do to the os was to install the debuginfod package as per the help page of drkonqi.

Still some way to go. Phone sometimes doesn’t wake up from sleep (also when called), locked session which afaik can’t be dealt with without dock and keyboard, hotspot doesn’t work (no SSID to be found) and switches back to client wifi, bluetooth HFP doesn’t work with car radio (accept calls/hang up/phone book/signal strength).