Manjaro ARM Beta 11 with Plasma Mobile (PinePhone / PinePhone Pro)

We are happy to present our eleventh Beta Release of the Manjaro Plasma-Mobile edition for the PinePhone and PinePhone Pro.

This image includes

  • Kernel 5.16.11 optimized for the Pinephone
  • Frameworks 5.91
  • Plasma 5.24.2
  • Plasma-Mobile apps, which are bundled as Plamo Gear 22.02
  • Maui Apps 2.1.1 and
  • Camera app Megapixels 1.4.3 with great improvements in responsiveness
  • PulseAudio 15.0
  • Appimagelauncher 2.2.0 and
  • our Pico-Wizard for easy initial setup at first launch

The new and improved drop-down menu provides Settings, Flashlight, a Screenshot function and more.
With Plamo Gear and the Maui Apps applications for all basic everyday needs are pre-installed.

Known issues:

  • Because of an issue with Pico Wizard’s session, you now need to login with PIN 123456 before Pico Wizard is shown.
  • Text prediction is not working.
  • Discover might not want to update packages.
  • Many translations are still missing and may even crash some applications.
  • Megapixels and camera does not work yet on Pinephone Pro.


Device PlaMo
PinePhone (Pro) Beta 11
PinePhone (Pro) Development

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

PinePhone Pro:
The Pinephone Pro is all you love about the PinePhone, except with better specifications. It has a 6-Core RK3399S SoC and 4 GB RAM, which is a huge upgrade compared to the regular Pinephones Allwinner A64 and 2/3 GB of RAM.
More information can be found on the Pine64 PinePhone Pro page.


Pinephones Beta Edition are currently out of stock. Keep an eye on Pine64 Store for when it’s back in stock.
Pinephone Pro Explorer Edition are now available! Order here.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone (Pro) should recognize the SD card as a bootable device and boot from it.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker


Thanks to everyone involved with this!

Any chance to get automount sdcard’s (/dev/mmcblk1p1) and usb sticks (/dev/sda) in the next build?
Manjaro (Index) mounts the stuff in /run/media/username/

and also exFat (sudo pacman -S exfat-utils ) and NTFS support (sudo pacman -S ntfs-3g) by default.

To prevent corruption we should add “noatime” to the device in /etc/fstab
This will prevent writing the access time of the storage to the storage all the time
(currently testing this setting and would report if it causes any downsides).

I am currently trying to create a PinePhonePro Convergence demo video which is fully made on the PPP.
We definitely need window borders/window management in convergence mode (similar to phosh), e.g. gimp is only usable when going into fullscreen mode, otherwise it looks like this (and I am not able to move it somehow):

The phonescreen stays fully white,
except sliding settings from top is only displaying on the phonescreen.

Screenshot only takes a screenshot from the phone screen, and never from the convergence screen.
Hitting Print Screen on a connected USB Keyboard does nothing.
Any idea on how to fix this, since screenshot is nearly the most used tool for creatives…


While Calligra Office is quite usable:

Libre Office is somehow offscreen and also the dialogs don’t fully show:

I am not sure if this the right place to ask this. Text entry dialogs in chromium browser do not invoke the keyboard; because of this chromium is unusable. Is it possible to fix this? Also is there a way to invoke the keyboard at will, without a text entry dialog to click on.

Launch chromium through wayland, instead of xwayland. That should work. Chromium is not mobile friendly though, so I would not recommend using it.

But is there a way to invoke the keyboard similar to the shortcut at the bottom corner of the phosh interface?

I don’t believe there is, no.

I asked on git and matrix channel:
No one currently knows how to trigger the keyboard manually and if, it would maybe not work to input text.
However, the virtual keyboard is located in: /usr/bin/maliit-keyboard

Sourcecode is here I think and settings here maliit-kcm

You might be able to install squeekboard (sudo pacman -S squeekboard) and set this as default with:
kcmshell5 virtualkeyboard or any other neat trick…

Tested this beta release from an SD card and it is quite usable.

Could not install manjaro-arm-flasher from pacman (invalid or corrupt package (PGP signature), or Discover (manjaro-arm-flasher not found in the available sources). Is there an alternative repo for manjaro-arm-flasher with proper PGP sigs or should I just compile from source files?

Manjaro ARM Flasher is just a python script. It does not need to be compiled.

What are you installing from? Is your system up-to-date?

I’m installing from the PinePhone itself.

Could not install updates using Discover. Tried updating with sudo pacman -Syu and I get error messages for Philip Mueller’s PGP key import: signature from “Philip Mueller (Called Little) is unknown trust”.

After that it throws another invalid or corrupted package for the only package to be updated, alsa-ucm-pinephone-0.5.7-1-any.pkg.tar.zst.

Incidentally I get the same PGP errors for Philip’s and your PGP sigs when trying to install manjaro-arm-flasher.

Just tried on a fresh install of Plasma Mobile on my phone. manjaro-arm-flasher installed just fine.

Try re-installing the keyring packages:
sudo pacman -Syyu manjaro-keyring manjaro-arm-keyring

Blockquote Try re-installing the keyring packages:
sudo pacman -Syyu manjaro-keyring manjaro-arm-keyring

Gives same keyring errors for Philip’s and your own.

Tried deleting /etc/pacman.d/gnupg/ and reinstalling gnupg manjaro-keyring manjaro-arm-keyring but still the same errors related to invalid corrupt keys

Flashed the image again and now everything is fine. I could update the system from the SD card and install manjaro-arm-flasher. I don’t know why the first flash would not work because the SHA1 hash matched the one from the image. Anyway…

1 Like

How would I fix this annoying message popping up after every reboot:

sudo pacman -Syyu does not help, nor does booting from SD and repairing filesystem with Gnome-Disks.

sudo rm /var/lib/PackageKit/offline-update-competed
(and yes, they misspelled completed as competed in that file name, so you have to write it exactly that way).

1 Like

perfect, thank you!

After flashing this image and updating via pacman -Syu, the issue with Discover is fixed on my Pinephone CE. I will note that while updating via pacman with Beta 9 initially flashed will not make the issue with Discover be resolved.

MMS is still a no-go for Plasma + Spacebar?

I noticed there are instructions/hints for setting up MMS with Phosh.

Pretty sure you can just set up your providers MMS details in the Spacebar settings and it will work.

I notice the MMS size has a limit of 5K. I tried to set it to 0, hoping for “unlimited”. I regularly receive MMS messages larger than 5K… is there a work-around to increase this size above 5K?

Edit: Eh, never mind, it does receive a MMS message larger than 5K even if set for 5K.