Manjaro ARM Alpha4 with Phosh (PinePhone)

But it’s already on sale. They haven’t announced what they are selling with? :wink:

top menu middle icon on bottom row

I just wonder if the developers do consult the bug trackers???
There are 33 issues up to 1 month old and only one is closed.

I also think that it would be important to priorize the bugs preventing use of phone, SMS, contacts and software management.

1 Like

Yes thanks for the feedback and yes we do follow issue tracker on our gitlab, as you’re aware of Mobile season being something new to Linux we have to wait for the developers to find solution for each issues raised.

Yes phone calls, sms, contact and software management should be the high priority but we just pkg the work from the developers and once the developers solve the issue we rebuild the pkg and push it to the repo for Manjaro users.

Thank you for your support.


This may be a silly question, but is it possible to test in a virtual environment to get a feel for the system?

Well, we developers work mostly on the hardware. Emulating a pinephone might be a little hard. It might help App developers a little, but for now we recommend the real device to test the software out.

No worries! Thought I would check. I have been trying to decide whether to pick the phone up. Just not the same testing these systems on nexus 5!

pinephone manjaro edition is sold with phosh or plazma?

Great work, developers! This build (alpha4) is working much, much better out of the box than alpha1 and alpha2 on my pinephone (branded “ubports edition”).

I haven’t yet seen mobile data work with this build; do I typically need to do anything for that to work (“4G” is showing in top bar and both calls + SMS work out of the box).

Thanks for all the work!

p.s. (I have now found “Issue 24” – sorry can’t link – but haven’t made it work yet … it’s possible of course this is a problem with my provider or similar).

p.p.s the instructions in Issue 24 HAVE worked for me … after I changed the APN settings to actually match my provider (I’m using “Public Mobile” which is the off-brand/cheap version of Telus Mobility in Alberta and whatever the phone found for APN settings was wrong).

So: 4G LTE data works! Wooo!

WiFi hotspot works too. Great!


latest update complained libhandy1 is owned by libhandy and neither of them worked as overwrite target so i fixed it by just using pacman -Syu --overwrite ‘*’

Last I saw, they were targeting Lomiri for the release devices. Not sure if thats changed since it was announced.

Just popped in a T-Mobile SIM in my PinePhone with Alpha 4. Funny thing, the default OS didn’t give me a cellular connection, but Manjaro did. :man_shrugging: Anyway, Launched Telegram (which was excrutiatingly slow), got connected, but when I try to send a message, the keyboard is numeric. I can’t find a way to change it to alphanumeric.

this caused messages app to fail launching. What seems to have worked was simply pacman -Rdd libhandy1 before running -Syu