Manjaro ARM Alpha3 with Lomiri (PinePhone)

Manjaro ARM Alpha3 of Lomiri for PinePhone!

The Manjaro ARM project is together with UBPorts Foundation proud to announce our third ALPHA release for the PinePhone running Lomiri!

This image are running the 5.10 kernel from Megi, which is designed for the PinePhone.

Features:

  • We ported Lomiri and most of is apps over to Manjaro
  • Morph-Browser is using GPU acceleration
  • We added an initial setup wizard
  • Initial work on call and SMS functions are done
  • You have following apps: Calculator, Clock, Contacts, Document Viewer, File Manager, Gallery, Messaging, Morhp Browser, Music, Phone, System Settings and Terminal
  • This image uses a Crust enabled uboot

Currently broken:

  • Calls are highly unstable (Issue)
  • Messaging might not work properly (see Issues)

Changes since Alpha2:

  • we use now latest Megi-Kernel of 5.10 series
  • rebuild of Lomiri packages against boost and smaller updates
  • megapixels is now at 0.14.0
  • patches to ofono so more network carriers work
  • qt got updated to 5.15.2
  • systemd is now at 247.2
  • mesa stack is at 20.3.3
  • update of most of the ayatana-indicators
  • update of system-settings and settings-components
  • First-Run wizard is back
  • we added a preview of uNav
  • Morph browser might work with GPU acceleration now
  • DRAM frequency got lowered to 528 MHz
  • KDE Frameworks got updated to 5.78.0
  • Gstreamer and PluseAudio updated
  • More fixes to Lomiri parts to support X11 and Bluetooth better
  • updated packages

Known issues

  • UI may become unresponsive after a while or show glitches.
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Lomiri
PinePhone Alpha3
PinePhone Nightly

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Last Chance to Order:

You can now order the Mobian CE Edition and the Mobian CE Convergence Package of the Pinephone! 10 $ per sale will go to the Mobian Project. Last chance to get a community edition of the Pinephone …

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

4 Likes

Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Alpha4 here

  • Alpha3 (2021-01-21) Download
  • Dev (2021-01-31) Download
    • based on unstable branch
    • Kernel got updated to 5.10.12
    • we are using now eg25-manager in combination with ofonoctl to manage the modem
    • Mesa is now at 20.3.4
    • Small fixes to Unity8 and Lomiri-Keyboard
    • regular upstream updates

My SIM, Finnish Telia is not working. Same thing goes applies for Plasma Mobile. Probably ofono? It does read Telia upleft and has some numbers there before it starts to read just Telia. No internet connection though.

Pinephone manjaro edition, lomiri alpha 3, Denmark Tdc
Phone calls work with no problems and sound perfect.
Sms can send and receive (can begin to freeze when receiveing), Mms cant get it to work.
Wifi , internet browsing and terminal updates works. Youtube running very good.
4g cant get on the internet, but think it is something with the Apn.
Second monitor, is a no go, can get a picture up and mouse quickly stops working on the phone.
The phone it self is running smoothly, just like a new android or an iphone, very nice work there.

Not a long road ahead before this becomes my main phone.
Very good job done.

care to explain the new ‘nightly’ builds. is each one different than the last? will there be a changelog for every nightly release?

1 Like

I think the ‘nightly’ builds just come with newer packages, so if you don’t want to have to download/update as much after installing a new image, get the nightly. There will sometimes be notes in the bugtracker post if there is anything of particular importance.

btw there is a bounty source for making Anbox work on Wayland. Currently its at 180$ if someone is interesting on contributing to the bounty or making the work and reclaiming the price its here:

https://www.bountysource.com/issues/95432153-implement-native-wayland-support-for-anbox

1 Like

Installed Alpha 3. Lomiri ui is great! But I have some problems with WLAN. Can’t wait to see more releases and progress :+1:

  • wifi doesn’t work some times
  • can’t activate gps
  • login input blocked in neochat (server field after typed first characters)

But Manjaro works much better than mobian / postmarket with my pinephone. Both are unusable if I try to update with packet manager or change language. Manjaro with lomiri gui is the best choice for me.

1 Like

We try to work closely with UBPorts developers on these issues. However the process is kinda slow.

It will need some time, but I really like what I see so far :slight_smile:

Yeah, even progress on their own OS for Pinephone is barely a crawl.

Tested mobian (posh), postmarketos (posh, plasma) and finally manjaro (plasma, lomiri).
Lomiri hat mich am optisch und von der Bedienung her am meisten angesprochen und Manjaro war bisher das stabilste OS der Kandidaten.
Entsprechend bin ich sehr gespannt auf Manjaro mit Lomiri. Good job!

How are they doing?

Hi, latest dev build isn’t booting with my pinephone. I liked the Lomiri UI, but looks like should move to another UI? Which ist the smoothest and active developed UI / OS build for pinephone?

We need to look at whats broken as it fails to load. I hope to rebuild the whole lomiri pkgs list and see if that would help.

Thank you for reporting.

Not sure if this is relevant, but hey :stuck_out_tongue:
I’ve noticed that doing a system update (pacman -Syu) starting from the alpha3 image will cause the pinephone to seem bricked.
From what i can tell everything looks good except that lightdm isn’t starting up.
After a bit of digging it looks like the unity-system-compositor can’t start because the file ‘libprotobuf-lite.so.23’ is missing.

i’m guessing that the system upgraded removes libprotobuf-lite.so.23 and adds libprotobuf-lite.so.27.

I’m not exactly sure what to do with this information, or even if it’s the root cause of the problem, but i hope it helps someone out.

Yes, alpha3 was the last image we did for Lomiri. Currently this edition is unmaintained.

Hi @philm

I noticed that some broken dependencies are preventing the lomiri image from building.

They are

  • lomiri-keyboard-git
  • inputcontext-gtk
  • location-services-git

lomiri-keyboard-git and inputcontext-gtk both fail because they have a dependency on maliit-framework-git which has been replaced by maliit-framework in the repos

So changing this dependency in PKGBUILD files for the respective packages will fix them
(i know i tried :stuck_out_tongue: )

But for location-service-git there seems to be a bigger problem (for me at least :stuck_out_tongue: )

It depends on net-cpp-git, which in turn depends on pyhton2-decorators

I can’t find pyhton2-decorators anywhere… any clue where it went or what it can be replaced with? :stuck_out_tongue:

If i can figure that out, i can submit some patches to the relevant repos and we can get the image up and building again

(also mir needs a rebuild with the new protobuf lib, no patch needed, just a rebuild will be enough)

3 Likes

Maybe it can be replaced with python-decorator? That seems to be the closest alternative available, maybe it replaced python2-decorator.

I would love to see some activity on Lomiri development again, so thanks for bringing this up! I’ll try to figure out how to contribute something useful to this too.

1 Like

in the mean time i’ve found that it’s much more complex that this :frowning:

ubports moved to gitlab, this basically means that all the PKGBUILD files need to updated to point to the gitlab repos and rebuilt

And probably update the dependencies as well and who knows what else…

It makes me sad that manjaro does not support lomiri, but i get it…

I’ve tried to update the builds myself, but i’m by no means capable of doing this.
I’d be more than happy to learn and do this, but i would need a lot of help and i’m not even sure who to ask :stuck_out_tongue: