Manjaro ARM Alpha2 with Lomiri (PinePhone)

Manjaro ARM Alpha2 of Lomiri for PinePhone!

The Manjaro ARM project is together with UBPorts Foundation proud to announce our second ALPHA release for the PinePhone running Lomiri!

This image are running the 5.9 kernel from Megi, which is designed for the PinePhone.

Features:

  • We ported Lomiri and most of is apps over to Manjaro
  • Morph-Browser is using GPU acceleration
  • We added an initial setup wizard
  • Initial work on call and SMS functions are done
  • You have following apps: Calculator, Clock, Contacts, Document Viewer, File Manager, Gallery, Messaging, Morhp Browser, Music, Phone, System Settings and Terminal
  • This image uses a Crust enabled uboot

Currently broken:

  • Calls are highly unstable (Issue)
  • Messaging might not work properly (see Issues)
  • Bluetooth not working yet

Changes since Alpha1:

  • we use now latest Megi-Kernel of 5.9 series
  • Screen displays now 60 Hz
  • mesa got updated to 20.2.2
  • using now 8 kHz for call playback, which improves the quality much better
  • fixed issue with volume buttons
  • fixed issue with receiving text messages
  • worked on issue with not receiving text messages right away
  • stabilized receiving calls and making some
  • worked on LED indicators
  • try to fix GTK keyboard issues
  • add megapixels 0.12.0
  • updated packages

Known issues

  • UI may become unresponsive after a while or show glitches.
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Lomiri
PinePhone Alpha2

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Last Chance to Order:

You can still order the Manjaro CE Edition and the Manjaro CE Convergence Package of the Pinephone! Over 4000 pcs already sold! Only few left …

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

9 Likes

Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Alpha3 here

  • Alpha2 (2020-11-24) Download

  • Dev (2021-01-08) Download

    • based on unstable branch
    • kernel updated to 5.10.5
    • rebuild of Lomiri packages against boost and smaller updates
    • megapixels is now at 0.13.2
    • patches to ofono so more network carriers work
    • qt got updated to 5.15.2
    • systemd is now at 247.2
    • mesa stack is at 20.3.2
    • detailed changes here
  • Dev (2021-01-10) Download

    • based on unstable branch
    • update of most of the ayatana-indicators
    • kernel is at 5.10.6
    • update of system-settings and settings-components
    • regular upstream updates
  • Dev (2021-01-12) Download

    • based on unstable branch
    • more Lomiri packages got needed fixes, which give them more stability
    • First-Run wizard is back
    • we added a preview of uNav
    • Morph browser might work with GPU acceleration now
  • Dev (2021-01-15) Download

    • based on unstable branch
    • DRAM frequency got lowered to 528 MHz
    • KDE Frameworks got updated to 5.78.0
    • Gstreamer and PluseAudio updated
    • Kernel is not at 5.10.7
    • Mesa got updated to 20.3.3
    • Modem-Scripts got prepared for eg25-manager (not added yet)
    • More fixes to Lomiri parts to support X11 better
2 Likes

hi i try too install it but the phone only start up the default os
and not what on the micro card i tryed different programs

we have an label issue. both root and boot partitions have the same labels as the SD card. you may need more reboots until it boots from SD. With a new ISO we may use UUID or something.

ooh will try that

3 posts were merged into an existing topic: Manjaro system security

wifi dos not work for me on the ubports pinephone edition wlan is turned on but no connection,
i hhve 1 saved connection but can not connect to any wifi

Hello and welcome to the community,

I hope you have Manjaro Lomiri edition installed on your ubport edition device, Can you please share the output of this command
inxi -Fzxi

I do not understand why before publication this image did not get the primordial test of booting and running a few simple apps like clock?
Although I appreciate the effort of all developpers, IMHO this shows disrespect of the user’s time…

This is alpha image for users to test it.

It is only testing and reviewing and not for final use hence named alpha.

Thanks for trying it out. It will be helpful if you can raise an issue at our git issues list.

Much appreciated.

I have the ubports one as well. For me it was constantly asking for the WPA key.
After a reboot it was ok though.

Got the same issue. To fix it type in terminal:

rfkill unblock wifi
nmcli radio wifi on

At some point an update has killed this, I installed updates and rebooted and now it won’t boot

1 Like

Yes the lomiri pkgs are not build with the updated dependencies, currently it is not being maintained as the core developer have been sick since long time.

Will update the thread once I get to hear from the core developer again.

I’m currently working on Lomiri and might have a developer build out soon. Stay tuned. Also Lomiri images are not meant to be updated as of now.

5 Likes

Anbox now can be started on Lomiri on Manjaro but it has a ton of issues right now like the apps having half the screen black and being super laggy.
Also the scaling is super tiny.

1 Like

This is AWESOME! :smiley: I would try to use a wayland backed instead of x11. It’s using sdl so you can try to set SDL_VIDEODRIVER=wayland

3 Likes

anbox doesnt work with wayland backend right now because of this issue [wayland support] replacing pbuffers · Issue #1270 · anbox/anbox · GitHub

Comands i used to install and run Anbox:

sudo pacman -S anbox anbox-image
sudo systemctl start anbox-container-manager
export DISPLAY=:0
anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewActivity

1 Like

Thank you für your installation suggestions.
Sadly the result was: failed to connect to DBus