Manjaro ARM Alpha1 with Lomiri (PinePhone)

Manjaro ARM Alpha1 of Lomiri for PinePhone!

The Manjaro ARM project is together with UBPorts Foundation proud to announce our first ALPHA release for the PinePhone running Lomiri!

This image are running the 5.7 kernel from, which is designed for the PinePhone.


  • We ported Lomiri and most of is apps over to Manjaro
  • Morph-Browser is using GPU acceleration
  • We added an initial setup wizard
  • Initial work on call and SMS functions are done
  • You have following apps: Calculator, Clock, Contacts, Document Viewer, File Manager, Gallery, Messaging, Morhp Browser, Music, Phone, System Settings and Terminal
  • This image uses a Crust enabled uboot

Currently broken:

  • Calls are highly unstable (Issue)
  • Messaging might not work properly (see Issues)
  • No vibartion functions yet
  • No camera function yet
  • No auto-brightness yet
  • No volume buttons and volume control (Issue)

Known issues

  • There is a font gap between $ and cursor within terminal-app
  • UI may become unresponsive after a while or show glitches.
  • Lots of apps are still missing or are not mobile friendly yet.


Device Lomiri
PinePhone Alpha1

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


You can now pre-order the Manjaro CE Edition and the Manjaro CE Convergence Package of the Pinephone!

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.



If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Alpha2 here

  • Alpha1 (2020-09-19) Download
  • Alpha1 (2020-09-23) Download
    • fixed issue with volume buttons
    • fixed issue with receiving text messages
    • worked on issue with not receiving text messages right away
    • stabilized receiving calls and making some
    • worked on LED indicators
    • fixed calendar indicator
  • Alpha1 (2020-10-01) Download
    • try to fix GTK keyboard issues
    • add megapixels
    • updated packages
  • Alpha1 (2020-10-02) Download
    • rebuild maliit packages
    • more updates to packages
  • Alpha1 (2020-10-03) Download
    • update megapixels
    • rebuild addressbook-app
    • reuse lomiri-keyboard

When i try to install apps with pacman it says it is disabled, i see the pacman binary has been replaced with a bash script, how can i enable pacman?

1 Like

Yes, I just experienced the same thing when I tried to use pacman. Other than that, first impressions are very good. The initial setup looks polished

yes, first look is very good & smooth. Nice work

pacman is disabled in this edition

i use pamac to install / building packages

  • same problem with wrong Time Bar here - use RTC or UTC ?
date & timedatectl
Sa 19. Sep 14:03:10 CEST 2020

               Local time: Sa 2020-09-19 14:03:17 CEST
           Universal time: Sa 2020-09-19 12:03:17 UTC 
                 RTC time: Sa 2020-09-19 12:03:18     
                Time zone: Europe/Berlin (CEST, +0200)
System clock synchronized: yes                        
              NTP service: active                     
          RTC in local TZ: no            
sudo dmesg -l emerg,alert,crit,err,warn
[    0.596957] sun50i-de2-bus 1000000.bus: Error couldn't map SRAM to device
[    0.597787] sun4i-usb-phy 1c19400.phy: Couldn't request VBUS detect GPIO
[    0.598275] sun6i-mipi-dphy 1ca1000.d-phy: Couldn't create the DPHY encoder regmap
[    0.603596] sun50i-a64-r-pinctrl 1f02c00.pinctrl: supply vcc-pl not found, using dummy regulator
[    0.625008] sun6i-mipi-dsi 1ca0000.dsi: Couldn't get VCC-DSI supply
[    0.762412] axp20x-adc axp813-adc: DMA mask not set
[    0.763395] axp20x-battery-power-supply axp20x-battery-power-supply: DMA mask not set
[    0.769456] axp20x-usb-power-supply axp20x-usb-power-supply: DMA mask not set
[    2.321099] usb_phy_generic supply vcc not found, using dummy regulator
[    2.344479] phy id_det change to device
[    2.471274] Goodix-TS 1-005d: Direct firmware load for goodix_917S_cfg.bin failed with error -2
[    2.674655] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    2.787896] GPT:Primary header thinks Alt. header is not at the end of the disk.
[    2.795399] GPT:28515624 != 30785535
[    2.798998] GPT:Alternate GPT header not at the end of the disk.
[    2.806397] GPT:28515624 != 30785535
[    2.811246] GPT: Use GNU Parted to correct GPT errors.
[    6.257195] systemd[1]: system-getty.slice: unit configures an IP firewall, but the local system does not support BPF/cgroup firewalling.
[    6.269580] systemd[1]: (This warning is only shown for the first unit using IP firewalling.)
[    9.516732] sgm3140 led-controller: supply vin not found, using dummy regulator
[    9.524443] sgm3140 led-controller: flash-max-timeout-us property missing
[   10.193527] 8723cs: module is from the staging directory, the quality is unknown, you have been warned.
[   10.629100] bt-sco bt-sco-codec: ASoC: sink widget Capture overwritten
[   10.629117] bt-sco bt-sco-codec: ASoC: source widget Playback overwritten
[   10.629220] simple-amplifier audio-amplifier: supply VCC not found, using dummy regulator
[   10.632570] debugfs: File 'Playback' in directory 'dapm' already present!
[   10.632582] debugfs: File 'Capture' in directory 'dapm' already present!
[   11.598467] sun6i-csi 1cb0000.csi: Direct firmware load for gc2145-init.bin failed with error -2
[   11.607318] gc2145 4-003c: Failed to read firmware gc2145-init.bin, continuing anyway...
[   11.819573] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[   12.127684] anx7688 1-0028: boot firmware load failed (you may need to flash FW to anx7688 first)
[   14.025087] sun6i-csi 1cb0000.csi: Direct firmware load for gc2145-init.bin failed with error -2
[   14.033972] gc2145 4-003c: Failed to read firmware gc2145-init.bin, continuing anyway...
[   54.879610] ------------[ cut here ]------------
[   54.884259] WARNING: CPU: 3 PID: 33 at net/wireless/sme.c:756 __cfg80211_connect_result+0x218/0x260
[   54.893378] Modules linked in: qmi_wwan option cdc_wdm usb_wwan usbnet usbserial rfcomm bnep zram zsmalloc ov5640 crct10dif_ce sun50i_codec_analog sun8i_adda_pr_regmap st_magn_spi st_sensors_spi lima sun6i_csi panel_sitronix_st7703 hci_uart btrtl btbcm bluetooth gpu_sched inv_mpu6050_i2c st_magn_i2c st_magn st_sensors_i2c st_sensors inv_mpu6050 stk3310 industrialio_triggered_buffer kfifo_buf ecdh_generic ecc anx7688 sun8i_codec sun4i_lradc_keys sun4i_i2s 8723cs(C) snd_soc_simple_amplifier snd_soc_bt_sco snd_soc_ec25 snd_soc_simple_card snd_soc_simple_card_utils snd_soc_core snd_pcm_dmaengine snd_pcm snd_timer i2c_gpio leds_sgm3140 display_connector snd soundcore ipv6
[   54.954584] CPU: 3 PID: 33 Comm: kworker/u8:2 Tainted: G         C        5.7.19-2-MANJARO-ARM #1
[   54.963547] Hardware name: Pine64 PinePhone (1.2) (DT)
[   54.968683] Workqueue: cfg80211 cfg80211_event_work
[   54.973555] pstate: 60000005 (nZCv daif -PAN -UAO)
[   54.978336] pc : __cfg80211_connect_result+0x218/0x260
[   54.983465] lr : __cfg80211_connect_result+0x1bc/0x260
[   54.988591] sp : ffff8000111abcd0
[   54.991899] x29: ffff8000111abcd0 x28: 0000000000000060 
[   54.997202] x27: 0000000000000000 x26: dead000000000100 
[   55.002504] x25: dead000000000122 x24: 0000000000000000 
[   55.007807] x23: ffff000068e8b2d8 x22: ffff000068e8b248 
[   55.013109] x21: ffff000068e8b200 x20: ffff000051c18818 
[   55.018411] x19: ffff000068e8b200 x18: 0000000000000000 
[   55.023713] x17: 0000000000000000 x16: 0000000000000004 
[   55.029016] x15: 004fee08238c82e6 x14: 0064147be7e24344 
[   55.034318] x13: ffff800010bd71d0 x12: 00000000eac0c6e6 
[   55.039621] x11: 000000000000011e x10: 000000000064147b 
[   55.044923] x9 : ffff800010b4036c x8 : 0000000000000001 
[   55.050225] x7 : 0000000000000012 x6 : 0000000000000002 
[   55.055527] x5 : ffff00006b429ad8 x4 : 000000002279495c 
[   55.060830] x3 : ffffffff00010cad x2 : ffff00006f6b1b80 
[   55.066132] x1 : ffff00006f6b1b80 x0 : 0000000000000000 
[   55.071434] Call trace:
[   55.073878]  __cfg80211_connect_result+0x218/0x260
[   55.078661]  cfg80211_process_wdev_events+0x18c/0x24c
[   55.083703]  cfg80211_process_rdev_events+0x38/0x90
[   55.088572]  cfg80211_event_work+0x20/0x34
[   55.092664]  process_one_work+0x1d8/0x3a0
[   55.096665]  worker_thread+0x15c/0x504
[   55.100409]  kthread+0x11c/0x120
[   55.103633]  ret_from_fork+0x10/0x38
[   55.107201] ---[ end trace ab0feef29abbef21 ]---
[  110.853033] hrtimer: interrupt took 752833 ns
systemd-analyze blame
25.688s ofonoctl.service                             
10.086s bootsplash-hide-when-booted.service          
 3.323s lvm2-monitor.service                         
 3.027s dev-mmcblk0p2.device                         
 2.257s tlp.service                                  
 2.080s systemd-random-seed.service                  
 1.772s upower.service                               
 1.311s repowerd.service                             
 1.217s systemd-logind.service                       
 1.169s bluetooth.service                            
 1.154s NetworkManager.service                       
 1.110s systemd-networkd.service                     
 1.096s iio-sensor-proxy.service                     
  992ms systemd-homed.service                        
  965ms user@1000.service                            
  943ms ofono.service                                
  931ms systemd-timesyncd.service                    
  930ms accounts-daemon.service                      
  930ms systemd-udevd.service                        
  858ms systemd-journald.service                     
  842ms pinephone-camera-setup.service               
  797ms systemd-userdbd.service                      
  785ms polkit.service                               
  716ms zswap-arm.service                            
  426ms systemd-udev-trigger.service                 
  411ms alsa-restore.service                         
  326ms dev-hugepages.mount                          
  321ms dev-mqueue.mount                             
  318ms sys-kernel-debug.mount                       
  307ms tmp.mount                                    
  301ms kmod-static-nodes.service                    
  265ms wpa_supplicant.service                       
  228ms systemd-modules-load.service                 
  225ms systemd-remount-fs.service                   
  162ms sys-fs-fuse-connections.mount                
  156ms sys-kernel-config.mount                      
  136ms lightdm.service                              
  126ms phosh-renice.service                         
  122ms systemd-sysctl.service                       
  117ms systemd-tmpfiles-setup-dev.service           
   91ms udisks2-zram-setup@zram0.service             
   87ms systemd-tmpfiles-setup.service               
   71ms rtkit-daemon.service                         
   67ms systemd-backlight@backlight:backlight.service
   55ms systemd-update-utmp.service                  
   51ms user-runtime-dir@1000.service                
   47ms systemd-journal-flush.service                
   43ms systemd-user-sessions.service                
   35ms boot.mount                                   
   34ms systemd-rfkill.service             

congret with the first alpha 1
works good so far
have some trouble with mobiel internet

Ok using pamac to install software, thanks @Lila-Kuh

Will respin the image with pacman enabled. For those already have downloaded do this:

pamac reinstall pacman

1 Like

Didn’t work for me with the install option, but it worked with “reinstall”

sudo pamac reinstall pacman

I tried installing some of the plasma-mobile apps , angelfish, vvave, nota, buho, index and they work fine but i had to modify the scaling with the env variable QT_SCALE_FACTOR=2 otherwise the buttons and text were too small.

I also installed plasma-discover for graphicall installing apps and wors fine too with the scaling env.


We are working on a plugin


I also tried anbox without success, I installed it with sudo pacman -S anbox anbox-image
then i started the anbox manager with sudo systemctl start anbox-container-manager
finally i tried to launch the app manager but it failed to start with error message:

[daemon.cpp:61@Run] [org.freedesktop.DBus.Error.ServiceUnknown] The name org.anbox was not provided by any .service files

Amazing, lomiri is one of the most polished UIs I’ve used for PinePhone.

Any idea when megi kernel 5.9 with hdmi fixes will be available?

Very promising build!

Do we need to flash each build of Alpha-1 separately or does an update with pamac or pacman also work ?

Normal updates will update your system with given applications. We don’t added meta-packages yet. So it is recommended to test each alpha release fresh, as we may add new apps or change scripts or firmware. When development is over, I’m sure we will find a regular update procedure.

Wow, I’ve tried PlaMo, Phosh and this one, and have to say this is by far the best looking Pinephone DE so far :slight_smile: I dare say it even feels better than Ubuntu Touch. Great work!

I managed to install Discover as well, however, for me it’s not loading anything. Discover seems to start /usr/bin/kded5 and then just hangs. Did you do anything specific to get it to work?

Edit: never mind. Closed it, then started it again and now a list of applications is shown :slight_smile: Now attempting to install Snes9x, let’s see how it goes! :grin:

you have to install also breeze icons, otherwise the apps shows no icons. And i use QT_SCALE_FACTOR=2 env variable to make the qt apps scale properly.

Ah, thanks! Was wondering why they didn’t show, but makes sense. All of the KDE/Plasma stuff is absent in Lomiri. Already used your scaling tip, thanks for that as well!

After installing Discover I noticed that it shows up 4 times in the Lomiri application overview (long swipe from the left). Was this the same for you? Also, as I described above I installed Snes9x through Discover as a test. It didn’t show up in the application list, and I also can’t start it from the terminal. So it seems that Discover installed the application in a directory that is not in Lomiri’s default $PATH. I’ll look into this a bit more.

Strange here:

Wifi is not preferred over mobile data. Wifi works absolutely correct, but traceroute shows that the preferred way to the internet is mobile data. ???