Manjaro ARM Alpha1 with Lomiri (PinePhone)

I switched to “Testing”. Worked well. Via pacman I tried gnome-camera, patheon-camera, plasma-camera and megapixels: Megapixels works! (it stays in portrait-mode and it is hard to take a picture, but nevertheless connects to the front camera).

Lomiri seems to be already really smooth! :wink:

best regards!

tested the latest image 2020-09-23 and now volume buttons and the systray applets work.

Tested usb-c earphones and they work and switch audo automatically! awesome!

Test default route in all possible variants with mobile data on/off wifi on/off and all combinations:

Default route and internet traffic go always via mobile connection :frowning:

wifi doesnt work for me on this build. I see my ap, put in the password, but it fails to make a connection.
Also screen stays on and never goes to sleep.

Is there any plans to have lomiri available on regular x86 manjaro?

Newest release: Incoming calls on sleep not signalized and so unfortunately total missing

I just wanted to thank you all for your hard work. I tested several different distributions and UIs this weekend and I have to say, that Manjaro Lomiri was my favourite of all of them. Super snappy, performant and nice looking. Overall just a great feeling. For me Lomiri feels more polished than the current KDE or the Phosh version. And it was even quite a bit smoother than the Ubuntu Touch version of megis multiboot image flashed to eMMC not external sd card. So: Awesome work for an Alpha 1 release! Keep it coming!

4 Likes

Tested the latest image 20201001, some thoughts:

  • They get rid of the ubports keyboard on favor of the plasma-mobile one. I liked the ubports one more but this one works with gtk apps (kinda)
  • They dont have anymore xwayland installed for what it looks like but X11 apps dident work at all on the old lomiri images anyway because lomiri crashed any time on x11 apps. (This is bad because Anbox relays on X11 support for now)
  • Megapixels app and gtk apps in general have a weird border on the top and left side and the scaling is off

Honestly, loosing Anbox for Lomiri is not too bad a trade in my view. Anbox drains the battery, and a lot of the Android apps you can’t easily replace with native or web apps works don’t work properly without Play Services anyway or have other features that do not work great with Anbox, like video.
With regard to the weird border of GTK apps you describe, this might help (copying from my fosstodon account because I am not allowed to just paste a link): The fix for the window-shadow thing was adding the following to ~/.config/GTK-3.0/gtk.css:

.window-frame {
box-shadow: none;
margin: 0;
}

decoration  {
transition: 0;
box-shadow: none;
margin: 0;
padding: 0;
}   
decoration:backdrop  {
transition: 0;
box-shadow: none;
margin: 0;
padding: 0;
}

back-tick web-address back-tick

1 Like

i only need anbox for a couple of apps i realy need for swtitching to the pinephone as my daily driver, whatsapp for keeping contact with the family and friends and some apps for payments. So i guess i will have to stick to phosh or plasma-mobile for now

Do those payment apps work? If so, could you share the names? (Could help others :-))

Yes, Verse and Twyp but i dont know if those are available outside my country (spain), For my daily driver i use a oneplus 5t with lineageos with microg, i dont have google services installed so i know all the apps i use work at least with microg…

1 Like

According to Post #152558 found on the Manjaro Forums (sorry, the system is preventing me from adding a link to my first post), snapd can be installed on a Raspberry Pi running Manjaro ARM using:

sudo pacman -S snapd

Can snapd be installed onto a PinePhone running Manjaro ARM? And in particular, can snapd be installed onto a PinePhone running Manjaro Lomiri?

If so, I’d be curious how well (if at all) various Snaps run on Manjaro Lomiri.

Provided that you’re able to install snapd first, how about attempting to install Anbox as a Snap using:

sudo snap install --devmode --beta anbox

I usually start the Anbox Snap on Ubuntu from a launcher. But if I recall correctly, you can start the Anbox Snap from a terminal using:

anbox.appmgr (or maybe try using sudo anbox.appmgr)

snapd can be installed on the pinephone yes but not all snaps are available for arm64, as for anbox its not possible to use it on lomiri at the moment because anbox is an X11 app and lomiri doesnt support them for now.

1 Like

Ooops… It has to be ~/.config/gtk-3.0/gtk.css.

BUG in version:

If mobile data and WiFi are active and connected the IP traffic only goes over the SIM-Card. So WiFi is quite useless for receiving patches etc.

Are “Click Packages” supposed to work with this or is that strictly for Ubuntu Touch?

I’m under the impression that there are no plans to bring Click packages to Manjaro Lomiri. (If I’m wrong about that, I hope someone will correct me.)

However, Ubuntu Touch will eventually support Snaps. Indeed, UBports has stated that a “central part of [their] aim would be to have [their] own apps packaged as snaps.”

So, if I had to guess, I’d guess that Clicks will eventually be replaced by Snaps on Ubuntu Touch. But again, that’s just my guess. :slight_smile:

Yes this is a known issue as we’re still using the experimental modem power up and connect function pkg build by martijn. Once lomiri team comes up with something in the shell itself to replace this experimental pkg that it will be replaced.

Currently we have tried to build ubport apps naively without click and some were build and worked successfully but some still need click to compile.

It all depends on ubport team on how they plan to handle this situation either by finding a way to get apps to work without click or go with snap pkgs.

Only time will tell as it is a huge task.

1 Like