Manjaro ARM 23.02 released!

Manjaro ARM 23.02 released!

We are proud to announce the release of Manjaro ARM 23.02.

You can find all our images on!

Application for flashing images

We have our own GUI app to make it easy for users to flash a Manjaro ARM image on to an SD card, eMMC card or USB stick.
If you are on Manjaro ARM, simply install manjaro-arm-flasher and launch the app “Manjaro ARM Flasher” from your menu. This will download and flash the image of your choice.

You can also manually run the application (if you are not running Manjaro ARM) by downloading this python script, make it executable with chmod +x manjaro-arm-flasher, install the dependencies listed in the and then run it with sudo ./manjaro-arm-flasher.

First Time setup on Minimal edition

This release sports the First Time setup for all Minimal images, also via SSH. This means that at first boot, you will be asked about the following:

  • keyboard layout (except on pinebook, that is fixed to us layout)
  • username
  • additional user groups (optional)
  • full name
  • password for that username
  • password for root
  • timezone
  • locale
  • hostname

Then the setup script will set these settings and reboot to the login screen.


All the download links can be found on the website

Torrents are also available!


  • New packages from upstream and Manjaro ARM
  • By popular demand Pinebook Pro specific images are available again
  • XFCE 4.18
  • KDE Plasma 5.26.5
  • Gnome 43
  • MATE 1.26
  • Sway 1.8
  • Pacman 6.0

Development images

Images for devices in development or just development (unstable) versions of supported devices can be found on our Github page.

Updating from 22.12:

  • No major changes

Tips and Tricks:

Smoothness on Raspberry Pi 3 devices

To get a smoother experience on your Raspberry Pi 3 device, while running the Raspberry Pi 4 image do this:

  • Install xf86-video-fbdev.
  • Edit /boot/config.txt and comment out dtoverlay=vc4-kms-v3d and max_framebuffers=2.
  • Save the file and reboot.

Supported Devices:


  • Generic Aarch64 (With Tow-Boot installed on SPI)
  • Generic EFI Aarch64 (With Tow-Boot installed on SPI) and Quartz64-A with EDK2-QUARTZ64
  • Khadas Vim 2
  • Khadas Vim 3
  • Odroid C4
  • Odroid HC4
  • Odroid M1
  • Orange Pi 3 LTS
  • Orange Pi 4 LTS
  • Orange Pi 800
  • Pinebook Pro
  • Quartz64 Model A
  • Quartz64 Model B
  • Radxa Zero
  • Raspberry Pi 4 (tested on Model B, Raspberry Pi 3 and Raspberry Pi 400)
  • Rock 3A
  • Ugoos AM6 Plus

With Manjaro ARM Installer (in addition to the above devices): (Download it here)

  • ClockworkPI DevTerm
  • Khadas Vim 1
  • Khadas Edge-V Pro
  • LibreComputer ROC-RK3328-CC
  • NanoPC T4
  • Odroid C2
  • Odroid N2
  • Odroid N2+
  • Pine64+
  • Pine64-LTS
  • Pine-H64
  • Pinebook
  • Pinephone
  • Pinephone Pro
  • Rock64
  • RockPro64
  • Rock Pi 4B
  • Rock Pi 4C

What about other devices?

While we do make images for a lot of devices, we won’t be making images for all the supported devices. If your desired image for your desired supported device does not exist, please use manjaro-arm-installer to install it to an SD/eMMC card.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


I just tried the pi3 trick and now it won’t boot. says the codec has an invalid control.

what is first setup script package name?

On the Minimal editions it’s called manjaro-arm-oem-install. On GUI editions it’s Calamares.


My S905 Tv box (Clone of MXQ 4k Pro P201) could boot Manjaro-ARM-mate-vim2-22.08.img and update to 23.02 with latest mainline kernel without any problem, but the later releases, including Manjaro-ARM-minimal-vim2-23.02.img would always bring me into this error:

OF: reserved mem: failed to allocate memory for node 'linux,cma': size 896MiB
Starting systemd-udevd version 252.5-1-arch
meson-drm d0100000.vpu: Failed to find CVBS Connector bridge
Error: device 'PARTUUID=83251003-02' not found. Skipping fsck.
mount: /new_root: can't find PARTUUID=83251003-02.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]#

So what is changed after vim2-22.08 release and is it possible for me to boot 23.02 image with some tweak? I tried to create my own profile and make image with manjaro-arm-tools ,but unfortunately, it did not boot:

# Kernel and bootloader stuff

# Video driver

# Other device specific packages

I think the partuuid of the boot and root partition have changed. Just update it in extlinux.conf and fstab

That should fix the issue.

Hello, @spikerguy, I no longer have a recognized sound card (apart from my full digital amplifier in usb or bluetooth audio). what’s happening :slight_smile: ? Cordially.

Out of curiosity, what difference there is between the Generic image and the Pinebook Pro one? I know the PBP can run both.

The Generic image comes without a bootloader, so it requires the device to have it’s own, like Tow-boot on SPI.
This also makes it possible to have the Generic image bootable on lots of different systems, instead of just the Pinebook Pro.

The Pinebook Pro image comes with u-boot and as such will only really work on the Pinebook Pro, because the boot software is designed for it. And it also comes with a couple of other fixes, like a workaround for the Pinebook Pro speaker audio.

1 Like

Thanks for the explanation! BTW audio seems to be working fine even on Generic EFI now.

Which device is it?

am6b plus
I don’t even have the fe.dai errors (those in the screenshot) when I type dmesg

If I have a Pinebook with Towboot installed, should I use Generic or the Pinebook Pro image (for things like the speaker fix)? Will the PBP image overwrite the SPI chip? (I’m thinking no)

I’m asking, but I’m giving it a whirl anyway, haha. I installed Generic yesterday but had some issues, I’m trying the PBP image right now.

so, we missed 23.04-img!

Yes, there might be some change in the duration of the image releases since Dan @Strit is not here anymore.

does buildarmimg broken, after build sway rpi4, its 150M only?

Do you have logs?

sudo buildarmimg -d rpi4 -e sway -v 2023.5.13 -b testing

==> Creating sway edition rootfs image for rpi4...
  -> Extracting aarch64 rootfs...
  -> Setting up keyrings...
  -> Setting branch to testing...

==> Installing packages for sway edition on rpi4...
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
warning: systemd-libs-253.3-3 is up to date -- reinstalling
warning: curl-8.0.1-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "", a dependency of "gitui"
:: The following package cannot be upgraded due to unresolvable dependencies:

:: Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency '' required by gitui
==> ERROR: Aborting...

I skipped gitui and got all the way to the end, but not completely successfully.

Reccommend you try it and report back?


you can install 23.02-img & block gitui.
but still needed hundreds of M-byte update, we need new img to save bandwidth.