Manjaro arm 22.08 won't start on raspberry pi 3 b

Hi. I downloaded the latest version of image for raspberry pi3b from I installed it on the sd card using the etcher utility. When I try to start the raspberry, nothing happens except for a black screen. Then I tried to use another sd card, thinking that mine is not working, it still does not work. I tried to change the rufus utility to write to the sd card. Doesn’t work again. I tried different versions of manjaro arm 22.08 (gnome, plasma, mate, minimal, sway, xfce) - in vain.

Then I decided to install manjaro arm minimal 21.08 and it started, but after using sudo pacman -Syyu and restarting raspberry I got the same problem - it stopped starting again, as if there was no system at all

Welcome to the forum! :wave:

Please edit your post to change the title to have some informational content. You are posting on the Manjaro Linux forums, so we know you are asking about Manjaro. You’ve posted in the #arm:technical-assistance section, so we know you need help with ARM. Your title is an opportunity to provide additional information that is not already obvious from where you posted.

Please see:

If you have the option - I reccommend rpi-imager from the official repo.

To my knowledge there’s no official support for RPi3 - on the other hand

I have no issues with Manjaro on RPi3B - previously that is.

EDIT - I have checked with the rpi minimal on a 3B - no problems.

On the download page - the default download is a generic arm image - I don’t know if it makes any difference but you can use the dropdown to select an image specifically for RPi.

Another issue I have had is if I use the UUgear emmc/microsd stick the 3B will not boot.

It is worth ensuring the card is properly seated to connect properly to the system.

I messed with this on my pi3b and I also was having issues booting up. I made quite a few changes yesterday and today but the last change got mine booting into a DE and all seems to be working. I changed this in config.txt:

dtoverlay=vc4-kms-v3d to dtoverlay=vc4-fkms-v3d

I see also that I need some sort of cooling on my cpu :rage:

So now kms is broken and fkms works? Or is this only on the 3B?

Works fine on the pi4.

1 Like

On the Pi4, using vc4-fkms-v3d produces the slow/erratic mouse behaviour and kms-v3d-pi4 fixes it…

Yes, it seems that fkms is only viable on the 3B.

Well I just booted a Raspberry Pi 3 B+ with an original 22.08 Manjaro Pi4 XFce image burnt onto SD card with :

xzcat Manjaro-ARM-xfce-rpi4-22.08.img.xz | dd status=progress bs=16M of=/dev/mmcblk1

And it just boots properly, Plymouth splash and GUI OK.

config.txt contains : dtoverlay=vc4-kms-v3d

I only notice 2 glitches at 1st sight : Network icon and Pamac icon do not show up on the XFce panel (although they are “present but invisible” and do react to mouse clicks).