Manjaro ARM 22.06 released!

We are proud to announce the release of Manjaro ARM 22.06.

You can find all our images on!

All editions are now using pipewire by default

We are still working on getting great support for the Quartz64, but we will not make it part of these releases, until we have most of the stuff working. The mainline kernel 5.19 will likely give us a great boost to achieving this.
But you can find our weekly images on Github for Quartz64-A and Quartz64-B in our Manjaro ARM Flasher.
These images are currently Dev images, based on Unstable branch.

Application for flashing images

We have our own GUI app to make it easy for users to flash a Manjaro ARM image on to an SD card, eMMC card or USB stick.
If you are on Manjaro ARM, simply install manjaro-arm-flasher and launch the app “Manjaro ARM Flasher” from your menu. This will download and flash the image of your choice.

You can also manually run the application (if you are not running Manjaro ARM) by downloading this python script, make it executable with chmod +x manjaro-arm-flasher, install the dependencies listed in the and then run it with sudo ./manjaro-arm-flasher.

First Time setup on Minimal edition

This release sports the First Time setup for all Minimal images, also via SSH. This means that at first boot, you will be asked about the following:

  • keyboard layout (except on pinebook, that is fixed to us layout)
  • username
  • additional user groups (optional)
  • full name
  • password for that username
  • password for root
  • timezone
  • locale
  • hostname

Then the setup script will set these settings and reboot to the login screen.


All the download links can be found on the website

Torrents are also available!


  • New packages from upstream and Manjaro ARM
  • OnlyKey devices are now supported out of the box
  • XFCE 4.16
  • KDE Plasma 5.24
  • Gnome 42.2
  • MATE 1.26
  • Sway 1.7
  • Pacman 6.0

Development images

Images for devices in development or just development (unstable) versions of supported devices can be found on our Github page.

Updating from 22.04:

  • XFCE and MATE editions have switched to pipewire by default, installing pipewire-pulse should be enough to switch.

Tips and Tricks:

Smoothness on Raspberry Pi 3 devices

To get a smoother experience on your Raspberry Pi 3 device, while running the Raspberry Pi 4 image do this:

  • Install xf86-video-fbdev.
  • Edit /boot/config.txt and comment out dtoverlay=vc4-kms-v3d and max_framebuffers=2.
  • Save the file and reboot.

Supported Devices:


  • Khadas Vim 2
  • Khadas Vim 3
  • Generic Aarch64 (So far tested to work on Odroid N2(+), Pine64 LTS and Pinebook Pro, with Tow-Boot installed on SPI)
  • Odroid C4
  • Odroid HC4
  • Odroid N2
  • Odroid N2+
  • Pine64-LTS
  • Pine-H64
  • Pinebook
  • Pinebook Pro
  • Radxa Zero
  • Raspberry Pi 4 (tested on Model B, Raspberry Pi 3 and Raspberry Pi 400)
  • Rock64
  • Rock Pi 4B
  • Rock Pi 4C
  • RockPro64
  • Ugoos AM6 Plus

With Manjaro ARM Installer (in addition to the above devices): (Download it here)

  • ClockworkPI DevTerm
  • Khadas Vim 1
  • Khadas Edge-V Pro
  • LibreComputer ROC-RK3328-CC
  • NanoPC T4
  • Odroid C2
  • Pine64+
  • Quartz64 Model A

What about other devices?

While we do make images for a lot of devices, we won’t be making images for all the supported devices. If your desired image for your desired supported device does not exist, please use manjaro-arm-installer to install it to an SD/eMMC card.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Tried the Gnome edition on the Odroid N2+, 4GB on a eMMC.

  • I get the pink hues/tint problem that will not go away even if I switch to a generic SRBG .icc profile.
  • Some screen artifacts here and there, that seem to depend on the theme selected.
    Other than that, the system does not randomly lag anymore (had tried again some months ago) and is almost usable as a desktop replacement

I haven’t had this happen in a long while (like a couple of years now). Are you certain your monitor is set to standard RGB mode?

Tried using a different N2+, using xfce and kde and different distros, the problem remains.
I use the same monitor and cable on my desktop machine (also running manjaro) and colours are fine.

I tried to install Manjaro-ARM-xfce-generic-22.06.img.xz.torrent. Didn’t work so I tried the KDE image - same result: Firmware not found! I used Balena Etcher and gnome-disk-utility to write to USB.
As this didn’t work out I got the advice to use rpi-imager as it doesn’t pull the images from your website. That worked out for me. Smooth install and runs perfect.
Maybe there’s a problem with the torrents?

This doesn’t tell us much.

The torrents seems to download the image fine.

Pretty sure the Generic image does not work on the Raspberry Pi, as the Raspberry Pi expects certain RPi specific files to be present on the boot partition. Try the Raspberry Pi specific images.

1 Like

Got it - thank you

Hate to break it to you, but this downloads the exact same image that is on our website, from our website. It just only lists the Raspberry Pi specific images and not all the other devices we support.

I hate to add further contradiction, but I can confirm that flashing the current image on the Manjaro website (the image specifically labeled for the Pi) to an SD card won’t boot, where using the Raspberry Pi Imager works properly.

Checked on a Pi4B 8mb twice for thoroughness with both Balena and the Raspberry Pi Imager.

Is there any telemetry that I can post that may help identify the cause?

They are the exact same image. I maintain the image list for both the website and the rpi-imager.

I downloaded an flashed both the one on the website and the one from rpi-imager a couple of days ago to test this when I first saw your report.

Please provide the entire filename of the file you downloaded from the website today.

For the record, I wasn’t the one who filed the report, I was just confirming a shared experience. :slight_smile:

However, upon further examination I did find a possible explanation for what happened with my circumstances:

Where I remember that I was doing this on the day of the new release, the filename – which only now exists in my download history – was “Manjaro-ARM-kde-plasma-rpi4-22.04.img.xz” – so it looks like I was having trouble with the prior release, not the current one.

The version that I flashed directly from the Raspberry Pi Imager that worked fine is no longer cached, but I believe the one from the RPi Imager was likely the current image – and this is probably the cause of the odd behavior.

1 Like

Switching from linux 5.18 to linux-odroid 5.18 fixes the pink grays problem, at least on mate desktop

Raspberry Pi Minimal Version not working for me also (rpi4), and I used the Manjaro ARM Flasher

1 Like

What do you mean with “not working”?

Does it detect the SD card?
Does it turn on the screen?
Does it show the Manjaro logo?
Does it show the setup?

Things started working after I flashed Raspbian Lite, and then used the firmware updater to update my bootloader.

Then after that things worked a bit better, but HDMI failed after kernel boot splash, so after digging deeper I found that my issue was caused by the vc4 configs in /boot/config.txt. Once I commented out the configs in that group, I could finally reach a console. Now things work without issue!

1 Like