Manjaro-ARM-22.02 on Pi4B - no 5GHz WiFi

Hello everyone,

I am 100% new to Manjaro so please bear with me.
I downloaded Manjaro-ARM-kde-plasma-rpi4-22.02 and installed on Raspberry Pi4B.
I cannot see my 5GHz WiFi. Only the 2.4GHz.

How do I resolve this?

TIA

I am currently using Manjaro XFCE 22.02 on RPi4. My 5GHz WiFi shows up only occasionally as available. Other devices use 5GHz without a problem. Same problem for Manjaro Gnome test system. Not new to the 22.02 version. This has been around for at least a year.

BOOTLOADER: up to date
CURRENT: Tue Feb 8 05:24:46 PM UTC 2022 (1644341086)
LATEST: Tue Feb 8 05:24:46 PM UTC 2022 (1644341086)
RELEASE: stable (/lib/firmware/raspberrypi/bootloader/stable)
Use raspi-config to change the release.

VL805_FW: Dedicated VL805 EEPROM
VL805: up to date
CURRENT: 000138a1
LATEST: 000138a1

I do not have 5G but the first thing I would suggest is make sure you have crda installed and your regdomain for your country set.

https://wiki.archlinux.org/title/Network_configuration/Wireless#Respecting_the_regulatory_domain

It has been posted that the pi can not use all 5G channels (The higher ones) and people have to make their router use a lower channel. Seems like maybe channel 6 if I remember right people set.

1 Like

iw list showed all 5GHz channels configured, so I didn’t need to install crda and set regdomain. I switched the router to use a lower frequency (in this case 5220 MHz [44]) and 5Ghz was available and works. 5GHz was not listed as available when a higher frequency was in use. I couldn’t locate documentation saying what the RPi4 limitation is for 5GHz channel/frequency.

2 Likes

A combination of nano /etc/conf.d/wireless-regdom and uncommenting the WIRELESS_REGDOM=“US”, and setting my 5GHz bandwidth to a lower frequency (55 in my case) solved this for me.