Manjaro ARM 21.12 released!

Manjaro ARM 21.12 released!

We are proud to announce the release of Manjaro ARM 21.12.

You can find all our images on!

Manjaro ARM is proud to be the default installation on the Pinebook Pro and the PinePhone from Pine64.
We have put in a lot of work to get to this point and we are excited that we have been accepted by the creators of this laptop and phone, as a great OS option.

Pine64 also recently announced) that Manjaro ARM with Plasma Mobile is going to be the stock OS on the retail of the new PineNote, which is based on the new rk3566 SoC!

Pine64 announced the PinePhone Pro on the November 15th. And yet again, we are honored to be featured as the default OS on the device,
which is based on a special engineered rk3399 SoC, called rk3399s. The main difference between the new SoC and the SoC in the Pinebook Pro, is that the new one
is better suited for enclosed spaces, like a phone case. We have made testing images available on github with both Plasma Mobile and Phosh at the same place as our regular Pinephone images.

We are also working on getting great support for the Quartz64, but we will not make it part of these releases, until we have most of the stuff working.
But you can find our weekly images on Github and in our Manjaro ARM Flasher.
These images are currently Dev images, based on Unstable branch.

We are proud to introduce our first release images for the Radxa Zero, which is a Raspberry Pi Zero formfactor device.
DISCLAIMER: These images do not boot from eMMC yet!

Application for flashing images

We have our own GUI app to make it easy for users to flash a Manjaro ARM image on to an SD card or eMMC card.
If you are on Manjaro ARM, simply install manjaro-arm-flasher and launch the app “Manjaro ARM Flasher” from your menu. This will download and flash the image of your choice.

You can also manually run the application (if you are not running Manjaro ARM) by downloading this python script, make it executable with chmod +x manjaro-arm-flasher and then run it with sudo ./manjaro-arm-flasher. It requires python-blkinfo 0.1.3 to be installed, which can be installed with pip install blkinfo.

Introducing Calamares

This release uses Calamares as our new First Time Setup tool.
Calamares is a QT based graphical application for setting locale, keyboard layout, User information, timezone and so forth.
This also means, that SSH can no longer be used to setup the system on GUI editions.

First Time setup on Minimal edition

This release sports the First Time setup for all Minimal images, also via SSH. This means that at first boot, you will be asked about the following:

  • keyboard layout (except on pinebook, that is fixed to us layout)
  • username
  • additional user groups (optional)
  • full name
  • password for that username
  • password for root
  • timezone
  • locale
  • hostname

Then the setup script will set these settings and reboot to the login screen.



KDE Plasma





All the download links can be found on the website

Torrents are also available!
Because of the new build system, gpg signature is not available yet


  • New packages from upstream and Manjaro ARM.
  • All GUI editions now use Calamares for First Time Setup
  • XFCE 4.16
  • KDE Plasma 5.23
  • Gnome 41.1
  • MATE 1.26
  • Sway 1.6
  • Pacman 6.0

Updating from 21.10:

  • We added irqbalance to most of our editions. Install it with sudo pacman -S irqbalance and enable the service with sudo systemctl enable --now irqbalance.

Known issues:

  • No audio cards on Roc-CC.
  • Some devices can’t boot from eMMC. Check this issue report.

Tips and Tricks:

Smoothness on Raspberry Pi 3 devices

To get a smoother experience on your Raspberry Pi 3 device, while running the Raspberry Pi 4 image do this:

  • Install xf86-video-fbdev.
  • Edit /boot/config.txt and comment out dtoverlay=vc4-fkms-v3d and max_framebuffers=2.
  • Save the file and reboot.

Supported Devices:


  • Khadas Vim 2
  • Khadas Vim 3
  • Odroid C4
  • Odroid HC4
  • Odroid N2
  • Odroid N2+
  • Pine64-LTS
  • Pine-H64
  • Pinebook
  • Pinebook Pro
  • Radxa Zero
  • Raspberry Pi 4 (tested on Model B, Raspberry Pi 3 and Raspberry Pi 400)
  • Rock64
  • Rock Pi 4B
  • Rock Pi 4C
  • RockPro64

With Manjaro ARM Installer (in addition to the above devices): (Download it here)

  • Khadas Vim 1
  • Khadas Edge-V Pro
  • LibreComputer ROC-RK3328-CC
  • NanoPC T4
  • Odroid C2
  • Pine64+

What about other devices?

While we do make images for a lot of devices, we won’t be making images for all the supported devices. If your desired image for your desired supported device does not exist, please use manjaro-arm-installer to install it to an SD/eMMC card.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


sway download checksum ok, first booting setup error, tested twice.

Thanks for catching that. I’ve removed the download links for the Sway editions, until we figure out why it happens and have fixed it.

btw, click volume icon after that dialogue can not close.

On Radxa Zero, I could not succeed Manjaro 21.12 image boot from uSD card. I tried with clean eMMC, Ubuntu (official) and Debian (official).

Manjaro 21.12 needs Android on eMMC to run frm sd Card.

1 Like

Has the boot method changed in 21.12 release? I tested Manjaro-ARM-minimal-vim2-21.12.img.xz on my GXBB S905 Tv box and although it could boot into system, there’s something trouble with HDMI output. If I plug HDMI cable after system is fully up, there’s no HDMI signal. Besides, systemctl reboot does not work properly. With another Tv box, I add boot-vim2 to IgnorePkg and upgrade to 21.12 and everything is working as expected. There’s no u-boot.ext in core/boot-vim2 2021.12-2 , does that means the vendor’s u-boot directly boots manjaro without Chainload method ?


Do you see uEnv.ini in /boot/ if you do then that is the bootscript booting method.

This have always been the case with most of the arm devices.

Yes there seem to be some problem with reboot in newer kernel for some devices.

Yes if there is no u-boot.ext that means it is using bootscript method where it just loads the linux kernel over the existing vendor bsp uboot instead of chainloading mainline uboot.

I just found the reboot is an issue on latest kernel with boot script. I will have to debug it on vim2/vim3, It was working fine on older kernel.

1 Like

Rock Pi 4B Minimal still links to version 21.10

Not for me. Please update your browser cache.

Thanks, that did help.

Thanks for clarifying. Please notice me if you need test on GXBB variants.

so, there is no more sway-21.12 ?

Not for now. Will be when I finish the re-release.

Is it a good advice to enable that for a rpi4 xfce edition ? (desktop’s usage)

The ‘manjaro-release’ package is still 21.10 in unstable branche, is it normal ?
It provides /etc/lsb-release and then DISTRIB_RELEASE=21.10

Ah, that’s an oversight. I’ll update it.

1 Like

Is it a good advice to enable that for a rpi4 xfce edition ? (desktop’s usage)
@Darksky what do you think ?

I do not know. There is not much out there about it being enabled. The only thing I was able to find is one guy said it made his sound choppy.