Manjaro ARM 21.08 released!

This sounds a lot like the way Apple and updates the OS on its devices.


Congratulation to the dev team, calamares is now a nice feature to set an arm device, user friendly.
Is it an issue? With calamares I can’t set an user with a . I mean I Can’t set but nl-smart or nl_smart.

Is calamares include if I build an image ?
sudo buildarmimg -d on2 -e kde-plasma -v 2021.08.23 -n

The Odroid n2 is working again with your last stable image download on the Manjaro web site :-)

Is it thinkable in the future to boot an usb stick with an image on an arm device ? like the manjaro x86_64 image and install the os on a device ?

This seems to be a limitation in the Calamares user module. It would be the same on an x86_64 install media.

It’s not something we plan on doing, as the filesystem setup needs to be pretty specific and the u-boot part needs to be flashed to specific sectors on the drive.
However, or Manjaro ARM Installer does something like it.

Thanks for your reply.

Is calamares include if I build an image ?
sudo buildarmimg -d on2 -e kde-plasma -v 2021.08.23 -n

If you use the newest release of Manjaro ARM Tools, yes.

Since the last manjaro-arm-tools I built some image and calameres wasn’t include…

I can’t build and test an image today, but tomorrow.

The Calamares stuff was added after 2.10.2, so you need at least 2.10.3 for that.

I’ll test it as soon as possible, Thanks for your reply, have a good day.

It’s nice to see the 21.08 release ! :smiley:

Btw, linux-aml ( 5.13.0-1-MANJARO-ARM #1 SMP PREEMPT Wed Jun 30 23:07:51 +03 2021 aarch64 GNU/Linux) works on my board while linux (I think it is mainline kernel in the img ? ) not. Is it possible to manually replace mainline kernel in the released image with linux-aml ? I flashed my SD card accidently yesterday so I do not have a running Manjaro at the moment otherwise I could build myself with buildarmimg.

If you build the image, sure.

Just change the device profile for you board in /usr/share/manjaro-arm-tools/arm-profiles/devices/ to say linux-aml instead of linux and build the image.

What board do you have?
As far as I’m aware, we don’t have any board in our supported list that requires linux-aml to boot.

It is a S905 P201 Tv box actually , basically clone of MXQ 4K P201 . I used official khadas-vim-2-minimal 21.04 release and updated to 21.08(with linux-aml) without any issue . Yesterday I built an image based on vim2 profile : (Just switched to linux-aml and commented out some firmware )

sudo buildarmimg -d vim2m -e minimal -v 21.08 -n
## Maintained by Spikerguy ##

# Kernel and bootloader stuff

# Video driver

# Other device specific packages

However my image fails to boot and enters android recovery directly . I think I’m not supposed to comment out those firmwares in profile ?

Did you create A new device called vim2m ?

Can you confirm whether the build process was completed correctly?

Check if the image have boot-vim2 pkg files in BOOT_MNJRO partition.

I copied profile from vim2 and renamed it to vim2m .

I checked pkgs.txt and yes, it has boot-vim2 2020.09-1 . In BOOT_MNJRO there are

u-boot.ext u-boot-s905 u-boot-s905x2-s922 u-boot-s905x-s912

and I renamed u-boot-s905 to u-boot.ext . I’ll do further test later.

First of all, the work that has gone into this, and the product; just stunning. It’s really amazing just how usable my pinephone is with manjaro. I use it as a primary phone, and have been for a while. A testament to the amazing work done by everyone here.

After the last update, just tracking two issues. Still having issues with the sound and bluetooth, as per my post on the last update. Also, it seems that the last update has caused chatty to duplicate sms messages when I send them.

Just an edit: I’ve tried downgrading chatty, the problem still persists. Perhaps this might be an issue with some related package?

1 Like

Can we “script” setup ?

If you use the Manjaro ARM Installer, you don’t get the first run setup screen. No matter which edition.


Should have used Vim1 profile instead as I see your device is based on S905 Soc and not S912, I am still not sure if it is S905 or S905X

Good Luck.

1 Like

The official Plasma for Pi4 download link continues to be:

If you cut & paste and change both 7 → 8, it will download the 21.08 version.

You must have a cached version of the website loaded, because it points to 21.08 for me on the site.

So try doing a CTRL+F5 on that page and check again. :wink:

1 Like

Yup, that fixed it.