Manjaro Architect with BTRFS Install Questions

Hello, I wanted to install Manjaro with btrfs root and home, but Calamares gave me an error in the middle of the install.
So I looked up how to install with Architect and did so, but now there’s no wifi and majority of the default Manjaro KDE software and configs are missing (also octopi instead of pamac)
What do I need to do to install Manjaro on btrfs with Calamares, and is there a way to install the default Manjaro KDE software and config with Architect?

I did a very similar install only for Gnome. From all my research Calamares doesn’t yet support BTRFS with subvolumes so there isn’t a way to do what you are trying to do through it.

As for the missing KDE software and settings, my best guess would be that you missed some of the options when installing through architect. I know I did my first time through it.

I don’t know what I missed.
What I found strange is that there was no kde when selecting the DE, only kde-minimal.
Could it be because I’m installing it from the Manjaro KDE iso?

Hmm, I made it work.
I was installing on a new HDD with GPT partition table, but when I clicked next I got a warning saying I needed to make an unformatted 8mb partition with grub_bios flag, so I did that.

This time I made it with 1 fat32 boot, 1 btrfs root and 1 btrfs home partition like I intended, and it worked.

EDIT: Nope, I reinstalled again and made grub_bios. There was no problem this time.

This sounds strange 'coz I’ve installed Manjaro i3 with Calamares a month ago and it created both @ and @home alright. Btrfs v5.9.

I wonder why it didn’t work with an uefi install, when I tried linking the boot partition to /boot/efi.
Maybe the boot flag? Was there some other flag I was supposed select besides boot?
I just checked and there’s no btrfs subvolume @home in /home. Shouldn’t Calamares make it by default?

Do you have your /home on a separate partition? If no, then

  • sudo btrfs subvol l /

should show all your subvolumes. I believe, it’s a default layout immediately after install with Calamares.

Yes, the root and home are separate partitions. I thought Calamares would make @home by default but I guess it only works if they’re on one partition.
The reason I made them on separate partitions is so that I can reinstall or try new distro. But I don’t know how to only format a subvolume. For instance, how would I go about reinstalling Manjaro by formatting root while keeping home subvolume untouched, if they were on one partition in Calamares?

The only way I can think about is to probably restore it from a snapshot made beforehand.
As for separate partitions, well, I had my Manjaro Deepin installed in such fashion, however, later I abandoned this practice because I began to have serious problems with balancing the root subvolume and no empty space on it, tho filemanager showed a lot of space available, while @home on its separate partition was scarcely used.
By the way, you still can see your @home subvol if you mount its partition to, say, /mnt and check it with the btrfs list command.

1 Like

I’ve been doing some testing and unfortunately, when Calamares sees that there is a @ or @home it throws some python create @ @home error when I choose to keep the content without formatting.
I came up with deleting @ and renaming @home to @backup, so I can move the data to the new @home.
Or just deleting the new @home after the installation and renaming @backup to @home again (From a Live CD).

Thanks, I’ll make sure to not use separate partitions next time.
Also found this useful tip.

There’s a typing error in: dd if=/dev/zero of=/mnt/ramdisk/extend.img bs=4M count=1000
Missing “=” in “of /mnt/ramdisk…”

I also have a problem with mounting a new subvolume, because I have one SSD with @ and can’t umount @ so I get an error that /dev/sdaX is already mounted and I can’t change the default subvolume with:
sudo mount -o subvolid=258 /dev/sdaX /mnt
So the only solution is to make a new fstab entry. Do you have any idea how to mount subvolume without fstab?

Thanx a lot for the link.
As for mounting, I immediately turned to the terminal and tried to mount my @, already mounted by fstab, and it mounted alright. So, I’m at a loss and can’t tell you anything positive, sorry.

This is my output:

[user@user-manjaro ~]$ sudo mount -o subvol=@ /dev/sda2 /home/user/media
mount: /home/user/media: /dev/sda2 already mounted on /.
[user@user-manjaro ~]$ sudo mount -o subvolid=256 /dev/sda2 /home/user/media
mount: /home/user/media: /dev/sda2 already mounted on /.

Does this work for you? Or am I missing something?

Here is what I have after doing similar commands (with different sdX and id of course):

[malex@manjaro ~]$ sudo mount -o subvol=@home /dev/sdb9 /mnt
[sudo] password for malex:
[malex@manjaro ~]$ sudo mount -o subvolid=257 /dev/sdb9 /mnt
[malex@manjaro ~]$

Same goes for @. That is everything mounts to the mountpoint and I open my /mnt and see my subvols and can open them etc.

1 Like

It worked!
I realized I might have already mounted the device, but every time I looked in /mnt it showed as empty even with hidden files on.
It’s weird, when I manually fill the location bar /mnt/user it showed up, but dolphin shows /mnt as empty.

GREAT!!! Congrats! :star_struck:
It happens smts with file-managers, just hit F5 and refresh the tab.

1 Like

No, it doesn’t show the folder. I would get in and out of /mnt but it wouldn’t show.
Anyway, Thanks for your help.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.