Manjaro Architect hanging on "Generating grub.cfg.example config file"

grub
manjaro-architect

#1

Hi! This is my first post, and I’m a relatively new Linux user, so if I mess up in some way, please point it out!

I keep trying to install Manjaro Architect following this guide and using this guide to set up LUKS and LVM, but when I reach the point of installing GRUB, it hangs at:
Generating grub.cfg.config.example config file...
This may fail on some machines running a custom kernel.

I’ve been told it can take around 10 minutes but I’ve tried multiple times ranging anywhere from 30 minutes to 2 hours. What could cause it to take so long?


Manjaro-architect z-release 0.9.20
#2

lvm+grub

Take a look at this thread:


#3

And after you see my thread and tutorials I invite you to THIS ONE because you also may see this issue and we have to solve it)
In short. You have to use architect by that manual only for partition, LUKS, create volume group and mount. Thats all. And only. And then run graphical installer. There you indicate your bootloader on separate partition fat32 as /boot/efi, then in the top you chose instead of your hdd yours new Volume Group which should contains / /home swap (what you need) and indicate these mount points WITHOUT FORMATTING because it change names of Logical Volumes and you broke Volume Group. Hit install. You could see also in my last topic how I partition my disk.


#4

I’m having the same issue with just ext4 standard partition no LVM with LUKS.


#5

I just did an Architect install today. Basic uefi and ext4, no LVM or encryption. Twice stalled for about 10-15 minutes each during two stages of the grub portion of the install.

Eventually, my install did continue and finished with the “failed to install bootloader” false-positive error.

Confirmed boot into a fresh, perfect install.

GM


#6

Managed to get LVM+LUKS working, however I get a “Mount Failed!” error when mounting after installing the stable branch.


#7

Hello!
My installation also hangs on the step as in the title of this thread.
Does anyone know when can we expect fixed version of Manjaro Architect to be available?


#8

Same error with latest Manjaro-architect 0.9.20 (Manjaro-architect z-release 0.9.20) …


#9

It should now be fixed in uefi boot, but not tested nor implemented with legacy boot.