Manjaro Architect GRUB error

I get an error when it’s time to install GRUB:

Blockquote [Install GRUB][1] cp: cannot stat ‘EFI/manjaro/grubx64.efi’: No such file or directory

what’s going on here? -_-

1 Like

Possibly a syntax error? What was the command by which you attempted to install GRUB?

possible but unlikely, I’m simply running the automatic installer of the latest Manjaro Architect ISO… (from a pendrive).
Everything goes fine, including the download via wifi of all the necessary stuff, then when it’s time to install GRUB, the installer stops and shows that error: I got prompted no option to intervene, just “ok”…
I am not exactly an expert, but I guess that without GRUB my os won’t boot…

Switch to a different tty and try manually installing GRUB. If you need more information with that, then I’m afraid you are going to have to provide us with more information first; the quality of the help you’ll get always depends on the quality of the information you provide. :wink:


1 Like

Likely harmless, you can ignore it

eheh, the laptop boots directly to UEFI/BIOS, there is not even option for any disk/partition to choose from, so I guess that’s really critical.
Being the second time I attempt the install of Architect, and it fails always at the same point, I can think of several reasons for that, the first being “I’m still too nub” of course, but since I need that laptop standing on its feet asap I guess I’ll download the usual Manjaro ISO and that’s it.
Thanks anyway all for the tips :slight_smile:

You can fix it by installing grub manually if you want, but yes, calamares is a simpler installer.

1 Like

Make sure you get the 2.1-rc5 version of the .iso. :wink:

Hi Aragorn,
I have the same problem using the iso here:

How do you mount EFI partition during install?

@cfinnberg, so glad to receive your prompt response.
I am using Chris Titus Tech’s method of installing, he did not mention anything about mounting EFI partition.
I am a noob, let me know any further question you have

I check the video and he installs using BIOS mode. If you get the same error than the OP, then you are installing in UEFI mode. You should probably have noticed that not all dialogs are the same than the video

1 Like

:open_mouth:Ohhh, how to ensure to install using BIOS mode…

That depends on you computer and how you have configured your BIOS/UEFI settings. Probably it’s better that you find some guide to do in UEFI or use the normal installation media if you are new to Linux.

1 Like

Sure, I will just reset my BIOS settings using this guide for my laptop Dell Latitude E5430:

Don’t do that. That guide is not for changing your UEFI settings. Look up for help from some friend or where you buy your computer


What’s going on is that you need to read the wikis first to understand the difference between BIOS and UEFI installs here: Installation Guides - Manjaro , then try more advanced install methods :laughing:

/added: Some basics of MBR v/s GPT and BIOS v/s UEFI - Manjaro


From the Arch wiki I used Architect to install my root and even though it failed to create a bootloader in Architect, I managed to manually create it by doing this:

  1. mount both the root directory and the EFI partition. If nothing mounted to /mnt (or if you umount /mnt) make directories /mnt/root and /mnt/esp. Replace x with installation disk number. This presumes UEFI partition is 1 and root partition is 2

    sudo mkdir /mnt/root
    sudo mkdir /mnt/esp
    sudo mount /dev/sdx1 /mnt/root
    sudo mount /dev/sdx2 /mnt/esp
    sudo grub-install --target=x86_64-efi --efi-directory=/mnt/esp --bootloader-id=GRUB --root-directory=/mnt/root

This worked for me

@cscs do you want to check why grub installation is failing in manjaro-architect?

I wouldnt be able to for some days.