Manjaro Architect Freezing

I’m trying to install Manjaro on my XPS 9700 but Architect keeps acting up. Occasionally the screen will flicker on the Welcome to Manjaro screen, and every time I enter setup the entire system freezes.

I’m using the latest version of Manjaro Architect. My laptop has an Nvidia RTX 2060 MaxQ so I load in with non-free drivers. However even with free drivers I get these freezes. Any help would be greatly appreciated!

Here’s an image of what the frozen screen looks like. It looks… Weird. Foggy with a line running down the middle of the screen. I don’t have an graphical/screen issues on Windows (or Arch) so this isn’t a screen issue.

Edited for better visuals.

There is a discussion about that model here

In some cases you need to use also some ACPI custom kernel boot parameters. See here:

And one i’m sure you also should use is

Yeah I’ve been keeping an eye on that thread as this audio problem is widespread for the 9700 (though a Redditor found a fix for it on kernel 5.7.

I noticed that nouveau.modeset=0 is already in there by default. I tried acpi_rev_override=1 before - remembered that was needed when installing Manjaro on my XPS 9560. Went through 1 to 5, and 2 got me the furthest through Architect before freezing on my (made it to mirror list search and poof. 1, 3, 4, and 5 didn’t get me past the login in prompt.

Oddly enough, I just installed Manjaro (i3) with Calamares and it worked without any issues -_-