Manjaro-architect command not found

Just downloaded Manjaro Architect iso from official website


While installing (setup) i am getting error:

util-linux-libs and libutil-linux are in conflicts
error: unresolvable package conflicts

sudo:manjaro-architect: command not found


You didn’t search for the error, did you?

I’m having the same issue as OP.

Your helpful pointer to look at the recent posts shows someone else had a similar issue ([Architect] Unresolvable package conflicts detected: util-linux-libs and libutil-linux) and if I’m reading it correctly, they were basically told that they have to download a full ISO (which includes manjaro-architect). That doesn’t really seem like a fix for the core issue though; that the latest version of the standalone manjaro-architect ISO from Manjaro - Downloads or Downloading File /architect - Manjaro Linux - OSDN doesn’t work out-of-the-box and (to the best of my understanding) there isn’t a clear workaround aside from compromising and grabbing something like XFCE minimal.

Yep so if you read the thread about the issue you’re right, the old Architect only ISO is old and has an issue, your solution is to use another ISO. That’s not a fix that’s your only solution for now. Until they rebuild a new Architect ISO.

I did.
And the solution says

Architect is available on any ISO, you’ll want to download a newer one like 20.2.1.

And i have already downloaded the latest Architect iso and I am still getting that error

Then reply to the appropriate thread, this thread is solved already.

That’s understandable, and a bit more searching shows that it’s unlikely that will come anytime soon; it seems Architect is without a maintainer. Maintainer(s) wanted

Okay i found a fix for the minimal architect iso.
when you get this error. just run the command.

sudo pacman -S util-linux-libs

and it will ask you to remove the other one then press Y, and you are good to go.
Just tried and installed


Aside from any workarounds, I think the intended solution is to grab a copy of an ISO for one of the currently supported releases (e.g. XFCE 20.2.1, perhaps in the minimal variant) and use architect from there.

1 Like

Perhaps another part of the solution should be to remove architect’s seperated old download from the main site so everyone who downloads it doesn’t come and start one of these threads?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.