Manjaro and VirtualBox 3-D Acceleration issue

Host Device : Windows 10 (latest version)
Guest Device ( using on virtualbox) : Manjaro KDE Plasma 21.0.7

So bassically I wanted to use manjaro bcuz i was bored of other distros and also wanted to have arch experiance. I always use linux on virtualbox and give 4gb ram which is ample. I had an issue of no full screen inspite of using guest additions image. Later I tried using the VboxSVGA as my graphics controller, it worked and got a full screen display. But i am unable to use 3d re-acceleration for animations on my manjaro.

Welcome to the forum! :slight_smile:

You would actually be far better off with GNU/Linux as the host and Microsoft Windows as the guest.

I’m afraid that’s down to the host operating system. The host OS must allow pass-through of the GPU acceleration to the guest.

For all the other distros it works fine

Sorry, but regardless of the Host OS, VirtualBox has a clear instruction for Guest configuration:


So, if you want 3D acceleration enabled then use VMSVGA and not VboxSVGA

Yes, I have tried using VMSVGA graphics controller. It doesnt switch to full screen after installing virtualbox guest addtions CD image. Also, If I use VBoxSVGA controller , it gives me full screen but no animations which is not good.I really like Manjaro, no other linux distro is working well for me.
I dont wanna ruin my system with dual boot and and use manjaro in my virtualbox.

Edit : Really sorry for the late reply : (

Is that something that helps the workflow ?
VMSVGA graphics is not part of VBox, is just offered as alternative and virtualbox guest additions makes no difference with it.

On the other hand, make sure you select OpenGL 3.1 in your KDE Plasma install, that makes animations active, and other desktop effects that otherwise are not working.

Well, I am really - really happy your new update 21.1 pahavo is a blessing indeed. So me with no hopes deleted my virtual machine and installed the new update pahavo iso which is around 3 gigs. Then i made a virtual machine, with default setings and didnot change anything. I got the full screen from the startup itself. I was really happy , installed the manjaro in my virtualbox then shut it down and then i removed the iso . And then started the VM with 3d re accleration enabled and increased the video memory to full and started my machine . All the animations are working now and also the resizing without install guest additions . Also the default one was VMSVGA controller .

Tysm Manjaro team and everyone who supported me
Now Everthing is finee :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.