Manjaro and Lenovo Thinkpad doesn't find my SSD anymore

One Week ago I reinstalled Manjaro KDE on my Laptop but this time i encrypted the ssd. Now i want to boot the Laptop but i doesen’t work. My SSD doesen’t get recognized in my BIOS and in Manjaro Live Boot. Output from Commands

. Only the USB Stick get’s recognized but not my SSD. Is there a way how i could get my SSD back ?

This is a hardware issue:

  • or the cable was shaken loose: unplug it from both sides, clean contacts, re-insert
  • Your SSD died: replace it
    • unlike HDDs, who die a slow death lice cancer (slowing down, read errors, clicking, death)
    • SSDs die suddenly like a heart attack and it’s a good idea to check their health regularly with smartctl

:sob:

How did you do this, exactly?

1 Like

I just pressed Encrypt and entered the Encryption Key in the installation screen. I also Checked that he wipes my ssd before installing Manjaro. Then i Rebooted the Laptop and it worked. But now it doesn’t.

  • Encrypt in the UEFI firmware / BIOS or in the Manjaro installation screen?
  • Did you check the cable?

:thinking:

Yes i encrypted it in the Manjaro Installation Screen. But i still need to check the cable (have not a lot of time in the last weeks). But i will reply if i have looked at the cable.

1 Like

Also post the output to inxi --admin --verbosity=7 --filter --no-host --width as that will give us additional information.

System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=de_DE keytable=de 
  tz=Europe/Berlin driver=free nouveau.modeset=1 i915.modeset=1 
  radeon.modeset=1 misobasedir=manjaro misolabel=MANJARO_KDE_2011 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20NF001HGE v: ThinkPad E595 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20NF001HGE serial: <filter> UEFI: LENOVO 
  v: R11ET32W (1.12 ) date: 12/23/2019 
Battery:
  ID-1: BAT0 charge: 35.2 Wh condition: 43.7/45.7 Wh (96%) volts: 11.6/11.1 
  model: Celxpert 01AV448 type: Li-poly serial: <filter> status: Discharging 
  cycles: 46 
Memory:
  RAM: total: 13.64 GiB used: 1.02 GiB (7.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 18 (24) 
  stepping: 1 microcode: 8108102 L2 cache: 2048 KiB bogomips: 33551 
  Speed: 1221 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 1222 2: 1223 3: 1223 4: 1222 5: 1222 6: 1222 7: 1319 8: 1396 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sha_ni skinit smap smca sme smep ssbd 
  sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext 
  tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Picasso vendor: Lenovo ThinkPad E595 driver: amdgpu v: kernel 
  bus ID: 04:00.0 chip ID: 1002:15d8 
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus ID: 3-2:3 chip ID: 13d3:56a6 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu 
  FAILED: ati unloaded: modesetting alternate: fbdev,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: AMD RAVEN (DRM 3.38.0 5.8.11-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio 
  vendor: Lenovo ThinkPad E595 driver: snd_hda_intel v: kernel bus ID: 04:00.1 
  chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Lenovo ThinkPad E595 driver: snd_rn_pci_acp3x v: kernel 
  alternate: snd_pci_acp3x bus ID: 04:00.5 chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo ThinkPad E595 
  driver: snd_hda_intel v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo ThinkPad E595 driver: r8169 v: kernel port: 3000 
  bus ID: 01:00.0 chip ID: 10ec:8168 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Lenovo ThinkPad E595 driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: 2000 bus ID: 03:00.0 chip ID: 10ec:b822 
  IF: wlp3s0 state: down mac: <filter> 
  WAN IP: No WAN IP found. Connected to web? SSL issues? 
Drives:
  Local Storage: total: 59.75 GiB used: 135.2 MiB (0.2%) 
  ID-1: /dev/sda type: USB vendor: Samsung model: Flash Drive FIT 
  size: 59.75 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1100 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: N/A size: 10.23 GiB used: 135.2 MiB (1.3%) fs: overlay 
  source: ERR-102 label: N/A uuid: N/A 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/sda1 size: 2.90 GiB fs: iso9660 label: MANJARO_KDE_2011 
  uuid: 2020-10-01-14-09-49-00 
  ID-2: /dev/sda2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: 1AFD-57C6 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Device-1: 2-2:2 info: Silicon Motion - Taiwan (formerly Feiya ) Flash Drive 
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 3.1 speed: 5 Gb/s 
  chip ID: 090c:1000 serial: <filter> 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 3-1:2 info: Realtek RTL8822BE Bluetooth 4.2 Adapter 
  type: Bluetooth driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 0bda:b023 serial: <filter> 
  Device-2: 3-2:3 info: IMC Networks Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 13d3:56a6 
  serial: <filter> 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 43.4 C mobo: 0.0 C gpu: amdgpu temp: 43 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 242 Uptime: 1m Init: systemd v: 246 Compilers: gcc: N/A Packages: 
  pacman: 1201 lib: 318 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.05
  1. I suppose you cleaned / replaced the SATA cable and in that case:
  2. Yup, no sign of the SSD, so unless you changed a BIOS/UEFI option (E.G. RAID MODE):

Your SSD is dead! Sorry!

:sob:

After putting them in an other laptop it works.

Can you use the cable from the other laptop in the original?

Yes it works

If it still doesn’t work in the original machine with the cable from the second machine, it’s highly probable that your SATA controller died and that’s a cheapish replacement part. (is why I’m asking)

:+1: