Manjaro (5.15) frozes 6' after login

Kernel Version 5.15.7-1

Last things I’ve done were install some language packs which it said to be missing, and several applications, the last one being “Intellij idea community”; I’ve also applied some updates from pacman graphic interface.

Now, system, in GUI mode, frozes after some minutes; no mouse, no key response, the only way to get a response from the computer is to turn off.

The image shows Ntop after system froze. May be it is a journald problem?

I’ve tried to open a terminal before GUI login, and it’s worked!

I have done a pacman update, and system seems to be working now…
I’d entered terminal to run inxi, and this were the result:

  Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: ro root=UUID=886f64f9-d824-41d1-80a2-d374c3d36147
  Console: tty 5 DM: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81BG v: Lenovo ideapad 320-15IKB
    serial: <filter> Chassis: type: 10 v: Lenovo ideapad 320-15IKB
    serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <filter>
    UEFI: LENOVO v: 6JCN33WW date: 06/30/2020
  ID-1: BAT0 charge: 18.8 Wh (84.7%) condition: 22.2/30.0 Wh (74.2%)
    volts: 8.1 min: 7.4 model: LGC L16L2PB2 type: Li-poly serial: <filter>
    status: Charging
  RAM: total: 11.48 GiB used: 593.6 MiB (5.1%)
  Array-1: capacity: 32 GiB slots: 2 EC: None max-module-size: 16 GiB
    note: est.
  Device-1: ChannelA-DIMM0 size: 4 GiB speed: 2133 MT/s type: DDR4
    detail: synchronous unbuffered (unregistered) bus-width: 64 bits
    total: 64 bits manufacturer: Samsung part-no: M471A5244CB0-CRC serial: N/A
  Device-2: ChannelB-DIMM0 size: 8 GiB speed: 2133 MT/s type: DDR4
    detail: synchronous unbuffered (unregistered) bus-width: 64 bits
    total: 64 bits manufacturer: G.Skill part-no: F4-2133C15-8GRS serial: N/A
  Info: model: Intel Core i5-8250U socket: U3E1 bits: 64 type: MT MCP
    arch: Coffee Lake family: 6 model-id: 0x8E (142) stepping: 0xA (10)
    microcode: 0xD6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 702 high: 718 min/max: 400/3400 base/boost: 1500/3400
    scaling: driver: intel_pstate governor: powersave volts: 0.7 V
    ext-clock: 100 MHz cores: 1: 718 2: 700 3: 700 4: 700 5: 699 6: 700 7: 700
    8: 700 bogomips: 28808
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c
    flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp
    hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca
    mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
    pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
    rdrand rdseed rdtscp rep_good sdbg sep sgx smap smep ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: Syntek EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:3
    chip-ID: 174f:116a class-ID: 0e02 serial: <filter>
  Display: server: driver: loaded: modesetting
    alternate: fbdev,vesa tty: 170x48
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.40 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 4000 bus-ID: 01:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 3000
    bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-7:2 chip-ID: 0bda:c024 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 1.03 TiB used: 14.88 GiB (1.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SK Hynix model: HFS128G32TNF-N3A0A
    size: 119.24 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0P10 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDH3 1T00
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 20RL scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 73.24 GiB size: 71.54 GiB (97.68%) used: 14.68 GiB (20.5%)
    fs: ext4 block-size: 4096 B dev: /dev/sdb2 maj-min: 8:18 label: MJ-ROOT
    uuid: 886f64f9-d824-41d1-80a2-d374c3d36147
  ID-2: /efi raw-size: 384 MiB size: 380 MiB (98.96%) used: 2 MiB (0.5%)
    fs: vfat block-size: 512 B dev: /dev/sdb1 maj-min: 8:17 label: N/A
    uuid: 6864-413A
  ID-3: /home raw-size: 73.24 GiB size: 71.54 GiB (97.68%)
    used: 203.6 MiB (0.3%) fs: ext4 block-size: 4096 B dev: /dev/sdb3
    maj-min: 8:19 label: MJ-HOME uuid: dd1b813b-cfbb-44e0-b1c0-8371b5027442
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sdb4 maj-min: 8:20 label: MJ-SWAP
    uuid: 9659dec3-9ddc-44b4-9a6c-6a92d4fbc9c6
  ID-1: /dev/sda1 maj-min: 8:1 size: 260 MiB fs: vfat label: SYSTEM_DRV
    uuid: 7656-6044
  ID-2: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: N/A label: N/A uuid: N/A
  ID-3: /dev/sda3 maj-min: 8:3 size: 118 GiB fs: ntfs label: Windows
    uuid: 42D05A1CD05A168F
  ID-4: /dev/sda4 maj-min: 8:4 size: 1000 MiB fs: ntfs label: WINRE_DRV
    uuid: 2CDE5B7DDE5B3E70
  ID-5: /dev/sdb5 maj-min: 8:21 size: 768.65 GiB fs: ntfs label: Virtual
    uuid: 48621C73621C67C8
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:c024 class-ID: e001 serial: <filter>
  Device-2: 1-8:3 info: Syntek EasyCamera type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 174f:116a
    class-ID: 0e02 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 30.0 C pch: 32.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 172 Uptime: 11m wakeups: 384 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1216 lib: 347
  flatpak: 0 Shell: Bash (sudo) v: 5.1.12 running-in: tty 5 inxi: 3.3.11

It seems solved. I could do a sudo pacman -Syu; it seems everything to work, and no more freeze problem.

Some hours later:

It hadn’t been solved. It has been working for many hours without problem, but then, again it has been frozen, and then again, it has frozen several times, just some minutes after restart, as on the first time… I can’t stand where the problem comes from.

Now thinking about some kind of WiFi fail… but without any knowledge I don’t know which action i can do; the system is really unusable.

After login in monouser mode and activating the WIFI, I’ve used a pacman reinstall:

$ pacman -Qnq | pacman -S -

It needed Wifi activated, which I do in monouser mode using:

$ nmcli c up [WIFISSID]

The password for the Wifi was stored, and it retrieved correctly.

System keeps having a freeze behaviour: keyboard and mouse without response, and only on/off button works.

It seems that 5.15 is UNSTABLE KERNEL for me, at least with my packages… but I’ve not found a specific process involved: I’ve deactivated my NTFS data specific fstab line, but indeed kernel mounts automatically some windows partitions; system always freeze with an existing graphic terminal, even if no login done and another TTY (text mode) has been opened, but never observed on single-user text mode.

I’ve come back to 5.10 LTS

Hey, what is the output of free -h after login?
And journalctl -k --priority err?

[Manjaro (5.15) frozes 6' after login]

Well, cross-posting (or whatever it’s called) isn’t allowed.

  1. Anyway, boot with a live ISO, and open a terminal.
  2. Elevate the terminal privileges to root:
su -

(Enter manjaro for a password if prompted.)

  1. Enter a chroot environment, by entering in the terminal:
manjaro-chroot -a
  1. If successful, update your installation with pamac:
pamac update

(Note: Use pamac and not pacman.)

  1. When done, exit chroot:
  1. Followed by rebooting and hoping for the best.

That is, at the moment, all I can offer you.


Tx, I’ve even done

$ pacman -Qnq | pacman -S -

Finally I’ve downgraded to LTS 5.10

Mem: total: 11Gi used: 979Mi free: 9,4Gi shared: 284Mi buff/cache: 1,1Gi available: 9Gi
Swap: total: 15Gi used: 0B free: 15Gi

[cesc@Pcesc ~]$ journalctl -k --priority err
– Journal begins at Wed 2021-12-01 02:24:15 CET, ends at Fri 2021-12-24 13:53:>
– No entries –

Tip: When pasting terminal output on Discourse forums, one can either…

  • Use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):

    type or paste code here

  • Use HTML:

    type or paste code here

I’ve done it for you this time, you had two backticks instead of three. :wink:

1 Like

Even after downgrading the system freezes, with no information logged about; it seems a kernel crash.

Trying multiple options, I’ve seen that it is the WiFi driver (rtl8821ce) which causes the malfunction. Disabling it and using a UTP cable the system works perfectly, but activating the Wi-Fi it automatically freezes. Unfortunately it happens on any kernel, even after downgrading it; it was working before upgrade, but it has stopped to work.

I’ve tried to uninstall any packages from AUR; I’ve seen some applications were from AUR repositories, but they remain installed (my specific software is only Intellij community, MySqlWokbench and postgres pgAdmin),

I’ve also tried to reinstall the driver, using:

yay -Sy rtl8821ce-dkms-git

But it made no difference… or may be I’ve got a worse result (automatically freezes as I open a URL in Firefox).