Manjaro 21 running so slow


i’ve installed manjaro 21 xfce on an external 5200rpm hdd connected to a computer running windows 10 using usb and it’s running very slow. booting takes minutes to complete, as does clicking apps. sometimes connectivity (wi-fi) isn’t available in the network icon on the taskbar.

here’s my partition:

    /dev/sdc1  500M   EFI System (/boot, fat32)
    /dev/sdc2  2G     Linux swap
    /dev/sdc3  30G    Linux filesystem (/)
    /dev/sdc4  70.1G  Linux filesystem (/home)
    /dev/sdc5  195.5G Microsoft basic data (ntfs)

been using the same setup (docked hard disk, connected with usb) to a laptop since manjaro 17 without problem (albeit it always ran out of ram).

is there anything i can do to fix it? thanks in advance.

ps: i’m a n00b so plz be nice to me, and my english is not too good :slight_smile:

Then you are not counting as newbie.

If it is running slow now - then you have a configuration issue - and what issue - I haven’t got the foggiest idea.

Hello @godziblu :slight_smile:

Think about it: You ride a bike and manage 10 rpm when you go up the hill and wonder why it’s too slow. Then you look behind and see a column of trailers you’re pulling along and think to yourself, “Aw shucks, I can still do that!”" :upside_down_face:

  1. rotating HDD itself is slow
  2. USB connection is slow
  3. HDD is running 5200rpm which is slow
  4. if the disk is nearly full, then it is also slow

Of course, it is also necessary to mention the services that you start when you go uphill.

Throw off a little ballast and you’ll be faster. :slight_smile:

1 Like

okay, thanks. but this only happens with manjaro 21 as i said, probably i’m not doing it right :slight_smile:

here’s systemd-analyze blame:

1min 23.669s pamac-mirrorlist.service                                          >
      9.020s lvm2-monitor.service                                              >
      8.696s dev-sdc3.device                                                   >
      5.642s systemd-journal-flush.service                                     >
      2.583s polkit.service                                                    >
      1.777s lightdm.service                                                   >
      1.717s ufw.service                                                       >
      1.631s apparmor.service                                                  >
      1.467s avahi-daemon.service                                              >
      1.460s NetworkManager.service                                            >
      1.357s systemd-udevd.service                                             >
      1.324s ModemManager.service                                              >
      1.298s systemd-logind.service                                            >
       995ms tlp.service                                                       >
       749ms accounts-daemon.service                                           >
       635ms udisks2.service                                                   >
       606ms systemd-tmpfiles-setup-dev.service                                >
       597ms upower.service                                                    >
       535ms wpa_supplicant.service                                            >
       469ms modprobe@drm.service                                              >
       439ms systemd-fsck@dev-disk-by\x2duuid-63C4\x2d4B5D.service             >
       298ms systemd-fsck@dev-disk-by\x2duuid-f352de9b\x2d076a\x2d4355\x2d9741\>
       296ms systemd-udev-trigger.service                                      >
       267ms systemd-modules-load.service                                      >
       253ms systemd-random-seed.service                                       >
       222ms modprobe@fuse.service                                             >
       193ms kmod-static-nodes.service                                         >
       192ms modprobe@configfs.service                                         >
       189ms systemd-tmpfiles-setup.service                                    >
       187ms colord.service                                                    >
       180ms systemd-sysctl.service                                            >
       176ms linux-module-cleanup.service                                      >
       168ms dev-hugepages.mount                                               >
       168ms dev-mqueue.mount                                                  >
       167ms sys-kernel-debug.mount                                            >
       166ms sys-kernel-tracing.mount                                          >
       165ms systemd-journald.service                                          >
       157ms systemd-rfkill.service                                            >
       139ms user@1000.service                                                 >
       135ms dev-sdc2.swap                                                     >
       118ms boot-efi.mount                                                    >
        96ms systemd-remount-fs.service                                        >
        89ms pamac-cleancache.service                                          >
        88ms home.mount                                                        >
        83ms systemd-tmpfiles-clean.service                                    >
        51ms systemd-update-utmp.service                                       >
        49ms systemd-user-sessions.service                                     >
        46ms NetworkManager-wait-online.service                                >
        30ms sys-kernel-config.mount                                           >
        14ms rtkit-daemon.service                                              >
        10ms user-runtime-dir@1000.service                                     >
         3ms tmp.mount                                                         >
         1ms sys-fs-fuse-connections.mount                                     >

that’s just boot time. windows on the same computer boots in a jiffy (obviously, duh)

@linux-aarhus a n00b as n00b does, dear sir :slight_smile:


This starts only one time per week. Sure you can disable the timer if needed.

sudo systemctl disable --now pamac-mirrorlist.timer

But you will need to do it yourself from time to time.

This can be masked and disabled, since you don’t use lvm.

sudo systemctl disable --now lvm2-monitor.service
sudo systemctl mask lvm2-monitor.service

I guess windows uses “fastboot”, something like half-hibernation, or?

You should check your swap and swappiness settings.

In any case - running almost any Linux on an USB enclosure with - by today’s standards - a slow (5400rpm) spinning disk - will create bottlenecks.

latest batch updates (april 11) took care the problem.

sorry it took time to reply cause i have to make sure. thank you all for your help.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.