Manjaro 20.1 - Huawei Matebook D15 - Fingerprint Scanner issue

Hello Guys,

I am using a brand new Huawei Matebook D15 laptop. I have installed Manjaro 20.1 alongside Windows 10 (dual boot). Everything looking good so far except fingerprint scanner. This laptop has a fingerprint scanner which also works as Power Button.
Linux can detect it as below with lsusb command:

Bus 001 Device 003: ID 27c6:5110 Shenzhen Goodix Technology Co.,Ltd.

But I can’t use it under Manjaro! I have installed fingerprint-gui AUR package: GitHub - RogueScholar/fingerprint-gui: Use fingerprint readers with a Linux desktop environment

But It’s saying No device found

How to use this fingerprint scanner to authenticate/login into Manjaro?

The fingerprint reader on my notebook was also not recognized by fingerprint-gui, try using fprint in terminal, I’m pretty sure it will work for you. :wink:

I tried fprintd in terminal as well as you said, no luck :frowning:

    $ fprintd-enroll

    list_devices failed: No devices available

it seems the fingerprint device not recognized at all! it’s from Goodix

It seems I was too optimistic. I tried googling the ID of your FP reader and so far it seems it’s not yet supported under Linux, unfortunately… :disappointed:

1 Like

tough luck :frowning:
so I am stuck with traditional password method…

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.